Black screen at login

Bug #823621 reported by Sworddragon
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
lxdm (Ubuntu)
Undecided
Julien Lavergne

Bug Description

I'm using Ubuntu 11.10 dev with lxdm 0.4.0-0ubuntu1. If X starts and want to switch to the login screen the screen is just black. The solution is to downgrade LXDM to version 0.3.0 or to use another login manager like GDM.

Related branches

Revision history for this message
Stenten (stenten) wrote :

Hello,

I'm going to ask you to upload some log files to help diagnose this bug. Please reinstall lxdm 0.4.0 and reboot into it, triggering the bug. Then downgrade back to 0.3.0 (or however you recover the system) and copy some log files to your home directory using the following commands:

cat /var/log/Xorg.0.log > Xorg.0.log.txt
cat /var/log/Xorg.0.log.old > Xorg.0.log.old.txt
cat /var/log/kern.log > kern.log.txt
sudo cat /var/log/lxdm.log > lxdm.log.txt
sudo cat /var/log/lxdm.log.old > lxdm.log.old.txt
lspci -vvnn > lspci.txt
cat /etc/lxdm/default.conf > default.conf.txt

Then upload all of these files to this bug report. (Their names are the string after ">" in the above commands.)

Changed in lxdm (Ubuntu):
status: New → Incomplete
Revision history for this message
Sworddragon (sworddragon-deactivatedaccount) wrote :

I have made a look at the log files but were wasn't something interesting. But I have figured out why this bug happens. lxdm 0.4.0-0ubuntu1 installs a new version of /etc/lxdm/lxdm.conf with the entry "greeter=/usr/libexec/lxdm-greeter-gtk". But the file doesn't exist on my system. I have replace the line with "greeter=/usr/lib/lxdm/lxdm-greeter-gtk" (from lxdm 0.3.0) and now all is wotking fine.

I'm using a minimalistic system with no unnecessary packages. For example I install all packages with --no-install-recommends. Maybe there is a package in the dependencies missing. First I tried "dpkg -S lxdm-greeter-gtk" and got:

lxdm: /usr/lib/lxdm/lxdm-greeter-gtk
lxdm: /usr/share/man/man1/lxdm-greeter-gtk.1.gz

Then I installed apt-file and updated the lists. "apt-file search lxdm-greeter-gtk" has shown me:

lxdm: /usr/lib/lxdm/lxdm-greeter-gtk
lxdm: /usr/share/man/man1/lxdm-greeter-gtk.1.gz

I can't find any package with the file /usr/libexec/lxdm-greeter-gtk. A solution is to change the path in /etc/lxdm/lxdm.conf to the old one.

Revision history for this message
Stenten (stenten) wrote :

It looks like you just overwrote lxdm.conf during the upgrade with the defaults from upstream LXDM, instead of those from Lubuntu. There should have been a warning message saying that there were two different versions of that script, and which one you'd rather use, the current one or the package maintainer's version. It looks like you just chose the latter.

Changed in lxdm (Ubuntu):
status: Incomplete → Invalid
Revision history for this message
Sworddragon (sworddragon-deactivatedaccount) wrote :

I haven't installed my system from a Lubuntu image. But it doesn't change that the configuration file of the upstream package isn't good and should be fixed.

Changed in lxdm (Ubuntu):
status: Invalid → New
Revision history for this message
Stenten (stenten) wrote :

Check LXDM's man page. Lubuntu doesn't use /etc/lxdm/lxdm.conf as its configuration file. The fact that yours does and that this bug isn't reproducible suggests that it's a result of a configuration error, not a bug.

Now, you say you didn't install your system from a Lubuntu image. How did you install it? It might be that there's a bug in the method you used to install Lubuntu that doesn't appear on a conventional Lubuntu install from a disk.

Revision history for this message
Sworddragon (sworddragon-deactivatedaccount) wrote :

I have already said all related information. As you can see from the startpost I'm using lxdm 0.4.0-0ubuntu1. This means it is from the package manager and it has the file /etc/lxdm/lxdm.conf.

Revision history for this message
Sworddragon (sworddragon-deactivatedaccount) wrote :

Edit: I have made a look to the definition "upstream". I thought it means the official package archive but it doesn't. The package was just installed with apt.

Revision history for this message
Stenten (stenten) wrote :

I'm confused. So you're saying that you installed Ubuntu, not Lubuntu, and then installed LXDM, and that it resulted in an error?

Revision history for this message
Sworddragon (sworddragon-deactivatedaccount) wrote :

This is correct. The file /etc/lxdm/lxdm.conf in the package lxdm 0.4.0-0ubuntu1 from the official repository just contains a bad line (or there is a dependency missing).

Julien Lavergne (gilir)
Changed in lxdm (Ubuntu):
status: New → In Progress
assignee: nobody → Julien Lavergne (gilir)
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lxdm - 0.4.1-0ubuntu1

---------------
lxdm (0.4.1-0ubuntu1) oneiric; urgency=low

  * New upstream bugfix release.
  * debian/patches:
   - 21_fix_greeter_location.patch: Fix location of the greeter in the
     configuration file. (LP: #823621)
 -- Julien Lavergne <email address hidden> Fri, 19 Aug 2011 14:38:55 +0200

Changed in lxdm (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers