lxdm 0.2.0-0ubuntu3.2 wants to remove ubuntu-desktop

Bug #709531 reported by Stenten
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
lxdm (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: lxdm

This is on Ubuntu Maverick which I then installed lubuntu-desktop alongside.

$ sudo apt-get install lxdm
Reading package lists... Done
Building dependency tree
Reading state information... Done
Recommended packages:
  lxde-common locales-all
The following packages will be REMOVED:
  libpam-ck-connector ubuntu-desktop
The following packages will be upgraded:
  lxdm
1 upgraded, 0 newly installed, 2 to remove and 0 not upgraded.
Need to get 83.2kB of archives.
After this operation, 164kB disk space will be freed.
Do you want to continue [Y/n]?

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: lxdm 0.2.0-0ubuntu3.1
ProcVersionSignature: Ubuntu 2.6.37-graphics2+12.26~maverick-generic 2.6.37
Uname: Linux 2.6.37-graphics2+12-generic i686
Architecture: i386
Date: Fri Jan 28 17:24:33 2011
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release Candidate i386 (20100928)
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: lxdm

Related branches

Revision history for this message
Stenten (stenten) wrote :
Revision history for this message
Andrey Bondarenko (abone) wrote :

This bug was introduced in ldxm version 0.2.0-0ubuntu3.2, which added conflict with libpam-ck-connector as a workarround for #576073. Now lubuntu-desktop is not compatible with all the other desktop meta packages. You can't install any other -desktop if you have lubuntu-desktop installed:

aptitude search ~Dlibpam-ck-connect

kubuntu-desktop - Kubuntu Plasma Desktop system
kubuntu-mobile - Kubuntu Plasma Mobile system
libpam-foreground - transitional dummy package which can be sa
ubuntu-desktop - The Ubuntu desktop system
ubuntu-netbook - The Ubuntu Netbook system
ubuntu-sugar-remix - The Ubuntu Sugar Remix system
ubuntustudio-desktop - Ubuntu Studio Desktop Package
xubuntu-desktop - Xubuntu desktop system

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lxdm - 0.3.0-0ubuntu3

---------------
lxdm (0.3.0-0ubuntu3) natty; urgency=low

  * debian/patches/
   - 80_translations.patch: Update translations from upstream git (2011-02-14)
  * debian/lxdm.pam:
   - Add @include common-session-noninteractive instead of
     @include common-session to disable consolekit pam support, already in lxdm
     (LP: #576073).
  * debian/control:
   - Drop libpam-ck-connector conflicts, since the support is disabled in the
     pam file (LP: #709531).
 -- Julien Lavergne <email address hidden> Mon, 28 Feb 2011 00:17:20 +0100

Changed in lxdm (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers