Xsession unable to boot after fresh install Maverick

Bug #660260 reported by Jared Norris on 2010-10-14
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
lxdm (Ubuntu)
Medium
Unassigned

Bug Description

After a fresh install of Lubuntu 10.10 I was presented with an Xsession error. The only changes I made from a completely fresh install was to make the installation try to autologin and to use an existing /home directory.

When booting up the first time after the installation I was presented with the error reading:

xsession: unable to launch "gnome-session" X session: X session not found, falling back to default session

If I clicked the "OK" button it would drop me into some version of X where I had access to nothing but a blank screen with a cursor and I had to reset the power to the machine to get it back.

To workaround this I booted into rescue mode and went to command prompt. From there I went into /etc/xdg/lubuntu/lxdm/lxdm.conf and removed the autologin line. When I rebooted this then brought up the normal login screen. I then had to change the session from "Default" to "Lubuntu". After doing this it just worked as normal and continued to do so after a couple of reboots.

It would seem it was defaulting to try and use gnome for some reason somewhere instead of going to lxde as it should have.

I apologise if this report is incomplete I have not reported many bugs before. Please leave comments of anything else you want me to add.

Julien Lavergne (gilir) on 2010-12-10
affects: lubuntu-meta (Ubuntu) → lxdm (Ubuntu)
Julien Lavergne (gilir) wrote :

Thank you for your bug report. Could you attached the files /etc/xdg/lubuntu/lxdm/lxdm.conf, /etc/lxdm/lxdm.conf and /etc/lxdm/default.conf to this bug report ? It seems that it tried to launch an Openbox-Gnome session, which is impossible if you don't have gnome-session installed. But, by default, it should fallback to LXDE session.

Changed in lxdm (Ubuntu):
status: New → Incomplete
importance: Undecided → Medium
Jared Norris (jarednorris) wrote :
Jared Norris (jarednorris) wrote :
Jared Norris (jarednorris) wrote :
Jared Norris (jarednorris) wrote :

I'm not sure if these have been modified since the issue existed sorry but they are what is currently on my system. The error is no longer present due the workaround described above. If you want anything else please let me know.

Julien Lavergne (gilir) wrote :

As discuss on IRC, closing it until we can reproduce it.

Changed in lxdm (Ubuntu):
status: Incomplete → Invalid
Łukasz Klich (klich-lukasz) wrote :

I can reproduce this bug. Same story, I've got fresh install lubuntu, old home and xsession error about gnome-session.

Łukasz Klich (klich-lukasz) wrote :
Łukasz Klich (klich-lukasz) wrote :
Jared Norris (jarednorris) wrote :

It would appear the common factor is reusing a previous /home folder? Is there any information we can give to help out with this? I have reopened the bug by marking it as confirmed now that it can be reproduced.

Changed in lxdm (Ubuntu):
status: Invalid → Confirmed
Łukasz Klich (klich-lukasz) wrote :

I created new user, and set him to autologin. It works like a charm, so it definitely old /home problem

Jonathan Marsden (jmarsden) wrote :

If someone who can duplicate the issue has time, they can start renaming dotfiles (such as ~/.dmrc ) and also use diff to compare the files in the affected user's $HOME with those in a freshly created user account $HOME to see what the differences are.

ls -ld ~/.[0-9a-zA-Z]*

should display the set of files and directories of interest. Don't upload anything private (like ~/.ssh or ~/.gnupg contents!) here, but maybe

  tar zcvf ~/dotconfig.tar.gz ~/.config

and then uploading dotconfig.tar.gz might be worth doing?

The same goes for .gconf* and .gnome* stuff, I suspect.

I'm not enough of a GUI/X/window manager/DE person to know which files in $HOME are the likely culprits, but hopefully the above is a start.

Julien Lavergne (gilir) wrote :

At least for the beginning, the files beginning by .xsession could help. Thanks :)

Jared Norris (jarednorris) wrote :

I've just scanned my ~/.xsession-errors and the .old file associated with it and neither of them go back far enough to provide any information for 6 months ago. Hopefully Lukasz will have some useful logs.

Another way I thought of testing that I could try if I ever get time would be to set this up in a VM to test reproducibility and also should be able to get some logs.

Łukasz Klich (klich-lukasz) wrote :

Yesterday I was trying to figure out what's wrong with that so I made a copy of all my dotfiles and folders. So I've got two .xsession-errors and .xsession-errors.old. I've looked in there and there's bunch of mpd errors and the rest of errors are probably wiped out, but maybe it will be helpfull.

Łukasz Klich (klich-lukasz) wrote :

I forget that I've got .xsession file also so here it is:

#!/bin/bash
xmodmap /home/kleewho/.xmodmaprc

And that's all

Jared Norris (jarednorris) wrote :

I've just had exactly the same error when I upgraded this machine to Natty last night. I'll attach the same three files to see if anything can help. As per last time if there's anything else I can do to help track down the issue let me know. The workaround is simply just to not select "Default" at the Login Screen but to instead select "Lubuntu" from the dropdown box and it all then works as expected.

Jared Norris (jarednorris) wrote :
Jared Norris (jarednorris) wrote :
Jared Norris (jarednorris) wrote :

Sorry, forget to edit them to show where they all came from, the first is /etc/xdg/lubuntu/lxdm/lxdm.conf the second is /etc/lxdm/lxdm.conf and the third is /etc/lxdm/default.conf

Haydn Trigg (haydn-trigg) wrote :

I've had the same error by installing ubuntu server, then lxde/lxdm, then attempting to autologin to the account set up during the server install. Here's my xsession-errors file, the one similarity that I spotted was a "polkit-gnome-1-WARNING"

Dmitry Diskin (diskin) wrote :

I got the same error with fresh install of Lubuntu, autologin enabled, and installed lightdm. When I switched back to lxdm I got the error. Removing ~/.dmrc solved it.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers