lubuntu cannot start programs if home-folder encryption is active

Bug #554583 reported by k4rsten on 2010-04-03
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
lubuntu-meta (Ubuntu)
Undecided
Unassigned
Nominated for Lucid by k4rsten
lxdm (Ubuntu)
Medium
Unassigned
Nominated for Lucid by k4rsten

Bug Description

Binary package hint: lubuntu-desktop

When I install lubuntu (own distribution or meta-package 'lubuntu') i can't start any programs when the encryption for my home-folder is active.

when i click on the icons, nothing happens.
when i run in terminal the 'firefox' command:

karsten@karsten-laptop:~$ firefox
Benutzerspezifisches GNOME-Konfigurationsverzeichnis »/home/karsten/.gnome2_private/« konnte nicht angelegt werden: Permission denied
karsten@karsten-laptop:~$

Related branches

Julien Lavergne (gilir) wrote :

It's actually a "missing feature" in lxdm, not able to unlock encrypted home.

Changed in lxdm (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
Changed in lubuntu-meta (Ubuntu):
status: New → Invalid
Julien Lavergne (gilir) wrote :
Changed in lxdm (Ubuntu):
status: Confirmed → Triaged
Changed in lnr:
status: New → Invalid

Is this related to lxdm/PAM?
If this is the case, then we need yet another thing to fix.
If it's not and the cause is unknown, I'd suggest turn encryption off
in the installer for 10.04.
BTW, we also need to either make autologin work or remove this option
from installer.

Any thoughts and how to do this?

On Sat, Apr 3, 2010 at 10:25 PM, k4rsten <email address hidden> wrote:
> ** Also affects: lnr
>   Importance: Undecided
>       Status: New
>
> --
> lubuntu cannot start programs if home-folder encryption is active
> https://bugs.launchpad.net/bugs/554583
> You received this bug notification because you are a member of Lubuntu,
> which is the registrant for Lubuntu Netbook Remix.
>
> Status in Lubuntu Netbook Remix: New
> Status in “lubuntu-meta” package in Ubuntu: New
> Status in “lxdm” package in Ubuntu: New
>
> Bug description:
> Binary package hint: lubuntu-desktop
>
> When I install lubuntu (own distribution or meta-package 'lubuntu') i can't start any programs when the encryption for my home-folder is active.
>
> when i click on the icons, nothing happens.
> when i run in terminal the 'firefox' command:
>
> karsten@karsten-laptop:~$ firefox
> Benutzerspezifisches GNOME-Konfigurationsverzeichnis »/home/karsten/.gnome2_private/« konnte nicht angelegt werden: Permission denied
> karsten@karsten-laptop:~$
>
>
>
> _______________________________________________
> Mailing list: https://launchpad.net/~lubuntu-desktop
> Post to     : <email address hidden>
> Unsubscribe : https://launchpad.net/~lubuntu-desktop
> More help   : https://help.launchpad.net/ListHelp
>

Autologin works in the installer, just need to include the patch.
Encryption never work for me with lxdm, I don't think it's linked to the
pam problem.

Le samedi 03 avril 2010 à 22:39 +0800, PCMan a écrit :
> Is this related to lxdm/PAM?
> If this is the case, then we need yet another thing to fix.
> If it's not and the cause is unknown, I'd suggest turn encryption off
> in the installer for 10.04.
> BTW, we also need to either make autologin work or remove this option
> from installer.
>
> Any thoughts and how to do this?
>
> On Sat, Apr 3, 2010 at 10:25 PM, k4rsten <email address hidden> wrote:
> > ** Also affects: lnr
> > Importance: Undecided
> > Status: New
> >
> > --
> > lubuntu cannot start programs if home-folder encryption is active
> > https://bugs.launchpad.net/bugs/554583
> > You received this bug notification because you are a member of Lubuntu,
> > which is the registrant for Lubuntu Netbook Remix.
> >
> > Status in Lubuntu Netbook Remix: New
> > Status in “lubuntu-meta” package in Ubuntu: New
> > Status in “lxdm” package in Ubuntu: New
> >
> > Bug description:
> > Binary package hint: lubuntu-desktop
> >
> > When I install lubuntu (own distribution or meta-package 'lubuntu') i can't start any programs when the encryption for my home-folder is active.
> >
> > when i click on the icons, nothing happens.
> > when i run in terminal the 'firefox' command:
> >
> > karsten@karsten-laptop:~$ firefox
> > Benutzerspezifisches GNOME-Konfigurationsverzeichnis »/home/karsten/.gnome2_private/« konnte nicht angelegt werden: Permission denied
> > karsten@karsten-laptop:~$
> >
> >
> >
> > _______________________________________________
> > Mailing list: https://launchpad.net/~lubuntu-desktop
> > Post to : <email address hidden>
> > Unsubscribe : https://launchpad.net/~lubuntu-desktop
> > More help : https://help.launchpad.net/ListHelp
> >
>
> _______________________________________________
> Mailing list: https://launchpad.net/~lubuntu-desktop
> Post to : <email address hidden>
> Unsubscribe : https://launchpad.net/~lubuntu-desktop
> More help : https://help.launchpad.net/ListHelp

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lxdm - 0.2.0~svn2307+git20100408-0ubuntu1

---------------
lxdm (0.2.0~svn2307+git20100408-0ubuntu1) lucid; urgency=low

  * New upstream snapshot (735dbe5727f)
   - Fix PAM support (LP: #550551)
   - Fix use of encrypted partition (LP: #554583)
  * debian/patches:
   - 11-use-desktop-session.patch: Refresh to only add startlubuntu for Lubuntu
     session.
   - 15-path-replace.patch: Refresh.
   - 17-last-session.patch: restore last session behavior (LP: #561377)
   - 20-stderr_stdout_to_log.patch: Refresh.
  * Update PAM file with current gdm one.
  * debian/lxdm.1 & debian/manpages: Add a man page based the one from Sidux
    (LP: #516703)
 -- Julien Lavergne <email address hidden> Tue, 13 Apr 2010 01:25:35 +0200

Changed in lxdm (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.