support old GDM themes

Bug #516815 reported by Martin-Éric Racine on 2010-02-03
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
LXDE
Unknown
Unknown
lxdm (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: lxdm

Mostly a wishlist item for upstream.

Seeing how GDM has become a completely GNOME-specific item and how it no longer supports the gdm-greeter themes, one desirable feature for LXDM would be to support themes created for GDM up to version 2.20. This would imply supporting the XML format for the theme layout description and SVG images for the background, with SVG or PNG icons for the menu descriptors.

ProblemType: Bug
Architecture: i386
Date: Thu Feb 4 01:13:49 2010
DistroRelease: Ubuntu 10.04
Package: lxdm 0.2.0~svn2307-0ubuntu1
ProcEnviron:
 LANGUAGE=fi_FI:fi:en_US:en
 PATH=(custom, user)
 LANG=fi_FI.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-10.14+bug396286v2-generic
SourcePackage: lxdm
Uname: Linux 2.6.32-10-generic i586

Martin-Éric Racine (q-funk) wrote :
Julien Lavergne (gilir) wrote :

Not sure it should be a priority, it's not the goal of LXDM to add the GDM backward compatibility.

Changed in lxdm (Ubuntu):
importance: Undecided → Wishlist
Martin-Éric Racine (q-funk) wrote :

Understood. It's just that adopting the old theme engine's XML files would instantly grant LXDM access to hundreds of existing themes, which would be a very thing at a time when GDM has been rewritten, rendering existing themes completely useless.

Julien Lavergne (gilir) wrote :

Yes, but it'll certainly add some weight to it :)

Julien Lavergne (gilir) wrote :

Forwarded upstream.

Changed in lxdm (Ubuntu):
status: New → Triaged
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.