$PATH is wrong

Bug #1465634 reported by Sworddragon on 2015-06-16
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
lxdm (Ubuntu)
Undecided
Unassigned

Bug Description

I'm using Ubuntu 15.10 dev and I'm noticing that I'm getting an unexpected $PATH on a terminal with my user:

sworddragon@ubuntu:~$ echo $PATH
/bin:/usr/bin:/sbin:/usr/sbin

On the console all is fine and for root on the console and a terminal all is fine too. /etc/environment contains "PATH="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games"" and I couldn't figure out why only my user on a terminal gets the wrong path.

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1465634/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
yuehan (nae-ioan) wrote :

Thank you for taking the time to report this issue and helping to make Ubuntu better. Examining the information you have given us, this does not appear to be a bug report so we are closing it and converting it to a question in the support tracker. We understand the difficulties you are facing, but it is better to raise problems you are having in the support tracker at https://answers.launchpad.net/ubuntu if you are uncertain if they are bugs. You can also find help with your problem in the support forum of your local Ubuntu community http://loco.ubuntu.com/ or asking at http://askubuntu.com or http://ubuntuforums.org. For help on reporting bugs, see https://help.ubuntu.com/community/ReportingBugs.

Changed in ubuntu:
status: New → Invalid
Sworddragon (sworddragon) wrote :

I have already looked for information and tried various things to solve this issue. Maybe it is not a bug but from the many reports I have already made and the user-defined setup I'm running I would not be surprised if I hit again a rare condition.

Changed in ubuntu:
status: Invalid → New
Sworddragon (sworddragon) wrote :

On creating a new user I have noticed the same issue. I have then tested if /etc/environment is being read by adding a testvariable to it. Loging in with my account does not load this variable into the environment but loging in with root does. The permissions for this file are 0644 for root:root. Any idea how to debug this issue?

affects: ubuntu → pam (Ubuntu)
Steve Langasek (vorlon) wrote :

Logging in how? The various login services should all be respecting pam_env, but if one isn't, it's a bug in that specific service.

Changed in pam (Ubuntu):
status: New → Incomplete
Sworddragon (sworddragon) wrote :

This issue appears if I login with LXDM into my LXDE desktop. I'm not sure if this issue comes then from lxdm or lxsession.

Changed in pam (Ubuntu):
status: Incomplete → New
Steve Langasek (vorlon) on 2016-03-18
affects: pam (Ubuntu) → lxdm (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers