lxde package is missing dependecy on lxsession-logout

Bug #1613397 reported by bastafidli on 2016-08-15
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
lxde-common (Ubuntu)
Undecided
Unassigned
lxde-metapackages (Ubuntu)
Undecided
Unassigned
lxsession (Ubuntu)
Undecided
Unassigned

Bug Description

When installing LXDE using instructions provided here
https://help.ubuntu.com/community/Installation/LowMemorySystems?action=login&login=1#LXDE
on ubuntu 16.04 system and then accessing the LXDE session using x2go, the user is unable to logout from the session, because the LXDE Logout dialog never appears.

This is due to missing lxsession-logout command that is referenced from /usr/bin/lxde-logout script.

Once the lxsession-logout command is installed manually using apt-get, the LXDE is able to display the logout dialog and the x2go session is cleaned up correctly.

The proposed solution is for the lxde package to include dependency on lxsession-logout package.

description: updated
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in lxde-metapackages (Ubuntu):
status: New → Confirmed
Jeremy Bicha (jbicha) wrote :

Debian's lxsession 0.5.3-1 just has lxsession depend on lxsession-logout. Since lxde depends on lxde-common which depends on lxsession, that would fix this bug.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in lxsession (Ubuntu):
status: New → Confirmed
LStranger (andrej-rep) wrote :

lxde-common is right package where this issue is fixed now (0.99.2-3)

Changed in lxde-metapackages (Ubuntu):
status: Confirmed → Invalid
Changed in lxsession (Ubuntu):
status: Confirmed → Invalid
Changed in lxde-common (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers