SRU of LXD 2.0.1 (upstream bugfix release)

Bug #1582891 reported by Stéphane Graber on 2016-05-17
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
lxd (Ubuntu)
Undecided
Unassigned
Trusty
Undecided
Stéphane Graber
Xenial
Undecided
Stéphane Graber

Bug Description

LXD upstream released LXC 2.0.1 as a bugfix release with following changelog:
 - Don't fail to start when shmounts can't be mounted, instead fail container startup
 - Invalidate the simplestreams cache on proxy change
 - Write the container's config file on start to the log path directly
 - Fix crash in list due to empty responses (Issue #1903)
 - Fail when removing non-existent profiles (Issue #1886)
 - Document --alias to image import (Issue #1900)
 - Fix "lxc start" and "lxc stop" options (stateful/stateless)
 - Give better error on invalid source stream (simplestreams)
 - Add basic REST API usage example to README.md
 - Fix typo in lxc stop --help
 - Convert lxc-to-lxd to stable supported pylxd API (Issue #1901)
 - Properly log image update failures
 - Better validate and rollback bad images (Issue #1913)
 - Send operation return value through SmartError
 - Fix basic filtering in lxc list (Issue #1917)
 - Tell the user how to launch a container on first start (Issue #1931)
 - Redirect "remote" to "remote:" when not conflicting (Issue #1931)
 - Don't load the LXC config for snapshots (Issue #1935)
 - list: Allow filtering by unset key (Issue #1917)
 - Fix example in lxc launch
 - Update Japanese translation and other po files
 - Fall back to cpuset.cpus on older kernels (Issue #1929)
 - Properly validate the server configuration keys (Issue #1939)
 - Fix daemonConfig handling of storage
 - Don't remove config file on forkmigrate
 - Fix config handling following config validation change
 - Fixed Markdown syntax in documentation
 - Don't fail early when removing disks (Issue #1964)
 - Don't recursively delete devices
 - Don't fail when some unix devices fail to be deleted
 - Use the same config checks for unix-char and unix-block
 - Allow removing when fs object no longer exists (Issue #1967)
 - Do proper logfile expiry (Issue #1966)
 - Make logging a bit more consistent
 - Don't ignore zfs errors
 - Properly update the mode, uid and gid on existing files (Issue #1975)
 - Detect invalid certificate files (Issue #1977)
 - Fix broken apparmor status check
 - Allow on/off as boolean strings
 - Properly validate the container configuration keys (Issue #1940)
 - Don't mask rsync transfer errors
 - Move execPath to a global variable
 - Use custom netcat instead of nc -U for rsync over websocket (Issue #1944)
 - Fix wrong state dir path in migration
 - Don't fail deleting images when the storage delete fails
 - Improve messages in the Japanese translation
 - Add more checks for the criu binary
 - Rework (live) migration tests
 - Make it explicit in documentation that devices on create are optional
 - Properly record the source of all image copies (Issue #2010)
 - Don't mark containers as ERROR while being created (Issue #1988)
 - Cleanup events sent for operations (Issue #1992)
 - Fix ZFS refcounting issues (Issue #1916 and Issue #2013)
 - Propagate snapshot config when copying a snapshot (Issue #2017)
 - Implement lxc config show for snapshots
 - Add Unix socket example to REST API usage.

Just like Ubuntu itself, upstream releases long term support releases, as is 2.0 and then periodic point releases including all the accumulated bugfixes.

Only the latest upstream release gets full support from the upstream developers, everyone else is expected to first update to it before receiving any kind of support.

This bugfix release has already been uploaded to Yakkety and automatically backported in the upstream PPAs for all Ubuntu releases. So far without any reported regression.

This should qualify under the minor upstream bugfix release allowance of the SRU policy, letting us SRU this without paperwork for every single change included in this upstream release.

Once the SRU hits -updates, we will be backporting this to trusty-backports as well, making sure we have the same version everywhere.

Changed in lxd (Ubuntu):
status: New → Fix Released
Changed in lxd (Ubuntu Trusty):
status: New → Triaged
Changed in lxd (Ubuntu Xenial):
status: New → In Progress
Changed in lxd (Ubuntu Trusty):
assignee: nobody → Stéphane Graber (stgraber)
Changed in lxd (Ubuntu Xenial):
assignee: nobody → Stéphane Graber (stgraber)
Stéphane Graber (stgraber) wrote :

Uploaded to the queue.

Hello Stéphane, or anyone else affected,

Accepted lxd into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/lxd/2.0.1-0ubuntu1~16.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in lxd (Ubuntu Xenial):
status: In Progress → Fix Committed
tags: added: verification-needed
Stéphane Graber (stgraber) wrote :

I've been running this in production over the past few days without seeing any problem (running a bit under 12000 containers).

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :
Download full text (3.3 KiB)

This bug was fixed in the package lxd - 2.0.1-0ubuntu1~16.04.1

---------------
lxd (2.0.1-0ubuntu1~16.04.1) xenial; urgency=medium

  * New upstream bugfix release (2.0.1) (LP: #1582891)
    - Don't fail to start when shmounts can't be mounted, instead fail
      container startup
    - Invalidate the simplestreams cache on proxy change
    - Write the container's config file on start to the log path directly
    - Fix crash in list due to empty responses (Issue #1903)
    - Fail when removing non-existent profiles (Issue #1886)
    - Document --alias to image import (Issue #1900)
    - Fix "lxc start" and "lxc stop" options (stateful/stateless)
    - Give better error on invalid source stream (simplestreams)
    - Add basic REST API usage example to README.md
    - Fix typo in lxc stop --help
    - Convert lxc-to-lxd to stable supported pylxd API (Issue #1901)
    - Properly log image update failures
    - Better validate and rollback bad images (Issue #1913)
    - Send operation return value through SmartError
    - Fix basic filtering in lxc list (Issue #1917)
    - Tell the user how to launch a container on first start (Issue #1931)
    - Redirect "remote" to "remote:" when not conflicting (Issue #1931)
    - Don't load the LXC config for snapshots (Issue #1935)
    - list: Allow filtering by unset key (Issue #1917)
    - Fix example in lxc launch
    - Update Japanese translation and other po files
    - Fall back to cpuset.cpus on older kernels (Issue #1929)
    - Properly validate the server configuration keys (Issue #1939)
    - Fix daemonConfig handling of storage
    - Don't remove config file on forkmigrate
    - Fix config handling following config validation change
    - Fixed Markdown syntax in documentation
    - Don't fail early when removing disks (Issue #1964)
    - Don't recursively delete devices
    - Don't fail when some unix devices fail to be deleted
    - Use the same config checks for unix-char and unix-block
    - Allow removing when fs object no longer exists (Issue #1967)
    - Do proper logfile expiry (Issue #1966)
    - Make logging a bit more consistent
    - Don't ignore zfs errors
    - Properly update the mode, uid and gid on existing files (Issue #1975)
    - Detect invalid certificate files (Issue #1977)
    - Fix broken apparmor status check
    - Allow on/off as boolean strings
    - Properly validate the container configuration keys (Issue #1940)
    - Don't mask rsync transfer errors
    - Move execPath to a global variable
    - Use custom netcat instead of nc -U for rsync over websocket (Issue #1944)
    - Fix wrong state dir path in migration
    - Don't fail deleting images when the storage delete fails
    - Improve messages in the Japanese translation
    - Add more checks for the criu binary
    - Rework (live) migration tests
    - Make it explicit in documentation that devices on create are optional
    - Properly record the source of all image copies (Issue #2010)
    - Don't mark containers as ERROR while being created (Issue #1988)
    - Cleanup events sent for operations (Issue #1992)
    - Fix ZFS refcounting issues (Issue #1916 and Issue #2013)
    - Propagate snapshot config when copyi...

Read more...

Changed in lxd (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for lxd has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Changed in lxd (Ubuntu Trusty):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers