IPv4/6 setup debconf questions default to "no"

Bug #1567874 reported by Martin Pitt on 2016-04-08
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
lxd (Ubuntu)
Undecided
Unassigned

Bug Description

Thanks for fixing bug 1567440, with today's version this already is a whole lot easier!

I started from a clean minimal VM today without any lxc/lxd packages installed, apt install lxd, and then ran "sudo lxd init" as suggested by the postinst stdout.

A remaining issue from the debconfery is that the "Do you want to set up an IPv[46] subnet" questions default to "No". I'm not sure about IPv6 (I think it's about time to configure all containers with IPv6), but IMHO pretty much everyone wants to do this, so could this default to "true"?

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: lxd 2.0.0~rc9-0ubuntu3
ProcVersionSignature: User Name 4.4.0-17.33-generic 4.4.6
Uname: Linux 4.4.0-17-generic x86_64
ApportVersion: 2.20.1-0ubuntu1
Architecture: amd64
Date: Fri Apr 8 12:26:16 2016
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: lxd
UpgradeStatus: No upgrade log present (probably fresh install)

Martin Pitt (pitti) wrote :
summary: - lxc init / debconf does not actually set up bridge, and IPv4/6 setup
- defaults to "no"
+ IPv4/6 setup debconf questions defaults to "no"
summary: - IPv4/6 setup debconf questions defaults to "no"
+ IPv4/6 setup debconf questions default to "no"
Stéphane Graber (stgraber) wrote :

Hmm, that's odd, I definitely did add logic to pre-select yes in that case :)

Stéphane Graber (stgraber) wrote :

I'll take a look at this in a bit.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lxd - 2.0.0~rc9-0ubuntu4

---------------
lxd (2.0.0~rc9-0ubuntu4) xenial; urgency=medium

  * More lxdbr0 tweaks:
    - Fix logic so that on first "dpkg-reconfigure" run, IPv4 and IPv6
      are actually set to "yes". (LP: #1567874)
    - Add an extra check to the IPv4 and IPv6 subnet generators to
      attempt to ping the usual default gateways on the subnet and use another
      subnet if we get an answer.

 -- Stéphane Graber <email address hidden> Fri, 08 Apr 2016 13:52:46 -0400

Changed in lxd (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers