SRU of LXCFS 2.0.8 (upstream bugfix release)

Bug #1727373 reported by Stéphane Graber on 2017-10-25
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
lxcfs (Ubuntu)
Undecided
Unassigned
Trusty
Undecided
Unassigned
Xenial
Undecided
Unassigned
Zesty
Undecided
Unassigned
Artful
Undecided
Unassigned

Bug Description

LXCFS upstream released LXCFS 2.0.8 as a bugfix release with following changelog:
 - bindings: Add mountpoint for unified hierarchy
 - bindings: Calculate uptime via proc//stat
 - bindings: Revert virtualization of 'btime' field due to regressions in ps
 - doc: Update README
 - init: Add cgroupfs-mount to Should-Start/Stop sysvinit LSB headers
 - lib: Add common fallback dlopen for liblxcfs.so
 - lib: Fix the installation directory for liblxcfs to ${libdir}/lxcfs
 - pam: Add a 'all' option for -c
 - pam: Chown cgroup.procs file on unified hierarchy
 - pam: Report back when we find a unified hierarchy
 - tests: Fix invalid comparison
 - uptime: Fix a problem with subsequent reads

Just like Ubuntu itself, upstream releases long term support releases, as is 2.0 and then periodic point releases including all the accumulated bugfixes.

Only the latest upstream release gets full support from the upstream developers, everyone else is expected to first update to it before receiving any kind of support.

This should qualify under the minor upstream bugfix release allowance of the SRU policy, letting us SRU this without paperwork for every single change included in this upstream release.

Once the SRU hits -updates, we will be backporting this to trusty-backports as well, making sure we have the same version everywhere.

Changed in lxcfs (Ubuntu Zesty):
status: New → In Progress
Changed in lxcfs (Ubuntu Xenial):
status: New → In Progress
Changed in lxcfs (Ubuntu Artful):
status: New → In Progress
Stéphane Graber (stgraber) wrote :

For bionic, we'll just sync lxcfs from Debian after I get Debian to update the packaging slightly to deal with us backporting lxcfs all the way down to trusty.

Stéphane Graber (stgraber) wrote :

I uploaded the artful version of this, working on zesty and xenial next.

Changed in lxcfs (Ubuntu):
status: New → Fix Released
Stéphane Graber (stgraber) wrote :

And uploaded bionic, zesty and xenial now.

Brian Murray (brian-murray) wrote :

The bionic upload is stuck in -proposed.

Stéphane Graber (stgraber) wrote :

Yeah, I'll push an hint, the problem is that the lxc tests depend on Ubuntu having a cloud-image for the current series, which isn't currently true for bionic...

Łukasz Zemczak (sil2100) wrote :

I approved the artful SRU but of course LP timed out when the tooling was supposed to update the bug. Doing that manually now - please test the artful-proposed packages.

Changed in lxcfs (Ubuntu Artful):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-artful

Hello Stéphane, or anyone else affected,

Accepted lxcfs into zesty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/lxcfs/2.0.8-0ubuntu1~17.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-zesty to verification-done-zesty. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-zesty. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in lxcfs (Ubuntu Zesty):
status: In Progress → Fix Committed
tags: added: verification-needed-zesty
Łukasz Zemczak (sil2100) wrote :

Hello Stéphane, or anyone else affected,

Accepted lxcfs into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/lxcfs/2.0.8-0ubuntu1~16.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in lxcfs (Ubuntu Xenial):
status: In Progress → Fix Committed
tags: added: verification-needed-xenial
Stéphane Graber (stgraber) wrote :

We got a report of lxcfs restarting rather than reloading with this update, we need to reproduce it to confirm but if that's the case, we'll need a follow-up upload to fix this.

Stéphane Graber (stgraber) wrote :

A fix for this issue has been uploaded to bionic and to the queue for all SRUs.

Brian Murray (brian-murray) wrote :

Hello Stéphane, or anyone else affected,

Accepted lxcfs into artful-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/lxcfs/2.0.8-0ubuntu1~17.10.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-artful to verification-done-artful. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-artful. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Brian Murray (brian-murray) wrote :

Hello Stéphane, or anyone else affected,

Accepted lxcfs into zesty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/lxcfs/2.0.8-0ubuntu1~17.04.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-zesty to verification-done-zesty. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-zesty. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Brian Murray (brian-murray) wrote :

Hello Stéphane, or anyone else affected,

Accepted lxcfs into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/lxcfs/2.0.8-0ubuntu1~16.04.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Stéphane Graber (stgraber) wrote :

Been running LXCFS 2.0.8 on a variety of systems for the past couple of weeks, other than the initial upgrade issue which we fixed, everything looks good.

tags: added: verification-done verification-done-artful verification-done-xenial verification-done-zesty
removed: verification-needed verification-needed-artful verification-needed-xenial verification-needed-zesty
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lxcfs - 2.0.8-0ubuntu1~16.04.2

---------------
lxcfs (2.0.8-0ubuntu1~16.04.2) xenial; urgency=medium

  * Add symlink from /usr/lib/HOST-ARCH/lxcfs to /usr/lib/lxcfs.
    This is needed so that an already running lxcfs daemon can properly
    reload the internal lxcfs library on upgrade.

lxcfs (2.0.8-0ubuntu1~16.04.1) xenial; urgency=medium

  * New upstream bugfix release (2.0.8) (LP: #1727373)
    - bindings: Add mountpoint for unified hierarchy
    - bindings: Calculate uptime via proc//stat
    - bindings: Revert virtualization of 'btime' field due to regressions in ps
    - doc: Update README
    - init: Add cgroupfs-mount to Should-Start/Stop sysvinit LSB headers
    - lib: Add common fallback dlopen for liblxcfs.so
    - lib: Fix the installation directory for liblxcfs to ${libdir}/lxcfs
    - pam: Add a 'all' option for -c
    - pam: Chown cgroup.procs file on unified hierarchy
    - pam: Report back when we find a unified hierarchy
    - tests: Fix invalid comparison
    - uptime: Fix a problem with subsequent reads

 -- Stéphane Graber <email address hidden> Wed, 08 Nov 2017 17:07:44 -0500

Changed in lxcfs (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for lxcfs has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lxcfs - 2.0.8-0ubuntu1~17.04.2

---------------
lxcfs (2.0.8-0ubuntu1~17.04.2) zesty; urgency=medium

  * Add symlink from /usr/lib/HOST-ARCH/lxcfs to /usr/lib/lxcfs.
    This is needed so that an already running lxcfs daemon can properly
    reload the internal lxcfs library on upgrade.

lxcfs (2.0.8-0ubuntu1~17.04.1) zesty; urgency=medium

  * New upstream bugfix release (2.0.8) (LP: #1727373)
    - bindings: Add mountpoint for unified hierarchy
    - bindings: Calculate uptime via proc//stat
    - bindings: Revert virtualization of 'btime' field due to regressions in ps
    - doc: Update README
    - init: Add cgroupfs-mount to Should-Start/Stop sysvinit LSB headers
    - lib: Add common fallback dlopen for liblxcfs.so
    - lib: Fix the installation directory for liblxcfs to ${libdir}/lxcfs
    - pam: Add a 'all' option for -c
    - pam: Chown cgroup.procs file on unified hierarchy
    - pam: Report back when we find a unified hierarchy
    - tests: Fix invalid comparison
    - uptime: Fix a problem with subsequent reads

 -- Stéphane Graber <email address hidden> Wed, 08 Nov 2017 17:05:33 -0500

Changed in lxcfs (Ubuntu Zesty):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lxcfs - 2.0.8-0ubuntu1~17.10.2

---------------
lxcfs (2.0.8-0ubuntu1~17.10.2) artful; urgency=medium

  * Add symlink from /usr/lib/HOST-ARCH/lxcfs to /usr/lib/lxcfs.
    This is needed so that an already running lxcfs daemon can properly
    reload the internal lxcfs library on upgrade.

lxcfs (2.0.8-0ubuntu1~17.10.1) artful; urgency=medium

  * New upstream bugfix release (2.0.8) (LP: #1727373)
    - bindings: Add mountpoint for unified hierarchy
    - bindings: Calculate uptime via proc//stat
    - bindings: Revert virtualization of 'btime' field due to regressions in ps
    - doc: Update README
    - init: Add cgroupfs-mount to Should-Start/Stop sysvinit LSB headers
    - lib: Add common fallback dlopen for liblxcfs.so
    - lib: Fix the installation directory for liblxcfs to ${libdir}/lxcfs
    - pam: Add a 'all' option for -c
    - pam: Chown cgroup.procs file on unified hierarchy
    - pam: Report back when we find a unified hierarchy
    - tests: Fix invalid comparison
    - uptime: Fix a problem with subsequent reads

 -- Stéphane Graber <email address hidden> Wed, 08 Nov 2017 17:03:40 -0500

Changed in lxcfs (Ubuntu Artful):
status: Fix Committed → Fix Released
Changed in lxcfs (Ubuntu Trusty):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers