Newer systemd fails to start due to EINVAL on access to /sys/fs/cgroup/systemd

Bug #1574765 reported by Serge Hallyn on 2016-04-25
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
lxcfs (Ubuntu)
High
Unassigned
Xenial
High
Unassigned

Bug Description

==================================
Test case:
    lxc launch images:debian/jessie/amd64 j1
    lxc exec j1
    sleep 30s; ps -ef
  If you only see 3 tasks, then systemd has failed to properly start. With
  the access(2) patches this should be fixed.
==================================

Two patches from upstream (which are in yakkety) need to be SRUd to wily.

Changed in lxcfs (Ubuntu):
status: New → Fix Released
importance: Undecided → High
description: updated
Changed in lxcfs (Ubuntu Wily):
importance: Undecided → High
Changed in lxcfs (Ubuntu Xenial):
importance: Undecided → High
no longer affects: lxcfs (Ubuntu Wily)

Hello Serge, or anyone else affected,

Accepted lxcfs into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/lxcfs/2.0.0-0ubuntu2.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in lxcfs (Ubuntu Xenial):
status: New → Fix Committed
tags: added: verification-needed
Serge Hallyn (serge-hallyn) wrote :

Confirmed this works for me in xenial.

Two notes on the test case in description: 1. cgroup namespaces must be disabled (in the kernel or in lxc) to reproduce this issue. I'd forgotten about that, and it seems to change the priority of this for xenial. 2. the test case must be done using lxc, not lxd, as lxd doesn't seem to be working right at the moment without cgroup namespaces. So: lxc-create -t download -n j1 -- -d debian -r jessie -a amd64; lxc-start -n j1

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lxcfs - 2.0.0-0ubuntu2.1

---------------
lxcfs (2.0.0-0ubuntu2.1) xenial-proposed; urgency=medium

  * Cherrypick two upstream patches to fix access() returning EINVAL for
    cgroup controller directories, which prevents booting certain systemd
    systems. (LP: #1574765)

 -- Serge Hallyn <email address hidden> Fri, 22 Apr 2016 18:02:18 -0500

Changed in lxcfs (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for lxcfs has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers