syntax error, trusty beta-2 cloud image

Bug #1304167 reported by Dave Cheney on 2014-04-08
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
libvirt (Ubuntu)
High
Unassigned
Trusty
High
Unassigned
lxc (Ubuntu)
High
Unassigned
Trusty
Undecided
Unassigned

Bug Description

IMPACT: libvirt cannot be installed without apparmor
TEST CASE: set up a new VM, apt-get install libvirt-bin; check whether apparmor was installed
REGRESSION POTENTIAL: none, libvirt did not depend on apparmor previously.

sudo apt-get install lxc -y

Setting up lxc (1.0.2-0ubuntu2) ...
AppArmor parser error for /etc/apparmor.d/lxc-containers in /etc/apparmor.d/abstractions/lxc/container-base at line 6: syntax error, unexpected TOK_END_OF_RULE, expecting TOK_MODE
AppArmor parser error for /etc/apparmor.d/usr.bin.lxc-start in /etc/apparmor.d/abstractions/lxc/start-container at line 5: syntax error, unexpected TOK_END_OF_RULE, expecting TOK_MODE
lxc start/running

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in apparmor (Ubuntu):
status: New → Confirmed
affects: apparmor (Ubuntu) → lxc (Ubuntu)
Changed in lxc (Ubuntu):
importance: Undecided → High
status: Confirmed → Triaged
Serge Hallyn (serge-hallyn) wrote :

Equivalent fix pushed for libvirt

Changed in libvirt (Ubuntu):
importance: Undecided → High
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libvirt - 1.2.2-0ubuntu13

---------------
libvirt (1.2.2-0ubuntu13) trusty; urgency=medium

  * Add a dependency on the new apparmor to make sure we have the new
    parser around before we attempt to load a profile requiring the new
    stanza support. (LP: #1304167)
 -- Serge Hallyn <email address hidden> Mon, 14 Apr 2014 11:03:37 -0500

Changed in libvirt (Ubuntu):
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lxc - 1.0.3-0ubuntu3

---------------
lxc (1.0.3-0ubuntu3) trusty; urgency=medium

  * Add a dependency on the new apparmor to make sure we have the new
    parser around before we attempt to load a profile requiring the new
    stanza support. (LP: #1304167)
 -- Stephane Graber <email address hidden> Mon, 14 Apr 2014 10:10:40 -0400

Changed in lxc (Ubuntu):
status: Triaged → Fix Released
Anders Kaseorg (andersk) wrote :

Can you change Depends: apparmor (>= 2.8.95~2430-0ubuntu4) to Conflicts: apparmor (<< 2.8.95~2430-0ubuntu4)? It used to be possible to use libvirt-bin without installing apparmor at all, and now it’s not.

Serge Hallyn (serge-hallyn) wrote :

Thanks, it's too late to do this before release but your request makes sense so I'll try to SRU that asap.

Changed in libvirt (Ubuntu):
status: Fix Released → Confirmed

Thanks for uploading the fix for this bug report to -proposed. However, when reviewing the package in -proposed and the details of this bug report I noticed that the bug description is missing information required for the SRU process. You can find full details at http://wiki.ubuntu.com/StableReleaseUpdates#Procedure but essentially this bug is missing some of the following: a statement of impact, a test case and details regarding the regression potential. Thanks in advance!

description: updated

Hello Dave, or anyone else affected,

Accepted libvirt into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/libvirt/1.2.2-0ubuntu13.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in libvirt (Ubuntu Trusty):
status: New → Triaged
importance: Undecided → High
Changed in libvirt (Ubuntu):
status: Confirmed → Triaged
Changed in libvirt (Ubuntu Trusty):
status: Triaged → Fix Committed
tags: added: verification-needed
Anders Kaseorg (andersk) wrote :

libvirt 1.2.2-0ubuntu13.1 fixes the apparmor dependency and otherwise works for me.

tags: added: verification-done
removed: verification-needed

The verification of the Stable Release Update for libvirt has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libvirt - 1.2.2-0ubuntu13.1

---------------
libvirt (1.2.2-0ubuntu13.1) trusty-proposed; urgency=medium

  * debian/control: change apparmor dependency into an inverse conflicts,
    so that libvirt can continue to be used without apparmor. (LP: #1304167)
 -- Serge Hallyn <email address hidden> Thu, 17 Apr 2014 10:42:08 -0500

Changed in libvirt (Ubuntu Trusty):
status: Fix Committed → Fix Released
Changed in libvirt (Ubuntu):
status: Triaged → Fix Released
Changed in lxc (Ubuntu Trusty):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers