ppc64el enablement for juju/lxc

Bug #1273769 reported by James Page on 2014-01-28
22
This bug affects 2 people
Affects Status Importance Assigned to Milestone
juju-core
Critical
Dave Cheney
cloud-utils (Ubuntu)
High
Unassigned
juju-core (Ubuntu)
High
Unassigned
lxc (Ubuntu)
High
Unassigned

Bug Description

After some initial testing of juju (with local provider) on ppc64el - we need todo some work to fully enable this option.

1) LXC templates need to support ppc64el as a valid container arch
2) ubuntu-cloudimg-query is not avaliable on ppc64el
3) Juju is explicit in its support for x84 and arm - so enablement work is needed here as well.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: lxc 1.0.0~beta3-0ubuntu1
ProcVersionSignature: User Name 3.13.0-2.17-generic 3.13.0-rc7
Uname: Linux 3.13.0-2-generic ppc64le
ApportVersion: 2.13.2-0ubuntu2
Architecture: ppc64el
Date: Tue Jan 28 16:49:03 2014
ProcEnviron:
 TERM=screen-256color-bce
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: lxc
UpgradeStatus: No upgrade log present (probably fresh install)
defaults.conf:
 lxc.network.type = veth
 lxc.network.link = lxcbr0
 lxc.network.flags = up
 lxc.network.hwaddr = 00:16:3e:xx:xx:xx

James Page (james-page) wrote :
Stéphane Graber (stgraber) wrote :

I have sent patches enabling arm64 and ppc64el for both the ubuntu and ubuntu-cloud template, they should be in by the next 1.0 milestone (next week or so).

Stéphane Graber (stgraber) wrote :

(I have obviously no way of testing them, I'm expecting the lxc-ubuntu template to work fine and the lxc-ubuntu-cloud template to fail horribly due to missing images or missing support in ubuntu-cloudimg-query).

Curtis Hovey (sinzui) on 2014-01-28
Changed in juju-core:
status: New → Triaged
importance: Undecided → High
Scott Moser (smoser) wrote :

I just uploaded cloud-utils fix to know about ppc64el
 https://lists.ubuntu.com/archives/trusty-changes/2014-January/008098.html
and put a mail to lxc-devel to fix the 'ubuntu-cloud' template.

Changed in cloud-utils (Ubuntu):
status: New → In Progress
Changed in lxc (Ubuntu):
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cloud-utils - 0.27-0ubuntu6

---------------
cloud-utils (0.27-0ubuntu6) trusty; urgency=medium

  * sync to trunk at revno 254
    * growpart: run partx only on block devices (not files)
    * ubuntu-cloudimg-query: allow 'ppc64el' as input. (LP: #1273769)
    * ubuntu-cloudimg-query, ubuntu-ec2-run: know about trusty
 -- Scott Moser <email address hidden> Wed, 29 Jan 2014 13:44:03 -0500

Changed in cloud-utils (Ubuntu):
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lxc - 1.0.0~beta4-0ubuntu1

---------------
lxc (1.0.0~beta4-0ubuntu1) trusty; urgency=medium

  * New upstream release (1.0.0~beta4). (LP: #1273769)
  * Move uidmap from Depends to Recommends.
  * Drop duplicate python3 cflags (LP: #1272948)
  * Tweak adt to use a proxy server.
 -- Stephane Graber <email address hidden> Thu, 06 Feb 2014 19:32:23 -0500

Changed in lxc (Ubuntu):
status: In Progress → Fix Released
John A Meinel (jameinel) wrote :

Given the statements in bug #1276909 this seems to be a small patch so that we have a regex to recognize the architecture.

It seems the new patch would be something like:
--- juju-core-1.17.2.orig/src/launchpad.net/juju-core/environs/manual/init.go
+++ juju-core-1.17.2/src/launchpad.net/juju-core/environs/manual/init.go
@@ -128,6 +128,7 @@ var archREs = []struct {
  {regexp.MustCompile("amd64|x86_64"), "amd64"},
  {regexp.MustCompile("i[3-9]86"), "i386"},
  {regexp.MustCompile("armv.*"), "arm"},
+ {regexp.MustCompile("ppc64el"), "ppc64el"},
 }

I don't personally have a way to test this, and I don't know the exact strings that we should be using.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in juju-core (Ubuntu):
status: New → Confirmed
Changed in lxc (Ubuntu):
importance: Undecided → High
Changed in juju-core (Ubuntu):
importance: Undecided → High
Changed in cloud-utils (Ubuntu):
importance: Undecided → High
Curtis Hovey (sinzui) on 2014-02-10
Changed in juju-core:
milestone: none → 1.18.0
James Page (james-page) on 2014-02-17
Changed in juju-core (Ubuntu):
status: Confirmed → Triaged

I'm pretty sure the arch changes haven't landed yet, right? (mapping the
values of uname -m to the names we'll be using for the juju
packages/tarballs)

On Mon, Feb 17, 2014 at 10:02 PM, James Page <email address hidden> wrote:

> ** Changed in: juju-core (Ubuntu)
> Status: Confirmed => Triaged
>
> --
> You received this bug notification because you are subscribed to juju-
> core.
> https://bugs.launchpad.net/bugs/1273769
>
> Title:
> ppc64el enablement for juju/lxc
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/juju-core/+bug/1273769/+subscriptions
>

Dave Cheney (dave-cheney) wrote :

Not yet, I had to hack my working copy.

On Tue, Feb 25, 2014 at 8:46 PM, John A Meinel <email address hidden> wrote:
> I'm pretty sure the arch changes haven't landed yet, right? (mapping the
> values of uname -m to the names we'll be using for the juju
> packages/tarballs)
>
>
> On Mon, Feb 17, 2014 at 10:02 PM, James Page <email address hidden>
> wrote:
>
>> ** Changed in: juju-core (Ubuntu)
>> Status: Confirmed => Triaged
>>
>> --
>> You received this bug notification because you are subscribed to juju-
>> core.
>> https://bugs.launchpad.net/bugs/1273769
>>
>> Title:
>> ppc64el enablement for juju/lxc
>>
>> To manage notifications about this bug go to:
>> https://bugs.launchpad.net/juju-core/+bug/1273769/+subscriptions
>>
>
> --
> You received this bug notification because you are subscribed to juju-
> core.
> Matching subscriptions: MOAR JUJU SPAM!
> https://bugs.launchpad.net/bugs/1273769
>
> Title:
> ppc64el enablement for juju/lxc
>
> Status in juju-core:
> Triaged
> Status in "cloud-utils" package in Ubuntu:
> Fix Released
> Status in "juju-core" package in Ubuntu:
> Triaged
> Status in "lxc" package in Ubuntu:
> Fix Released
>
> Bug description:
> After some initial testing of juju (with local provider) on ppc64el -
> we need todo some work to fully enable this option.
>
> 1) LXC templates need to support ppc64el as a valid container arch
> 2) ubuntu-cloudimg-query is not avaliable on ppc64el
> 3) Juju is explicit in its support for x84 and arm - so enablement work is needed here as well.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 14.04
> Package: lxc 1.0.0~beta3-0ubuntu1
> ProcVersionSignature: User Name 3.13.0-2.17-generic 3.13.0-rc7
> Uname: Linux 3.13.0-2-generic ppc64le
> ApportVersion: 2.13.2-0ubuntu2
> Architecture: ppc64el
> Date: Tue Jan 28 16:49:03 2014
> ProcEnviron:
> TERM=screen-256color-bce
> PATH=(custom, no user)
> XDG_RUNTIME_DIR=<set>
> LANG=en_US.UTF-8
> SHELL=/bin/bash
> SourcePackage: lxc
> UpgradeStatus: No upgrade log present (probably fresh install)
> defaults.conf:
> lxc.network.type = veth
> lxc.network.link = lxcbr0
> lxc.network.flags = up
> lxc.network.hwaddr = 00:16:3e:xx:xx:xx
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/juju-core/+bug/1273769/+subscriptions

Mark Ramm (mark-ramm) wrote :

Dave, can you turn you hack of your working copy into a branch proposal?

Changed in juju-core:
importance: High → Critical
Dave Cheney (dave-cheney) wrote :

On Fri, Mar 14, 2014 at 5:59 AM, Mark Ramm
<email address hidden> wrote:
> Dave, can you turn you hack of your working copy into a branch proposal?

All my outstanding changes have long since been committed to trunk

>
> ** Changed in: juju-core
> Importance: High => Critical
>
> --
> You received this bug notification because you are subscribed to juju-
> core.
> Matching subscriptions: MOAR JUJU SPAM!
> https://bugs.launchpad.net/bugs/1273769
>
> Title:
> ppc64el enablement for juju/lxc
>
> Status in juju-core:
> Triaged
> Status in "cloud-utils" package in Ubuntu:
> Fix Released
> Status in "juju-core" package in Ubuntu:
> Triaged
> Status in "lxc" package in Ubuntu:
> Fix Released
>
> Bug description:
> After some initial testing of juju (with local provider) on ppc64el -
> we need todo some work to fully enable this option.
>
> 1) LXC templates need to support ppc64el as a valid container arch
> 2) ubuntu-cloudimg-query is not avaliable on ppc64el
> 3) Juju is explicit in its support for x84 and arm - so enablement work is needed here as well.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 14.04
> Package: lxc 1.0.0~beta3-0ubuntu1
> ProcVersionSignature: User Name 3.13.0-2.17-generic 3.13.0-rc7
> Uname: Linux 3.13.0-2-generic ppc64le
> ApportVersion: 2.13.2-0ubuntu2
> Architecture: ppc64el
> Date: Tue Jan 28 16:49:03 2014
> ProcEnviron:
> TERM=screen-256color-bce
> PATH=(custom, no user)
> XDG_RUNTIME_DIR=<set>
> LANG=en_US.UTF-8
> SHELL=/bin/bash
> SourcePackage: lxc
> UpgradeStatus: No upgrade log present (probably fresh install)
> defaults.conf:
> lxc.network.type = veth
> lxc.network.link = lxcbr0
> lxc.network.flags = up
> lxc.network.hwaddr = 00:16:3e:xx:xx:xx
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/juju-core/+bug/1273769/+subscriptions

Curtis Hovey (sinzui) on 2014-03-13
Changed in juju-core:
milestone: 1.20.0 → 1.18.0
Dave Cheney (dave-cheney) wrote :

I'm going to mark this as fix committed for juju-core.

The prereq changes to lxc and cloud templates have been released

Juju now understands ppc64{el,le} as an arch and can bootstrap

ubuntu@winton-02:~/src/launchpad.net/juju-core$ juju switch local
julocal -> local
ubuntu@winton-02:~/src/launchpad.net/juju-core$ juju bootstrap --upload-tools
Logging to /home/ubuntu/.juju/local/log/cloud-init-output.log on remote host
Starting MongoDB server (juju-db-ubuntu-local)
Bootstrapping Juju machine agent
Starting Juju machine agent (juju-agent-ubuntu-local)
ubuntu@winton-02:~/src/launchpad.net/juju-core$ juju status
environment: local
machines:
  "0":
    agent-state: down
    agent-state-info: (started)
    agent-version: 1.17.5.1
    dns-name: localhost
    instance-id: localhost
    series: trusty
services: {}

Changed in juju-core:
assignee: nobody → Dave Cheney (dave-cheney)
status: Triaged → Fix Committed
John A Meinel (jameinel) on 2014-03-17
Changed in juju-core:
milestone: 1.18.0 → 1.17.6
Dave Cheney (dave-cheney) wrote :

You can mark this fix release against, 1.17.5 for what it's worth

On Mon, Mar 17, 2014 at 3:36 PM, John A Meinel <email address hidden>wrote:

> ** Changed in: juju-core
> Milestone: 1.18.0 => 1.17.6
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1273769
>
> Title:
> ppc64el enablement for juju/lxc
>
> Status in juju-core:
> Fix Committed
> Status in "cloud-utils" package in Ubuntu:
> Fix Released
> Status in "juju-core" package in Ubuntu:
> Triaged
> Status in "lxc" package in Ubuntu:
> Fix Released
>
> Bug description:
> After some initial testing of juju (with local provider) on ppc64el -
> we need todo some work to fully enable this option.
>
> 1) LXC templates need to support ppc64el as a valid container arch
> 2) ubuntu-cloudimg-query is not avaliable on ppc64el
> 3) Juju is explicit in its support for x84 and arm - so enablement work
> is needed here as well.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 14.04
> Package: lxc 1.0.0~beta3-0ubuntu1
> ProcVersionSignature: User Name 3.13.0-2.17-generic 3.13.0-rc7
> Uname: Linux 3.13.0-2-generic ppc64le
> ApportVersion: 2.13.2-0ubuntu2
> Architecture: ppc64el
> Date: Tue Jan 28 16:49:03 2014
> ProcEnviron:
> TERM=screen-256color-bce
> PATH=(custom, no user)
> XDG_RUNTIME_DIR=<set>
> LANG=en_US.UTF-8
> SHELL=/bin/bash
> SourcePackage: lxc
> UpgradeStatus: No upgrade log present (probably fresh install)
> defaults.conf:
> lxc.network.type = veth
> lxc.network.link = lxcbr0
> lxc.network.flags = up
> lxc.network.hwaddr = 00:16:3e:xx:xx:xx
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/juju-core/+bug/1273769/+subscriptions
>

Curtis Hovey (sinzui) on 2014-03-20
Changed in juju-core:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package juju-core - 1.17.6-0ubuntu1

---------------
juju-core (1.17.6-0ubuntu1) trusty; urgency=medium

  * New upstream point release, including fixes for:
    - br0 not bought up by cloud-init with MAAS provider (LP: #1271144).
    - ppc64el enablement for juju/lxc (LP: #1273769).
    - juju userdata should not restart networking (LP: #1248283).
    - error detecting hardware characteristics (LP: #1276909).
    - juju instances not including the default security group (LP: #1129720).
    - juju bootstrap does not honor https_proxy (LP: #1240260).
  * d/control,rules: Drop BD on bash-completion, install bash-completion
    direct from upstream source code.
  * d/rules: Set HOME prior to generating man pages.
  * d/control: Drop alternative dependency on mongodb-server; juju now only
    works on trusty with juju-mongodb.
 -- James Page <email address hidden> Mon, 24 Mar 2014 16:05:44 +0000

Changed in juju-core (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related blueprints