Oneiric regression: boot from lvm fails

Bug #874063 reported by Alan Jenkins on 2011-10-14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
lvm2 (Ubuntu)

Bug Description

I don't have a separate boot partition; both / and /boot are on the same Logical Volume.

In Natty, this worked fine. After upgrading to Oneiric, it broke. It hangs for a bit, then kicks me to the initramfs shell. It can't find the root device. /dev/mapper is empty (apart from the "control" device). lvscan manages to find all my logical volumes, but shows them as "inactive".

My old kernels are still able to boot. (If I select them from the GRUB menu). However, if I do update-initramfs -k <old-kernel>, that kernel stops working.

My first suspicion was the the lvm package was failing to copy the necessary information to the initramfs. But having played with the lvm manpages and commands, I can't find what information (i.e. files) would be needed. I suspect I was conflating lvm with something that MD/mdadm needs (I don't use MD*at all*).

So it's probably more that the lvm scripts in the initramfs are missing a command invocation, which is needed to make the volume groups active. Or the udev rules in the initramfs are missing the device & not running the command.... Hmm.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: lvm2 2.02.66-4ubuntu3
ProcVersionSignature: Ubuntu 2.6.38-11.50-generic
Uname: Linux 2.6.38-11-generic x86_64
ApportVersion: 1.23-0ubuntu3
Architecture: amd64
Date: Fri Oct 14 11:19:16 2011
 PATH=(custom, no user)
SourcePackage: lvm2
UpgradeStatus: Upgraded to oneiric on 2011-10-14 (0 days ago)

Alan Jenkins (aj504) wrote :
description: updated
Alan Jenkins (aj504) wrote :

Mount output after successful boot, showing / on LVM and no /boot partition.

$ mount
/dev/mapper/alan--desktop.Linux-karmic on / type ext4 (rw,noatime,errors=remount-ro,commit=0)
none on /proc type proc (rw,noexec,nosuid,nodev)
none on /sys type sysfs (rw,noexec,nosuid,nodev)
fusectl on /sys/fs/fuse/connections type fusectl (rw)
none on /sys/kernel/debug type debugfs (rw)
none on /sys/kernel/security type securityfs (rw)
none on /dev type devtmpfs (rw,mode=0755)
none on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=0620)
none on /run type tmpfs (rw,noexec,nosuid,size=10%,mode=0755)
none on /run/lock type tmpfs (rw,noexec,nosuid,nodev,size=5242880)
none on /run/shm type tmpfs (rw,nosuid,nodev)
/dev/mapper/alan--desktop.Linux-Ubuntu.home on /mnt/home type ext4 (rw,nosuid,noatime,errors=remount-ro,commit=0)
/dev/mapper/alan--desktop.Linux-backup--ext4 on /mnt/backup type ext4 (rw,nosuid,noatime,errors=remount-ro,commit=0)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,noexec,nosuid,nodev)
gvfs-fuse-daemon on /home/alan/.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev,user=alan)

Alan Jenkins (aj504) wrote :

Note: I can tolerate this for a short amount of time, but ultimately I'm likely to drop LVM altogther. After which, I won't be able to reproduce this / test any proposed fix.

Alan Jenkins (aj504) wrote :

Heh, switching to a separate /boot partition doesn't help. (I sort-of realized this would be the case, but I forgot again).

Still no idea why. I'm looking at dropping LVM now.

summary: - Oneiric regression: boot from lvm fails (w/o separate boot partition)
+ Oneiric regression: boot from lvm fails
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in lvm2 (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers