[Wishlist] Upgrade lvm2 to at least 2.02.73

Bug #726677 reported by UbuntuFlo on 2011-02-28
40
This bug affects 5 people
Affects Status Importance Assigned to Milestone
lvm2 (Ubuntu)
Wishlist
Clint Byrum

Bug Description

Binary package hint: lvm2

As of version 2.02.73 lvm2 is able to "Change default alignment of pe_start to 1MB" which means that users can align their filesystems easily to 1 MB areas.

Natty's lvm2-version is, as of today, 2.02.66-4ubuntu2. Actual version is 2.02.84. As I said: version 2.02.73 would be the least possible to get that new alignment feature which would increase comfort especially with SSDs and the todays 4k-HDDs.

See lvm2 changelog → http://www.mirrorservice.org/sites/sourceware.org/pub/lvm2/WHATS_NEW
See lvm2-ML-entry of "change default alignment of pe_start to 1MB" → http://www.redhat.com/archives/lvm-devel/2010-August/msg00035.html

Micah Gersten (micahg) on 2011-02-28
tags: added: upgrade-software-version
Alasdair G. Kergon (agk2) wrote :

I'm not recommending upgrades to anything other than 2.02.84 at the moment, due to other issues. So far I regard 2.02.84 as 'stable'. (Add 'Fix to make resuming exclusive cluster mirror use local target type.' to the release if you want.)

Clint Byrum (clint-fewbar) wrote :

2.02.84 is in Debian, so I would expect this one to be fixed by the next merge. Marking Confirmed/Wishlist.

Changed in lvm2 (Ubuntu):
status: New → Confirmed
importance: Undecided → Wishlist
Steve Langasek (vorlon) wrote :

Alasdair, is 2.02.86 also safe these days, or should we be holding back on 2.02.84? Debian has updated to 2.02.86 since this bug was filed.

Steve Langasek (vorlon) on 2011-10-17
Changed in lvm2 (Ubuntu):
assignee: nobody → Clint Byrum (clint-fewbar)

On Mon, Oct 17, 2011 at 11:45:53PM -0000, Steve Langasek wrote:
> Alasdair, is 2.02.86 also safe these days, or should we be holding back
> on 2.02.84? Debian has updated to 2.02.86 since this bug was filed.

2.02.86 should be OK, but patch it at least with the patch for:
  Terminate pv_attr field correctly.
(Otherwise 'pvs' can segfault when running.)

For the next RHEL5 and RHEL6 releases, we're using 2.02.88 and backporting
selected changes to it as the current upstream repo has some significant
development work going on in it and it'll be several more weeks before
there's another release.

Alasdair

Clint Byrum (clint-fewbar) wrote :

This merge is a bit of a sticky one due to all of the patches that have been applied on top of one another in our package, debian's package, and upstream. I'm moving through it, but slowly.

Arnd (arnd-arndnet) wrote :

Hey Clint,

any news on this?
I noticed that LVM in precise is still 2.02.66

Launchpad Janitor (janitor) wrote :
Download full text (5.7 KiB)

This bug was fixed in the package lvm2 - 2.02.88-2ubuntu1

---------------
lvm2 (2.02.88-2ubuntu1) quantal; urgency=low

  * Merge from Debian unstable (LP: #726677), remaining changes:
    - debian/patches/avoid-dev-block.patch: Prefer any other device name over
      names in /dev/block/ since lvm.conf won't handle this.
    - debian/rules:
      - copy .po file to .pot file for Rosetta (Ubuntu specific).
    - debian/{dmsetup,lvm2}-udeb.install:
      - install initramfs and udev hooks in udebs (Debian bug 504341).
    - auto-start VGs as their PVs are discovered (Ubuntu specific):
      - add debian/tree/lvm2/lib/udev/rules.d/85-lvm2.rules: use watershed plus
        the sledgehammer of vgscan/vgchange to turn on VGs as they come online.
      - debian/tree/lvm2/usr/share/initramfs-tools/scripts/hooks/lvm2:
        - add 85-lvm2.rules to the list of udev rules to copy.
        - depend on udev.
      - debian/control:
        - add versioned Depend on watershed in lvm2 for udev rules.
        - add versioned Depend/Breaks on udev in dmsetup for udev rules.
        - add Depend on initramfs-tools in dmsetup so system is not potentially
          rendered unbootable by out-of-order dpkg configuration. LP: #358654.
      - debian/rules:
        - do not install local-top scripts since Ubuntu mounts root using udev.
        - do not install init scripts for lvm2, since udev starts LVM.
      - debian/lvm2.postinst: handle missing lvm2 init script.
      - debian/tree/dmsetup/lib/udev/rules.d/60-persistent-storage-dm.rules:
        watch dm devices for changes with inotify
    - add mountroot failure hooks to help fix bad boots (Debian bug 468115):
      - debian/tree/lvm2/usr/share/initramfs-tools/scripts/init-premount/lvm2
    - add packages for upstream event manager (Debian bug 514706):
      - debian/control: define libdevmapper-event1.02.1 and dmeventd packages.
      - debian/rules:
        - enable dmeventd during configure.
        - add build targets.
        - fix shlibs invocation with a cleared DH_OPTIONS to get udeb shlibs.
      - debian/dmeventd.{install,8,manpages}: install dmeventd files.
      - debian/libdevmapper-event*.{install,symbols}: install dmeventd files.
      - debian/libdevmapper-dev.install: install libdevmapper-event files.
      - debian/patches/monitoring-default-off.patch: by default, do not
        expect to talk to dmeventd. Monitoring can be done via "--monitor y".
    - rename debian/clvm.defaults to debian/clvm.default so it is intalled
      correctly.
    - debian/control: add dmsetup-udeb to libdevmapper1.02.1-udeb recommends.
    - lidevmapper-dev: move .so symlinks to /usr/lib where they belong
    - debian/patches/rules-subdir.patch: removed as reordering will cause
      build failure with dmeventd.
    - debian/patches/libdm-event-static.patch: removed as other static libs
      aren't being built anymore either.
    - debian/rules: make sure dmsetup and lvm2 initramfs-tools scripts are
      executable. When the Ubuntu-specific ones are added with a patch,
      they may lose their executable bit.
    - Add and install clvmd resource agent
    - Add dependency on libudev-dev to libdevmapper-...

Read more...

Changed in lvm2 (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions