.: 6: Can't open /scripts/casper-functions when running update-initramfs

Bug #658719 reported by Eyad Salah on 2010-10-11
62
This bug affects 12 people
Affects Status Importance Assigned to Milestone
lvm2 (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: lvm2

Whenever I try running "update-initramfs -uv" I get the following:
.: 6: Can't open /scripts/casper-functions

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: dmsetup 2:1.02.39-1ubuntu6
ProcVersionSignature: Ubuntu 2.6.35-22.34-generic 2.6.35.4
Uname: Linux 2.6.35-22-generic i686
NonfreeKernelModules: nvidia
Architecture: i386
Date: Mon Oct 11 23:58:50 2010
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release i386 (20100429)
ProcEnviron:
 LANGUAGE=en_US
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: lvm2

Eyad Salah (eyad-salah) wrote :
Eyad Salah (eyad-salah) wrote :

Here's the full output of the command

Peter S (speter) wrote :

The same error occurred to me when running software update (on maverick/amd64). Removing "canonical-census" as advised on the page below solved the issue.
http://ubuntu-ky.ubuntuforums.org/showthread.php?t=1555885

tags: added: amd64
Eyad Salah (eyad-salah) wrote :

Yep, fixed the problem for me too, Thanks

Shouldn't this be reported as a bug in canonical census?

similar issue here

did not have that package installed

figured i could install then purge it

doing so indicated

dpkg: warning: while removing canonical-census, directory '/usr/share/initramfs-tools/scripts/casper-bottom' not empty so not removed.

ls -lh /usr/share/initramfs-tools/scripts/casper-bottom
total 32K
-rwxr-xr-x 1 root root 1.5K 2010-05-17 03:53 autologin.bkp
-rw-r--r-- 1 root root 22K 2010-05-17 03:53 kdmrc
-rwxr-xr-x 1 root root 161 2010-05-17 23:58 kpersonalizer

this installation was from the kubuntu with kde3 remix, guess some of the leftovers could have been from that

casper is for the live cd (from read-only media); do not think any part of it belongs on an installed system

eventually i just removed the dir and its contents: /usr/share/initramfs-tools/scripts/casper-bottom

now
$ sudo dpkg-reconfigure linux-headers-2.6.35-23-generic
$ sudo dpkg-reconfigure linux-image-2.6.35-23-generic
both run without displaying anything about a missing casper

rbertran (rbertran) wrote :

Still problem in Natty 64 bits beta 2.

ewwink (ewwink) wrote :

try this

cd /
ln -s /usr/share/initramfs-tools/scripts

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in lvm2 (Ubuntu):
status: New → Confirmed
martin suc (martin-suc) wrote :

It has appeared couple of days ago by doing following update-initramfs -u -k all as well within all installed kernels.

update-initramfs: Generating /boot/initrd.img-3.8.0-999-generic
/tmp/mkinitramfs_YjM4dZ/scripts/casper-bottom/48xubuntu_maybe_ubiquity: 6: .: Can't open /scripts/casper-functions
update-initramfs: Generating /boot/initrd.img-3.5.0-24-lowlatency
/tmp/mkinitramfs_emwa4c/scripts/casper-bottom/48xubuntu_maybe_ubiquity: 6: .: Can't open /scripts/casper-functions
update-initramfs: Generating /boot/initrd.img-3.5.0-24-generic
/tmp/mkinitramfs_PBg7Xl/scripts/casper-bottom/48xubuntu_maybe_ubiquity: 6: .: Can't open /scripts/casper-functions

(Not sure - seems it belongs to some xubuntu stuff ?)

martin suc (martin-suc) wrote :

Thanks ewwink #8 - at the first glance - seems works.

Portaro (joaoteixeira1984) wrote :

After this comand sudo update-initramfs -u in last week i lose any conection to my kernels boot, when i change the plymouth theme I start to have problems with kernels boot, and a two days ago i need reinstall ubuntu because my kernels dont boot after grub appear a message initate ramdisk or identify the boot partition problems. All after the command i do mention.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers