udevd-work[674]: kernel-provided name 'dm-5' and NAME= 'mapper/main-server1a--lu cid-cow' disagree, please use SYMLINK+= or change the kernel to provide the prop er name

Bug #621951 reported by Dave Gilbert on 2010-08-21
24
This bug affects 5 people
Affects Status Importance Assigned to Milestone
lvm2 (Ubuntu)
Medium
Colin Watson
Maverick
Medium
Colin Watson

Bug Description

Binary package hint: udev

I was looking through /var/log/boot.log on my Maverick system (upgrade from Lucid) and noticed a series of entries of the form:

udevd-work[580]: kernel-provided name 'dm-1' and NAME= 'mapper/main-more' disagree, please use SYMLINK+= or change the kernel to provide the proper name

These correspond to all my LVM volumes; including both the ones that actually get mounted (like mapper/main-more) and all the ones I use for KVM vm's (e.g. the mapper/main-fedora13).

Doesn't seem to have broken anything, but seems worth reporting.

Dave

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: udev 161+git20100820-1
ProcVersionSignature: Ubuntu 2.6.35-17.23-generic 2.6.35.2
Uname: Linux 2.6.35-17-generic x86_64
Architecture: amd64
CheckboxSubmission: f2d10bd9f943a85b486a282e7840a570
CheckboxSystem: 0531969bcfd4f03af7405c98dc94a948
Date: Sat Aug 21 21:07:48 2010
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release amd64 (20091027)
MachineType: To Be Filled By O.E.M. To Be Filled By O.E.M.
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.35-17-generic root=UUID=d8314979-8ace-401c-88df-728ad6b89cb5 ro ignore_loglevel netconsole=4444@192.168.66.33/eth0,514@192.168.66.25/00:a0:d1:63:68:a6 crashkernel=384M-2G:64M,2G-:128M quiet splash nointremap
ProcEnviron:
 PATH=(custom, user)
 LANG=en_GB.utf8
 SHELL=/bin/bash
SourcePackage: udev
dmi.bios.date: 09/10/2009
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: P1.50
dmi.board.name: P55M Pro
dmi.board.vendor: ASRock
dmi.chassis.asset.tag: To Be Filled By O.E.M.
dmi.chassis.type: 3
dmi.chassis.vendor: To Be Filled By O.E.M.
dmi.chassis.version: To Be Filled By O.E.M.
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrP1.50:bd09/10/2009:svnToBeFilledByO.E.M.:pnToBeFilledByO.E.M.:pvrToBeFilledByO.E.M.:rvnASRock:rnP55MPro:rvr:cvnToBeFilledByO.E.M.:ct3:cvrToBeFilledByO.E.M.:
dmi.product.name: To Be Filled By O.E.M.
dmi.product.version: To Be Filled By O.E.M.
dmi.sys.vendor: To Be Filled By O.E.M.

Related branches

Dave Gilbert (ubuntu-treblig) wrote :
Martin Pitt (pitti) wrote :

These come from /lib/udev/rules.d/55-dm.rules, and should indeed be changed to SYMLINK.

affects: udev (Ubuntu) → lvm2 (Ubuntu)
Changed in lvm2 (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
tags: added: iso-testing
Colin Watson (cjwatson) wrote :

We should change this, but not until after beta as it needs to be coordinated with a change in parted.

Thierry Carrez (ttx) on 2010-09-02
tags: added: server-mrs
Thierry Carrez (ttx) on 2010-09-02
tags: added: server-mro
removed: server-mrs
Colin Watson (cjwatson) on 2010-09-08
Changed in lvm2 (Ubuntu Maverick):
assignee: nobody → Colin Watson (cjwatson)
milestone: none → ubuntu-10.10
Colin Watson (cjwatson) wrote :

It looks like parted's behaviour is actually conditional on a patch in dmraid. I'm not proposing removing that right now, so it should be possible to change lvm2 on its own.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lvm2 - 2.02.54-1ubuntu5

---------------
lvm2 (2.02.54-1ubuntu5) maverick; urgency=low

  * Backport from Debian:
    - Don't overwrite names of dm devices; use symlinks instead
      (LP: #621951).
 -- Colin Watson <email address hidden> Wed, 08 Sep 2010 22:50:26 +0100

Changed in lvm2 (Ubuntu Maverick):
status: Triaged → Fix Released
Dave Gilbert (ubuntu-treblig) wrote :

Thanks, confirmed these messages have gone.

Dave

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers