lvm volume does not activate on boot

Bug #581214 reported by davidc on 2010-05-16
54
This bug affects 10 people
Affects Status Importance Assigned to Milestone
lvm2 (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: lvm2

I have an LVM volume that spans two drives, I am not trying to boot off it or use it for /home, it is just additional storage. Since doing a fresh install of Lynx, I have been unable to get it to activate on boot.

The fstab entry is:
/dev/mapper/ds9-odo /media/odo ext4 errors=remount-ro 0 1

I tried following the instructions on https://wiki.ubuntu.com/DebuggingLvm, but as noted on that page, it doesn't seem to work on Lynx. scripts/init-premount/udev and /sbin/udevtrigger do not exist.

When booting normally, I always get the purple boot screen, with the message:

The disk drive for /media/odo is not ready yet or not present
Continue to wait or Press S to skip mounting or M for manual recovery

If I wait, nothing happens (waited several minutes)

If I skip, the system boots, and my lvm volume is unmounted.

If I use manual recovery, or skip and let it boot, and try a 'mount -a' I get:

mount: special device /dev/mapper/ds9-odo does not exist

If I run: 'vgchange ds9 -a y' in the 'manual recovery' shell I get:

File descriptor 8 (pipe:[4433]) leaked on vgchange invocation. Parent PId 886: bash
  1 logical volume(s) in volume group "ds9" now active

If I do it after skipping (once one the gnome desktop), I don't get the error, just:
  1 logical volume(s) in volume group "ds9" now active

Then, whether in the recovery shell or after booting, once it says ds9 is active, 'mount -a' works correctly.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: lvm2 2.02.54-1ubuntu4
ProcVersionSignature: Ubuntu 2.6.32-22.33-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-22-generic i686
Architecture: i386
Date: Sun May 16 17:53:18 2010
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release i386 (20100429)
ProcEnviron:
 LANG=en_AU.utf8
 SHELL=/bin/bash
SourcePackage: lvm2

davidc (daave-daave) wrote :
Stefan Güls (sguels) wrote :

This bug started hitting me after kernel-update to 2.6.32-23.

Stefan Güls (sguels) wrote :

I might add that in approx. 1 out of 5 boots the bug does /not/ appear. So this could be a timing problem during execution of the initramfs phase

Ofer Chen (oferchen) wrote :

I have exactly the same issue LVM not getting mounted on boot and I can always mount it from recovery shell
maybe udev rule /lib/udev/rules.d/85-lvm2.rules doesn't get executed..
or /lib/udev/rules.d/56-lvm.rules

Martin von Boehlen (mvb-i) wrote :

Trying to write an upstart script or modify /etc/init/mountall.conf with two lines like
/sbin/vgscan
/sbin/vgchange -a y
did not work. Most probably due to my non-existent knowledge of upstart.
Any ideas on that account, anybody ?

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in lvm2 (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers