volume group on top of md raid array dissappears after reboot

Bug #343730 reported by Brazen on 2009-03-16
Affects Status Importance Assigned to Milestone
lvm2 (Ubuntu)

Bug Description

In a fresh install of Jaunty Alpha 6, the system has two identical 120GB ata hard drives. during the boot process I create 4 identical partitions and add them to Raid arrays:
md0 is /boot with 210MB Raid 1
md1 is swap with 1GB Raid 0
md2 is / with 4GB Raid 1
md3 is physical volume for LVM using the rest of the space in Raid 1

I created a volume group called 'vgdata' with md3

After a reboot, the volume group is missing. Running the following commands find the the volume group and appear to complete successfully:
sudo pvscan
sudo vgscan
sudo vgchange -ay vgdata
sudo vgmknodes

but there is still no /dev/vgkvm device created. I've tried wiping out md3 and recreating the raid device and volume group manually from the command line. After creation, I can use the volume group like normal, but it dissappears again after reboot.

Brazen (jdinkel) on 2009-03-16
description: updated
Brazen (jdinkel) wrote :

This may be more of a feature request than a bug. I see now that the volume group device does not show up unless a logical volume exists on the device.

This cause a problem with virt-manager though, which is where I first noticed it. I created the volume group with the intention of adding it as a storage pool to virt-manger/libvirt, but I am unable to do so with a blank volume group.

David Tombs (dgtombs) wrote :

I don't know much about RAID but I'm assigning this to virt-manager so someone who knows more will see it. Sorry for the wait.

affects: ubuntu → virt-manager (Ubuntu)
Marc Deslauriers (mdeslaur) wrote :

This has nothing to do with virt-manager. Reassigning to lvm2.

affects: virt-manager (Ubuntu) → lvm2 (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers