memory usage pvmove / Refactor pvmove allocation code

Bug #321667 reported by Michael Windelen on 2009-01-26
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
lvm2 (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: lvm2

Hello,

pvmove uses more an more memory while copying my data (2TB of data).
I am not able to move my logical Volumes to another Harddisks (ran out of memory - 2GB of RAM in my Server).

x64
Description: Ubuntu 8.04.2
Release: 8.04

Paket: lvm2
Version: 2.02.26-1ubuntu9
pvmove:
LVM version: 2.02.26 (2007-06-15)
Installiert:2.02.26-1ubuntu9

I found that this Problem is fixed in 2.02.29 and later.
e.g. i search for:
Refactor pvmove allocation code
and found e.g.:
http://liorkaplan.wordpress.com/2008/01/
ftp://sources.redhat.com/pub/lvm2/WHATS_NEW
Greetings
Michael

description: updated
Jeffrey Baker (jwbaker) wrote :

I'm not seeing this on Lucid. pvmove memory size holds steady during the move.

tom (thomas-gutzler) wrote :

I experienced the same bug on 9.04
I tried moving the data from a 1TB (sdc) disk to a 1.5TB (sdh) disk and at 40% the machine had a kernel panic: out of memory

After the reboot I started pvmove -i 60 -v
At the moment it's at
  /dev/sdc: Moved: 15.5%
    Finding all volume groups
    Finding volume group "BFG"
  /dev/sdc: Moved: 15.8%

And I'm already getting 60 identical processes like this one
 8385 ? S<s 0:00 (lvm2copy vgchange -a y

# ps axw | grep lvm| wc -l
60

tom (thomas-gutzler) wrote :
tom (thomas-gutzler) wrote :
tom (thomas-gutzler) wrote :
tom (thomas-gutzler) wrote :
tom (thomas-gutzler) wrote :
tom (thomas-gutzler) wrote :

Forgot to mention that the distribution is fully up to date with all packages and the current version of lvm installed is 2.02.39-0ubuntu9

tom (thomas-gutzler) wrote :

Since this seems to be solved in newer versions of ubuntu, I shall upgrade.
For now my solution was to run pvmove several times for different sufficiently small parts of the disk, passing it the :PE-PE parameter.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers