netboot: lvm unable to find libreadline and libncurses

Bug #263558 reported by Felix Hanley on 2008-09-01
2
Affects Status Importance Assigned to Milestone
lvm2 (Debian)
Fix Released
Unknown
lvm2 (Ubuntu)
High
Colin Watson

Bug Description

Binary package hint: debootstrap

Not sure of the package but...

intrepid Alpha 4
netboot install using PXE
'expert' install mode
loaded 'lvm' and 'partition' modules

It seems all the lvm tools require libreadline and libncurses in order to function. These are missing from the bootstrap setup though.

My own temporary fix involved downloading and extracting the two libraries (libreadline.so.5.2 and libncurses.so.5.6) and placing them where lvm tools expect to find them. A little tedious.

-felix

Related branches

Jonathan Davies (jpds) wrote :

I had this problem too with the 20081030 daily image. Marking as confirmed.

Changed in debootstrap:
status: New → Confirmed
Colin Watson (cjwatson) on 2008-09-01
Changed in lvm2:
importance: Undecided → High
assignee: nobody → kamion
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lvm2 - 2.02.39-0ubuntu2

---------------
lvm2 (2.02.39-0ubuntu2) intrepid; urgency=low

  * Backport from Debian unstable (Bastian Blank):
    - Disable readline support in udeb. (closes: #491203, LP: #263558)

 -- Colin Watson <email address hidden> Mon, 01 Sep 2008 16:47:50 +0100

Changed in lvm2:
status: Confirmed → Fix Released
Changed in lvm2:
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.