Please update lvm2 to 2.02.39

Bug #239460 reported by James Westby on 2008-06-12
2
Affects Status Importance Assigned to Milestone
lvm2 (Debian)
Fix Released
Undecided
Unassigned
lvm2 (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: lvm2

We should update lvm2 to the .38 release.

Thanks,

James

Related branches

Advise against that - none of the recent upstream releases has been stable.
2.02.38 (depends on a dm update too) might be OK.

On Thu, 2008-06-12 at 14:02 +0000, Alasdair G. Kergon wrote:
> Advise against that - none of the recent upstream releases has been stable.
> 2.02.38 (depends on a dm update too) might be OK.
>

Hi,

Thanks for the heads up.

Does lvm2 .38 require devmapper 1.02.26?

I'll file a bug in Debian asking for .38 to be uploaded, and give it a
bit of time before I consider proceeding with a direct upload.

Thanks,

James

James Westby (james-w) on 2008-06-12
Changed in lvm2:
importance: Undecided → Wishlist
status: New → Confirmed
status: Confirmed → Triaged
description: updated
Changed in lvm2:
status: Unknown → New
James Westby (james-w) wrote :

Hi,

Here is the .diff.gz which should be combined with

  ftp://sources.redhat.com/pub/lvm2/LVM2.2.02.39.tgz

to do this.

Please review for inclusion in to Intrepid.

Thanks,

James

James Westby (james-w) wrote :

Hi,

Here is the new .diff.gz including the recent uploads to Intrepid.

Thanks,

James

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lvm2 - 2.02.39-0ubuntu1

---------------
lvm2 (2.02.39-0ubuntu1) intrepid; urgency=low

  * New upstream release (LP: #239460).
  * Merges 2.02.35-1 from Debian.
  * Increase devmapper dependency to (>> 2:1.02.27) due to new API.
  * Re-add quilt to Build-Depends.
  * Add missing Build-Depends on autoconf and libtool.

lvm2 (2.02.35-1) unstable; urgency=low

  * New upstream version.

lvm2 (2.02.33-2) unstable; urgency=low

  * Fix LSB header of init script.

lvm2 (2.02.33-1) unstable; urgency=low

  * New upstream version.
  * Remove loading of additional modules from init script.

lvm2 (2.02.31-1) unstable; urgency=low

  * New upstream version.
  * Readd clvm.
  * Add LSB header to lvm2 init script. (closes: #426108)

lvm2 (2.02.29-1) unstable; urgency=low

  * New upstream version.
  * Load modules.
  * Don't longer directly link libncurses, libselinux and librt.
  * Drop lvm1 support in lvm2-udeb.
  * Force modprobe path to enable module loading.

 -- James Westby <email address hidden> Tue, 01 Jul 2008 16:39:18 +0100

Changed in lvm2:
status: Triaged → Fix Released
Alasdair G. Kergon (agk2) wrote :

Go for 2.02.42 which seems stable so far...

Artur Rona (ari-tczew) wrote :

 lvm2 (2.02.39-6) unstable; urgency=low

   * Readd a vgchange binary into the initramfs. At least cryptsetup depends on
     this.

 -- Bastian Blank <email address hidden> Sat, 22 Nov 2008 16:16:57 +0100

Changed in lvm2 (Debian):
importance: Unknown → Undecided
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.