Error message displayed during boot (mountroot hook, premount)

Bug #1871154 reported by Laurent Bonnaud on 2020-04-06
30
This bug affects 14 people
Affects Status Importance Assigned to Milestone
initramfs-tools (Ubuntu)
Undecided
Unassigned
Focal
Undecided
Unassigned
lvm2 (Ubuntu)
Undecided
Unassigned
Focal
Undecided
Unassigned

Bug Description

[Impact]
* People using lvm2 on ubuntu focal are getting a strange and weird message due to a wrong path

[Test Case]
* Install lvm2 on Ubuntu 20.04

[Regression Potential]
* Low, the fix is already part of groovy

[Other info]
Hi,

my Ubuntu system uses LVM2 for its root file system. It boots correctly, but an ugly error message is displayed during boot.

ProblemType: Bug
DistroRelease: Ubuntu 20.04
Package: lvm2 2.03.07-1ubuntu1
Uname: Linux 5.6.2-050602-generic x86_64
ApportVersion: 2.20.11-0ubuntu22
Architecture: amd64
CurrentDesktop: KDE
Date: Mon Apr 6 17:59:03 2020
SourcePackage: lvm2
UpgradeStatus: No upgrade log present (probably fresh install)

Here is a screenshot of the error message.

Here is my (very simple) LVM setup:

# pvdisplay
  --- Physical volume ---
  PV Name /dev/nvme0n1p2
  VG Name MonVolume2
  PV Size <850.00 GiB / not usable 3.00 MiB
  Allocatable yes
  PE Size 4.00 MiB
  Total PE 217599
  Free PE 89599
  Allocated PE 128000
  PV UUID oZhDcb-KQRJ-eFm9-sKDf-ZztS-1oiI-X3dV0V

# vgdisplay
  --- Volume group ---
  VG Name MonVolume2
  System ID
  Format lvm2
  Metadata Areas 1
  Metadata Sequence No 48
  VG Access read/write
  VG Status resizable
  MAX LV 0
  Cur LV 1
  Open LV 1
  Max PV 0
  Cur PV 1
  Act PV 1
  VG Size <850.00 GiB
  PE Size 4.00 MiB
  Total PE 217599
  Alloc PE / Size 128000 / 500.00 GiB
  Free PE / Size 89599 / <350.00 GiB
  VG UUID R8BWf2-UExN-WPsG-0bxU-7Qzf-PtlT-fgf4hS

# lvdisplay
  --- Logical volume ---
  LV Path /dev/MonVolume2/UbuntuRacine
  LV Name UbuntuRacine
  VG Name MonVolume2
  LV UUID nhjz7g-J0GH-uMqQ-3QQU-eoJH-tuc3-YTMtcd
  LV Write Access read/write
  LV Creation host, time ubuntu, 2019-05-03 18:45:22 +0200
  LV Status available
  # open 1
  LV Size 500.00 GiB
  Current LE 128000
  Segments 1
  Allocation inherit
  Read ahead sectors auto
  - currently set to 256
  Block device 253:0

My system had the same LVM setup in Ubuntu 19.10 and no error message was displayed during boot.

Here is a nicer screenshot taken in a VM.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lvm2 - 2.03.07-1ubuntu2

---------------
lvm2 (2.03.07-1ubuntu2) groovy; urgency=medium

  * Fix incorrect path to mountroot fail hook. LP: #1871154

 -- Dimitri John Ledkov <email address hidden> Tue, 26 May 2020 13:11:44 +0100

Changed in lvm2 (Ubuntu):
status: New → Fix Released

Thanks a lot for the fix!
How about a SRU for focal?

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in lvm2 (Ubuntu Focal):
status: New → Confirmed
description: updated
Changed in lvm2 (Ubuntu Focal):
status: Confirmed → In Progress

Laurent, I uploaded the package in queue for review, and in my ppa
https://launchpad.net/~costamagnagianfranco/+archive/ubuntu/locutusofborg-ppa

please have a look and report back

I installed the updated packages, and rebooted my system.
Unfortunately the error message is still displayed.

Dimitri John Ledkov (xnox) wrote :

It seems to me that /tmp/mountroot-fail-hooks.d/ never worked correctly.

Thus i wonder if it should be dropped altogether.

Changed in lvm2 (Ubuntu):
status: Fix Released → Triaged
Dimitri John Ledkov (xnox) wrote :

Ok, so lvm2 was not broken, but initramfs was!

./initramfs-tools-0.103ubuntu4.11/scripts/functions: ln -s "$0" /tmp/mountroot-fail-hooks.d/"$1"
./initramfs-tools-0.122ubuntu8.16/scripts/functions: ln -s "$0" /tmp/mountroot-fail-hooks.d/"$1"
./initramfs-tools-0.125ubuntu12.2/scripts/functions: ln -s "$0" /tmp/mountroot-fail-hooks.d/"$1"
./initramfs-tools-0.130ubuntu3.9/scripts/functions: ln -s "$0" /tmp/mountroot-fail-hooks.d/"$1"
./initramfs-tools-0.131ubuntu15.2/scripts/functions: ln -s "$0" /tmp/mountroot-fail-hooks.d/"$1"
./initramfs-tools-0.131ubuntu19.2/scripts/functions: ln -s "$0" /tmp/mountroot-fail-hooks.d/"$1"
./initramfs-tools-0.133ubuntu10/scripts/functions: ln -s "$0" /tmp/mountroot-fail-hooks.d/"$1"
./initramfs-tools-0.136ubuntu6/scripts/functions: ln -s "$0" /tmp/mountroot-fail-hooks.d/"$0"
./initramfs-tools-0.137ubuntu7/scripts/functions: ln -s "$0" /tmp/mountroot-fail-hooks.d/"$0"
./initramfs-tools-0.99ubuntu13.5/scripts/functions: ln -s "$0" /tmp/mountroot-fail-hooks.d/"$1"

Dimitri John Ledkov (xnox) wrote :
Changed in lvm2 (Ubuntu Focal):
status: In Progress → Invalid
Changed in initramfs-tools (Ubuntu):
status: New → Fix Committed
Changed in lvm2 (Ubuntu):
status: Triaged → Invalid
Changed in initramfs-tools (Ubuntu Focal):
status: New → In Progress

Uploaded initramfs-tools_0.136ubuntu6.20.04.1_source.changes in focal queue, after getting a good feedback from another user being hit from this bug.
(my ppa has the fix uploaded)

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lvm2 - 2.03.07-1ubuntu3

---------------
lvm2 (2.03.07-1ubuntu3) groovy; urgency=medium

  * Revert "Fix incorrect path to mountroot fail hook. LP: #1871154"
    regression is in the initramfs-tools package.

lvm2 (2.03.07-1ubuntu2) groovy; urgency=medium

  * Fix incorrect path to mountroot fail hook. LP: #1871154

 -- Dimitri John Ledkov <email address hidden> Sat, 30 May 2020 15:02:01 +0100

Changed in lvm2 (Ubuntu):
status: Invalid → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package initramfs-tools - 0.137ubuntu9

---------------
initramfs-tools (0.137ubuntu9) groovy; urgency=medium

  * Document add_mountroot_fail_hook correctly.

initramfs-tools (0.137ubuntu8) groovy; urgency=medium

  * Partially revert 0.133ubuntu12 upload:
    "* scripts/functions: Fix args in the add_mountroot_fail_check function."
    The arguments were correct, as used by lvm2 hook. LP: #1871154

initramfs-tools (0.137ubuntu7) groovy; urgency=medium

  * Fix copying libgcc_s when there is optimized pthreads installed.
    LP: #1880853

 -- Dimitri John Ledkov <email address hidden> Sat, 30 May 2020 16:33:08 +0100

Changed in initramfs-tools (Ubuntu):
status: Fix Committed → Fix Released

>Uploaded initramfs-tools_0.136ubuntu6.20.04.1_source.changes in focal queue, after getting a good >feedback from another user being hit from this bug.
>(my ppa has the fix uploaded)

Thanks, but I do not see an initramfs-tools package in your PPA.

 initramfs-tools - 0.136ubuntu6.20.04.3
in my ppa now!

Thanks a lot! And I confirm that the error message no longer appears :>.

Hello Laurent, or anyone else affected,

Accepted initramfs-tools into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/initramfs-tools/0.136ubuntu6.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-focal to verification-done-focal. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-focal. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in initramfs-tools (Ubuntu Focal):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-focal

I installed this package:

  Package: initramfs-tools
  Version: 0.136ubuntu6.1

from focal-proposed, checked that the initramfs were recreated:

-rw-r--r-- 1 root root 54661886 Jun 4 09:37 /boot/initrd.img-5.4.0-34-generic
-rw-r--r-- 1 root root 54666889 Jun 4 09:37 /boot/initrd.img-5.4.0-34-lowlatency
-rw-r--r-- 1 root root 55265839 Jun 4 09:37 /boot/initrd.img-5.6.16-050616-generic

and rebooted my system. It boots correctly and LVM is working. No error message is displayed during boot.

I also tried on another system where the lvm2 package is installed but not used. The error message also disappeared.

I also tried on another system where the lvm2 package is not installed and saw no problem during boot.

tags: added: verification-done verification-done-focal
removed: verification-needed verification-needed-focal
Andrew (angbor) wrote :

Hello guys. I'm just ordinary user, please help me to understand how to fix this error?
From what PPA you are getting it?

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package initramfs-tools - 0.136ubuntu6.1

---------------
initramfs-tools (0.136ubuntu6.1) focal; urgency=medium

  * SRU changes from Dimitri John Ledkov into focal:
    - Partially revert 0.133ubuntu12 upload:
      "* scripts/functions: Fix args in the add_mountroot_fail_check function."
      The arguments were correct, as used by lvm2 hook.
      LP: #1871154
    - Fix copying libgcc_s when there is optimized pthreads installed.
      LP: #1880853

 -- Gianfranco Costamagna <email address hidden> Mon, 01 Jun 2020 11:03:12 +0200

Changed in initramfs-tools (Ubuntu Focal):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for initramfs-tools has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Johannes Vass (johannes-vass) wrote :

I am experiencing a boot problem on my RaspberryPi 3 B+ which has a 64 Bit Ubuntu 20.04 installed. When I try to boot it, I only see two lines, the second of which is the error message of this bug. Can this bug be the cause of my Raspberry not booting? If yes, how would I install the patch if I cannot boot?

I assume that this bug causes my problems because in the duplicate issue 1873614 other people are reporting boot problems as well.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers