LVM volumes not activated during boot after upgrade to 18.04 LTS

Bug #1843623 reported by Marius Gedminas on 2019-09-11
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
lvm2 (Ubuntu)
Undecided
Unassigned

Bug Description

I've upgraded a server from Ubuntu 16.04 LTS to 18.04 LTS and now it fails to activate LVM volumes during boot (which causes systemd to stop in the middle of the boot process and ask me to fix this on the console without starting up services like SSH).

The root partition, which is also on LVM, gets activated (by the initramfs I assume), but none of the other ones are.

Everything worked fine on xenial, so I don't think this is a duplicate of 1573982?

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: lvm2 2.02.176-4.1ubuntu3.18.04.1
ProcVersionSignature: Ubuntu 4.15.0-62.69-generic 4.15.18
Uname: Linux 4.15.0-62-generic x86_64
ApportVersion: 2.20.9-0ubuntu7.7
Architecture: amd64
Date: Wed Sep 11 19:34:53 2019
ProcEnviron:
 LC_CTYPE=lt_LT.UTF-8
 TERM=xterm-256color
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: lvm2
UpgradeStatus: Upgraded to bionic on 2019-09-11 (0 days ago)

Marius Gedminas (mgedmin) wrote :
Marius Gedminas (mgedmin) wrote :

If I run pvscan --cache -aay in the systemd emergency console, all logical volumes get activated and the system then proceeds to boot normally.

It seems like for some reason udev is not running pvscan for me?

Marius Gedminas (mgedmin) wrote :

FWIW journalctl -b is showing a bunch of

Sep 11 19:16:30 fridge lvmetad[457]: WARNING: Ignoring unsupported value for cmd.
Sep 11 19:16:30 fridge lvmetad[457]: WARNING: Ignoring unsupported value for cmd.

before systemd unit timeouts that are about those missing partitions failing to mount.

Marius Gedminas (mgedmin) wrote :

In case this might be relevant:
- /var is a separate partition (/dev/md1)
- /var/cache is a separate partition (an LVM volume)
- /tmp is a separate partition (an LVM volume)

Marius Gedminas (mgedmin) wrote :

So, uh, I tried another reboot so I could debug the problem some more, and ... well ... the machine booted. No problems. I've no idea what's going on, feel free to close this bug.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers