File descriptor leaked on pvscan invocation

Bug #1241378 reported by latimerio on 2013-10-18
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
lvm2 (Ubuntu)
Undecided
Unassigned

Bug Description

I am running Ubuntu 12.04.3 LTS on my server an I have a ksh script which gathers system information.
It is invoked by cron.daily.
Recently I added the following lines:

      pvscan | grep "^ *PV " \
             | perl -ne 's/[\n\r]*$// ; s/[\[\]]//g ;
                         @Line=split() ;
                         printf( "%2s %-10s %2s %-8s %4s %6.2f %3s %s %6.2f %4s\n", @Line ) ;
                              '

Since then I get the error message below from cron.daily:
  File descriptor 3 (/) leaked on pvscan invocation. Parent PID xxxx: /usr/bin/ksh

I do not get the message if I run the script manually from a shell or from a regular cron.

I tried to set LVM_SUPPRESS_FD_WARNINGS=1 as described in debian bugs 432986, 466138 and 534220 but nothing changed.

It seems that nobody really addressed this rather old LVM issue.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers