initramfs is missing dm_raid dm target (lvm2 does a full resync on every MD raid1 mirror volume on boot)

Bug #1206235 reported by Andy Whitcroft on 2013-07-29
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
lvm2 (Ubuntu)
High
Andy Whitcroft
Precise
Medium
Andy Whitcroft
Raring
High
Andy Whitcroft
Saucy
High
Andy Whitcroft

Bug Description

When booting a system which has LVM volumes which are MD raid1 targets they will be resync'd in full in the initrd every time you boot. This leads to boot timeouts and enormous boot delays.

Andy Whitcroft (apw) wrote :

If you boot break=bottom you find that LVM is unable to start those volumes, and it is unable to determine their current sync state. This seems to trigger some sort of manual initialisation of the volumes.

Confirmed that this affects both saucy and raring.

Changed in lvm2 (Ubuntu):
status: New → In Progress
importance: Undecided → High
assignee: nobody → Andy Whitcroft (apw)
Andy Whitcroft (apw) wrote :

Further targetting this to precise as that also will support these via the backports kernels.

summary: - lvm2 does a full resync on every MD raid1 mirror volume on boot
+ initramfs is missing dm_raid dm target (lvm2 does a full resync on every
+ MD raid1 mirror volume on boot)
Andy Whitcroft (apw) wrote :

Ok this seems to be triggered by the lack of the dm_raid dm target in the initramfs which prevents us from converting the configuration we have for these LVS into device mapper targets, and leads to this suboptimal copying.

Changed in lvm2 (Ubuntu Raring):
status: New → In Progress
Changed in lvm2 (Ubuntu Precise):
status: New → In Progress
Changed in lvm2 (Ubuntu Raring):
importance: Undecided → High
Changed in lvm2 (Ubuntu Precise):
importance: Undecided → Medium
Changed in lvm2 (Ubuntu Raring):
assignee: nobody → Andy Whitcroft (apw)
Changed in lvm2 (Ubuntu Precise):
assignee: nobody → Andy Whitcroft (apw)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lvm2 - 2.02.98-1ubuntu4

---------------
lvm2 (2.02.98-1ubuntu4) saucy; urgency=low

  * hooks/lvm2: add dm_raid to the dm personality modules to be included in
    the initramfs as this is a valid personality for the root filesystem
    and such volumes lead to extended boot times and boot failures.
    (LP: #1206235)
 -- Andy Whitcroft <email address hidden> Mon, 29 Jul 2013 20:37:28 +0100

Changed in lvm2 (Ubuntu Saucy):
status: In Progress → Fix Released
Rolf Leggewie (r0lf) wrote :

raring has seen the end of its life and is no longer receiving any updates. Marking the raring task for this ticket as "Won't Fix".

Changed in lvm2 (Ubuntu Raring):
status: In Progress → Won't Fix
Andy Whitcroft (apw) on 2015-01-21
Changed in lvm2 (Ubuntu Precise):
status: In Progress → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers