Ubuntu

dmeventd package is missing libdevmapper-event-lvm2mirror.so and libdevmapper-event-lvm2snapshot.so

Reported by William Schaub on 2013-04-28
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
lvm2
Undecided
auto-lvm-devel
lvm2 (Ubuntu)
Medium
Dimitri John Ledkov

Bug Description

Under precise I tried to set up a test mirrored logical volume. but when I run vgchange --monitor y testvg
I get the following error:
  testvg-pics: event registration failed: 9087:3 libdevmapper-event-lvm2mirror.so dlopen failed: libdevmapper-event-lvm2mirror.so: cannot open shared object file: No such file or directory

So I downloaded the package source and included the libs in the dmeventd package. and ran into an undefined symbol in liblvm2cmd

I fixed that too and now everything seems to work as intended. I'm including my patch against the precise version of the lvm2 package.

William Schaub (wschaub) on 2013-04-28
description: updated

The attachment "ensure liblvm2cmd is linked against the right libs and dmeventd includes the right events libs." seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Rajiv Shah (compukid) on 2013-05-24
Changed in lvm2 (Ubuntu):
status: New → Confirmed
Changed in lvm2 (Ubuntu):
assignee: nobody → Dmitrijs Ledkovs (xnox)
Changed in lvm2 (Ubuntu):
status: Confirmed → In Progress
Changed in lvm2:
status: New → Invalid
Changed in lvm2 (Ubuntu):
importance: Undecided → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

  • auto-lvm-devel Edit

Bug watches keep track of this bug in other bug trackers.