does not ship clvm init script

Bug #1037033 reported by Dimitri John Ledkov on 2012-08-15
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
lvm2 (Ubuntu)
High
Dimitri John Ledkov
Precise
Undecided
Unassigned
Quantal
High
Dimitri John Ledkov

Bug Description

In the ubuntu changes there is an entry:
  - do not install init scripts for lvm2, since udev starts LVM.

But the corresponding debdiff between ubuntu & debian has these two hunks:

 install_clvm: export DH_OPTIONS = -pclvm
 install_clvm: DIR = $(BUILD_DIR)/install_deb
 install_clvm: $(STAMPS_DIR)/install_deb
+ mkdir -p $(BUILD_DIR)/install_deb/usr/lib/ocf/resource.d/lvm2
+ install -m 755 debian/clvmd.ra $(BUILD_DIR)/install_deb/usr/lib/ocf/resource.d/lvm2/clvmd
  +$(MAKE_SELF) install-base-prep INSTALL_DIR='$(DIR)'
- dh_installinit --no-start -- start 63 S . start 51 0 6 .
  +$(MAKE_SELF) install-base

 install_lvm2: export DH_OPTIONS = -plvm2
 install_lvm2: DIR = $(BUILD_DIR)/install_deb
 install_lvm2: $(STAMPS_DIR)/install_deb
  +$(MAKE_SELF) install-base-prep INSTALL_DIR='$(DIR)'
+ rm -rf debian/lvm2/usr/share/initramfs-tools/scripts/local-top
+ chmod +x -R debian/lvm2/usr/share/initramfs-tools
  dh_installinit --no-start -- start 26 S .
  +$(MAKE_SELF) install-base

Thus a redundant lvm2 init script is shipped, and clvm init script is not shipped.
Which can also be confirmed by:
http://packages.ubuntu.com/quantal/amd64/clvm/filelist
http://packages.ubuntu.com/quantal/amd64/lvm2/filelist

Related branches

Changed in lvm2 (Ubuntu):
status: New → Confirmed
importance: Undecided → High
assignee: nobody → Dmitrijs Ledkovs (dmitrij.ledkov)
Launchpad Janitor (janitor) wrote :
Download full text (5.2 KiB)

This bug was fixed in the package lvm2 - 2.02.95-4ubuntu1

---------------
lvm2 (2.02.95-4ubuntu1) quantal; urgency=low

  * Merge from Debian unstable, remaining changes:
    - debian/patches/avoid-dev-block.patch: Prefer any other device name over
      names in /dev/block/ since lvm.conf won't handle this.
    - debian/rules:
      - copy .po file to .pot file for Rosetta (Ubuntu specific).
    - debian/{dmsetup,lvm2}-udeb.install:
      - install initramfs and udev hooks in udebs (Debian bug 504341).
    - auto-start VGs as their PVs are discovered (Ubuntu specific):
      - add debian/tree/lvm2/lib/udev/rules.d/85-lvm2.rules: use watershed plus
        the sledgehammer of vgscan/vgchange to turn on VGs as they come online.
      - debian/tree/lvm2/usr/share/initramfs-tools/scripts/hooks/lvm2:
        - add 85-lvm2.rules to the list of udev rules to copy.
        - depend on udev.
      - debian/control:
        - add versioned Depend on watershed in lvm2 for udev rules.
        - add Depends on watershed-udeb in lvm2-udeb for udev rules.
        - add versioned Depend/Breaks on udev in dmsetup for udev rules.
        - add Depend on initramfs-tools in dmsetup so system is not potentially
          rendered unbootable by out-of-order dpkg configuration.
      - debian/rules:
        - do not install local-top scripts since Ubuntu mounts root using udev.
        - do not install init scripts for lvm2, since udev starts LVM.
      - debian/lvm2.postinst: handle missing lvm2 init script.
      - debian/tree/dmsetup/lib/udev/rules.d/60-persistent-storage-dm.rules:
        watch dm devices for changes with inotify
    - add mountroot failure hooks to help fix bad boots (Debian bug 468115):
      - debian/tree/lvm2/usr/share/initramfs-tools/scripts/init-premount/lvm2
    - remaining changes to upstream event manager packages (Debian bug 514706):
      - debian/rules:
        - enable dmeventd during configure.
      - debian/dmeventd.{8,manpages}: install dmeventd files.
    - rename debian/clvm.defaults to debian/clvm.default so it is installed
      correctly.
    - debian/control: add dmsetup-udeb to libdevmapper1.02.1-udeb recommends.
    - debian/rules: make sure dmsetup and lvm2 initramfs-tools scripts are
      executable. When the Ubuntu-specific ones are added with a patch,
      they may lose their executable bit.
    - Add and install clvmd resource agent
    - Add dependency on libudev-dev to libdevmapper-dev so that the .pc file
      works.
    - debian/{clvmd.ra,clvm.init}:
      - create /run/lvm if it doesn't exist.
    - debian/clvm.init:
      - exit 3 if not running on status action.
    - Call dh_installman so that our dmeventd manpage actually gets installed
    - Install the missing fsadm manpage.

   * libdevmapper-dev:
    - move .so symlinks and pkgconfig files to multiarched locations.
    - mark libdevmapper-dev M-A: same

   * libdevmapper-event1.02.1:
    - Add Breaks: dmeventd (<< 2.02.95-4ubuntu1) due to debian symbol rename

   * debian/lvm2.{preinst,postinst,postrm}:
    - Implement removal of obsolete /etc/init.d/lvm2 conffile, which
      should not have been re-introduced in Quantal.

   * Dropped Changes, ...

Read more...

Changed in lvm2 (Ubuntu Quantal):
status: Confirmed → Fix Released
Dimitri John Ledkov (xnox) wrote :

precise does have clvm init script

Changed in lvm2 (Ubuntu Precise):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers