package libdevmapper-event1.02.1 2:1.02.48-4ubuntu7.1 failed to install/upgrade: ErrorMessage: dependency problems - leaving unconfigured

Bug #1032823 reported by Gkvdon on 2012-08-03
70
This bug affects 14 people
Affects Status Importance Assigned to Milestone
lvm2 (Debian)
Won't Fix
Unknown
lvm2 (Ubuntu)
High
Martin Pitt
Xenial
High
Martin Pitt

Bug Description

Happens after upgrade from 10.04 to 12.04

ProblemType: Package
DistroRelease: Ubuntu 12.04
Package: libdevmapper-event1.02.1
ProcVersionSignature: Ubuntu 3.2.0-27.43-generic 3.2.21
Uname: Linux 3.2.0-27-generic x86_64
ApportVersion: 2.0.1-0ubuntu11
Architecture: amd64
Date: Fri Aug 3 21:40:54 2012
ErrorMessage: ErrorMessage: dependency problems - leaving unconfigured
InstallationMedia: Ubuntu 10.04.1 LTS "Lucid Lynx" - Release amd64 (20100816.1)
SourcePackage: lvm2
Title: package libdevmapper-event1.02.1 2:1.02.48-4ubuntu7.1 failed to install/upgrade: ErrorMessage: dependency problems - leaving unconfigured
UpgradeStatus: Upgraded to precise on 2012-08-03 (0 days ago)

Gkvdon (gkvdon) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in lvm2 (Ubuntu):
status: New → Confirmed
Martin Pitt (pitti) wrote :

Excerpt from log, for convenience:

Unpacking dmsetup (2:1.02.90-2ubuntu1) over (2:1.02.77-6ubuntu2) ...
Preparing to unpack .../libdevmapper1.02.1_2%3a1.02.90-2ubuntu1_amd64.deb ...
Unpacking libdevmapper1.02.1:amd64 (2:1.02.90-2ubuntu1) over (2:1.02.77-6ubuntu2) ...
Preparing to unpack .../libudev1_219-7ubuntu6_amd64.deb ...
Unpacking libudev1:amd64 (219-7ubuntu6) over (204-5ubuntu20.15) ...
Processing triggers for man-db (2.6.7.1-1ubuntu1) ...
Setting up libudev1:amd64 (219-7ubuntu6) ...
dpkg: dependency problems prevent configuration of libdevmapper1.02.1:amd64:
 libdevmapper1.02.1:amd64 depends on dmsetup (>= 2:1.02.90-2ubuntu1); however:
  Package dmsetup is not configured yet.

dpkg: error processing package libdevmapper1.02.1:amd64 (--configure):
 dependency problems - leaving unconfigured

Martin Pitt (pitti) wrote :

Looks like this is due to the circular dependency:

Package: libdevmapper1.02.1
Depends: [...], dmsetup (>= 2:1.02.110-1ubuntu1)

Package: dmsetup
Depends: [...], libdevmapper1.02.1 (>= 2:1.02.107), [...]

Changed in lvm2 (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → High
Changed in lvm2 (Debian):
status: Unknown → Won't Fix
Martin Pitt (pitti) on 2015-12-16
Changed in lvm2 (Ubuntu Xenial):
status: Triaged → Fix Committed
assignee: nobody → Martin Pitt (pitti)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lvm2 - 2.02.133-1ubuntu2

---------------
lvm2 (2.02.133-1ubuntu2) xenial; urgency=medium

  * Lower libdevmapper1.02.1's Depends: dmsetup to a Recommends:. This breaks
    the circular dependency that causes upgrade failures. As dmsetup is
    "Priority: required", this has no other practical consequences.
    (Closes: #586424, LP: #1032823)

 -- Martin Pitt <email address hidden> Wed, 16 Dec 2015 15:55:09 +0100

Changed in lvm2 (Ubuntu Xenial):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.