infinite loop in /etc/grub.d/10_linux while reading image list - "Found linux image: /boot/vmlinuz-2.6.32-16-generic"

Bug #540579 reported by mavgink on 2010-03-17
144
This bug affects 17 people
Affects Status Importance Assigned to Milestone
lupin (Ubuntu)
High
Colin Watson
Karmic
High
Colin Watson
Lucid
Undecided
Unassigned
Maverick
High
Colin Watson
update-manager (Ubuntu)
Undecided
Michael Vogt
Karmic
High
Unassigned
Lucid
Undecided
Michael Vogt
Maverick
Undecided
Michael Vogt

Bug Description

TEST CASE (for the update-manager SRU):
 1. use karmic
 2. install lupin-support
 3. run "update-manager --proposed"
 4. upgrade
 5. verify that there are no regression, no conffile prompt etc

A regression test should be enough, I don't know who to reliable trigger the bug, but given the nature
of the problem its important to avoid regressions.
-----
Binary package hint: memtest86+

I tried to update my 09.10 to the 10.04 alpha 3.

ProblemType: Package
Architecture: i386
Date: Wed Mar 17 23:34:29 2010
Dependencies:

DistroRelease: Ubuntu 10.04
ErrorMessage:
 ErrorMessage: package memtest86+ is not ready for configuration cannot configure (current status `half-installed')
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
NonfreeKernelModules: fglrx
Package: memtest86+ 2.11-3ubuntu5
ProcVersionSignature: Ubuntu 2.6.31-20.58-generic
SourcePackage: memtest86+
Title: package memtest86+ 2.11-3ubuntu5 failed to install/upgrade:
Uname: Linux 2.6.31-20-generic i686

mavgink (mavgink) wrote :
Jean-Baptiste Lallement (jibel) wrote :

Thanks for your report.

The relevant error is
---
Preparing to replace memtest86+ 2.11-3ubuntu5 (using .../memtest86+_4.00-2ubuntu2_i386.deb) ...
Unpacking replacement memtest86+ ...
Generating grub.cfg ...
untu1_i386.deb) ...
Found linux image: /boot/vmlinuz-2.6.32-16-generic
) ...
tu3_i386.deb) ...
 ...
-2ubuntu2_i386.deb) ...
Found linux image: /boot/vmlinuz-2.6.32-16-generic
Found linux image: /boot/vmlinuz-2.6.32-16-generic
Found linux image: /boot/vmlinuz-2.6.32-16-generic
[...]
Found linux image: /boot/vmlinuz-2.6.32-16-generic
Found linux image: /boot/vmlinuz-2.6.32-16-generic
Found linux image: /boot/vmlinuz-2.6.32-16-generic
^Cdpkg: warning: old post-removal script killed by signal (Interrupt)
dpkg - trying script from the new package instead ...
Generating grub.cfg ...
al (Interrupt)
^Cdpkg: warning: old post-removal script killed by signal (Interrupt)
dpkg - trying script from the new package instead ...
Generating grub.cfg ...
^Cdpkg: warning: old post-removal script killed by sign

^Cdpkg: warning: old post-removal script killed by signal (Interrupt)
dpkg - trying script from the new package instead ...
Generating grub.cfg ...
Found linux image: /boot/vmlinuz-2.6.32-16-generic
Found linux image: /boot/vmlinuz-2.6.32-16-generic
[...]
ric
^Cdpkg: error while cleaning up:
 subprocess new post-removal script killed by signal (Interrupt)

It shows some kind of loop.

summary: - package memtest86 2.11-3ubuntu5 failed to install/upgrade: distro
- upgrade from 09.10 to 10.04
+ infinite loop in /etc/grub.d/10_linux while reading image list - "Found
+ linux image: /boot/vmlinuz-2.6.32-16-generic"
affects: memtest86+ (Ubuntu) → grub2 (Ubuntu)
Changed in grub2 (Ubuntu):
importance: Undecided → Medium
Colin Watson (cjwatson) wrote :

I've read through the code very carefully, but at the moment I can't see why this would be happening. There are some changes I could make that would probably make it go away, but I'd like to understand the problem before randomly prodding at possible solutions.

Could somebody affected by this bug please do the following:

  * Edit /etc/grub.d/10_linux (as root) and put 'set -x' (without the quotes) on the second line, that is on the line immediately after '#! /bin/sh -e'.
  * Run 'sudo update-grub >update-grub.out 2>&1' (without the quotes; make sure you type this exactly).
  * Assuming that you hit the same problem, this should run indefinitely. Give it (say) a minute to make sure that it has definitely entered the infinite loop we're seeing here, and then press Control+c.
  * Attach the file update-grub.out to this bug.
  * Undo the change you made to /etc/grub.d/10_linux in the first step.

Thanks in advance!

Changed in grub2 (Ubuntu):
status: New → Incomplete
importance: Medium → High
Jean-Baptiste Lallement (jibel) wrote :

From the duplicates it seems that it only happens when dist-upgrading a wubi system from Karmic to Lucid.

Fair enough, though I still don't see how the loop could fail to
terminate and would like the set -x trace to help me determine that.

Pelias (peliaas) wrote :

Thanks for being interested in this bug.
Jean-Baptiste Lallement seems to be right, it did happen when upgrading wubi system from Karmic to Lucid. I don't see why it would make bug irrelevant though.

Now, reproducing bug will require some amount of time (I'll have to redownload Karmic, reinstall wubi, make proper backups for further testing, downloading all lucid upgrades to make sure it shows up, then going back to backup and running case), but I'll sacrifice some time and will try to get you results as soon as possible (evening or tomorrow).

Alex Salimian (noidea1990) wrote :

On updating my wubi installation a second time from 9.10 to 10.04 I got the same infinite error. It continued after I killed that part but a gui came up asking what partition i would like to install grub to, there was no option for anything wubi so selected nothing and pressed continue.
Afterwards I put the set -x and ran update-grub and i am attaching the output from that.

Colin Watson (cjwatson) wrote :

Alex, unfortunately your log does not show an infinite loop. It seems to complete normally.

Colin Watson (cjwatson) wrote :

However, this gave me a hint - I've been looking in the wrong place. The buggy script is actually /etc/grub.d/10_lupin, not /etc/grub.d/10_linux at all, and on looking at it I see the problem.

affects: grub2 (Ubuntu) → lupin (Ubuntu)
Changed in lupin (Ubuntu):
assignee: nobody → Colin Watson (cjwatson)
status: Incomplete → Triaged
Changed in lupin (Ubuntu Karmic):
status: New → Triaged
importance: Undecided → High
assignee: nobody → Colin Watson (cjwatson)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lupin - 0.29

---------------
lupin (0.29) lucid; urgency=low

  * Fix infinite loop if there's no initrd (LP: #540579).
 -- Colin Watson <email address hidden> Tue, 23 Mar 2010 09:16:15 +0000

Changed in lupin (Ubuntu):
status: Triaged → Fix Released
Colin Watson (cjwatson) wrote :

There's a remaining piece of this, namely that upgrades won't necessarily install the fixed lupin-support in time for it to be used. I've sent mail to a few people asking for advice on this.

jvoung (jvoung) wrote :

Hmm, is this fixed? I just hit the memtest infinite loop bug today while trying to upgrade a wubi install of Karmic to Lucid Lynx, using "udpate-manager -d" ...

Just tried this the second time again and have the same loop.
attempting to upgrade wubi install 9.10 to 10.04

Michael Vogt (mvo) on 2010-04-30
Changed in update-manager (Ubuntu Karmic):
milestone: none → karmic-updates
importance: Undecided → High
status: New → In Progress
description: updated

Accepted update-manager into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in update-manager (Ubuntu Maverick):
assignee: nobody → Michael Vogt (mvo)
Changed in update-manager (Ubuntu Lucid):
assignee: nobody → Michael Vogt (mvo)
status: New → Fix Committed
tags: added: verification-needed
perezcuesta (perezcuesta) wrote :

An inquiry, please: is available the package to update into lucid from karmic wubi installed? Thank you very much.

Fabio Marconi (fabiomarconi) wrote :

Testcase verified: OK
No regression, no prompt.

Martin Pitt (pitti) on 2010-05-09
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package update-manager - 1:0.134.8

---------------
update-manager (1:0.134.8) lucid-proposed; urgency=low

  * DistUpgrade/DistUpgradeCache.py:
    - show pulse while calculating the changes (LP: #548398)
  * DistUpgrade/DistUpgradeQuirks.py:
    - add workaround for 10_lupin infinite loop (LP: #540579)
      Thanks to Juergen Klar for providing the test-case
  * DistUpgrade/10_lupin:
    - include (fixed) lucid version of 10_lupin that fixes a possible
      infinite loop on upgrade
 -- Michael Vogt <email address hidden> Fri, 30 Apr 2010 17:08:46 +0200

Changed in update-manager (Ubuntu Lucid):
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

Copied update-manager lucid-proposed to maverick.

Changed in update-manager (Ubuntu Maverick):
status: New → Fix Released
Rolf Leggewie (r0lf) on 2011-10-19
Changed in lupin (Ubuntu Karmic):
status: Triaged → Won't Fix
Changed in update-manager (Ubuntu Karmic):
status: In Progress → Won't Fix
Rolf Leggewie (r0lf) wrote :

lucid has seen the end of its life and is no longer receiving any updates. Marking the lucid task for this ticket as "Won't Fix".

Changed in lupin (Ubuntu Lucid):
status: New → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers