Please merge lucene2_2.4.0+ds1-1 (universe) from Debian unstable (main)

Bug #300540 reported by Nick Ellery on 2008-11-21
4
Affects Status Importance Assigned to Milestone
lucene2 (Debian)
Fix Released
Unknown
lucene2 (Ubuntu)
Undecided
Unassigned

Bug Description

Please merge lucene2_2.4.0+ds1-1 (universe) from Debian unstable (main)

 lucene2 (2.4.0+ds1-1) unstable; urgency=low

   * New upstream version (2 patches patched)
   * Add DM-Upload-Allowed: Yes to debian/control

 -- Jan-Pascal van Best <email address hidden> Sat, 11 Oct 2008 22:46:02 +0200

Related branches

Onkar Shinde (onkarshinde) wrote :

Nick,

Are you going to work on this bug or do you expect someone else to look into it?
If you are expecting someone else to look into it then please assign this to me.

Nick Ellery (nick.ellery) wrote :

Hi,

I'm fine with somebody else taking over this, I'll assign it to you.

Thanks,
Nick

Changed in lucene2:
assignee: nobody → onkarshinde
Onkar Shinde (onkarshinde) wrote :

Please find attached the debdiff against Debian's version.

Following changes from previous Ubuntu version are dropped as they are not needed anymore.
1. - debian/control
       * Add w3c-dtd-xhtml as build dependency to fix FTBFS.
2. - debian/patches
       * 82_fix_xhtml_dtd_access.dpatch - Patch for fixing contrib unit tests. Fixes FTBFS on buildd.
       * 00list - Updated to include above patch

Changed in lucene2:
assignee: onkarshinde → nobody
status: New → Confirmed
James Westby (james-w) wrote :

Hi,

Is it really worth merging for this change?

Has the fact that the patch is no longer needed been reported to Debian?

Thanks,

James

Onkar Shinde (onkarshinde) wrote :

James,

Considering that how slow packages are moving these days in Debian because of lenny freeze I didn't bother to report. But now that you mention it I will report it and see if I get any reply within this week, so that we can do a sync later. Of course I will have to first verify that package builds properly in Debian pbuilder chroot.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lucene2 - 2.4.0+ds1-2ubuntu1

---------------
lucene2 (2.4.0+ds1-2ubuntu1) jaunty; urgency=low

  * Merge from debian unstable. (LP: #300540)
  * Remaining Ubuntu changes:
    - debian/patches
      * 00list - Remove Debian's patch 81_prevent-network-access.dpatch. Not
        needed anymore.
    - debian/control
       * Modify Maintainer value to match the DebianMaintainerField
         specification.

lucene2 (2.4.0+ds1-2) unstable; urgency=low

  * switch to libdb4.6-java as we need the armel binary of it since OOo/armel
    needs us
  * add myself to Uploaders:

lucene2 (2.4.0+ds1-1) unstable; urgency=low

  * New upstream version (2 patches patched)
  * Add DM-Upload-Allowed: Yes to debian/control

 -- Onkar Shinde <email address hidden> Sat, 22 Nov 2008 05:22:42 +0530

Changed in lucene2:
status: Confirmed → Fix Released
Changed in lucene2:
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.