software-center crashed with GError in constructor(): Format der Bilddatei unbekannt

Bug #971776 reported by Sasa Paporovic on 2012-04-02
34
This bug affects 4 people
Affects Status Importance Assigned to Milestone
lubuntu-software-center (Ubuntu)
Medium
Michael Vogt
Precise
Medium
Unassigned

Bug Description

I am on Ubuntu12.04 64bit updated to 2.3.2012.

The Software center crashed on the search term"python".

[TEST CASE]
This crash occurs only intermittently under certain conditions when an image download fails. As such, this error can't be reliably reproduced. However, to test, you can fully exercise this code by clearing the downloaded icon cache and then reloading them per the following steps:
1. Install the version of software-center in precise-proposed.
2. With Software Center not running, execute the following in a terminal:

    $ cd ~/.cache/software-center/icons
    $ rm *

3. Launch Software Center and navigate to "All Software" -> "For Purchase"
4. Verify that as you scroll the list the application icons are loaded in the view.

[REGRESSION POTENTIAL]
Very low. If a regression were to occur, it would manifest as "generic" icons appearing in the list views or the details view.

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: software-center 5.1.14
ProcVersionSignature: Ubuntu 3.2.0-21.34-generic 3.2.13
Uname: Linux 3.2.0-21-generic x86_64
ApportVersion: 2.0-0ubuntu2
Architecture: amd64
CrashCounter: 1
Date: Mon Apr 2 20:19:36 2012
ExecutablePath: /usr/share/software-center/software-center
ExecutableTimestamp: 1333128425
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta amd64+mac (20120328)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/software-center
ProcCwd: /home/user
ProcEnviron:
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
PythonArgs: ['/usr/bin/software-center']
SourcePackage: software-center
Title: software-center crashed with GError in constructor(): Format der Bilddatei unbekannt
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Related branches

Sasa Paporovic (melchiaros) wrote :
visibility: private → public
tags: removed: need-duplicate-check
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in software-center (Ubuntu):
status: New → Confirmed
Fredferrao (fredferrao) wrote :

Ubuntu 64bit here.

Open software center, search dropbox, click install, then it crashed

Michael Vogt (mvo) wrote :

This is a pretty common error according to errors.ubuntu.com so we need to SRU a fix.

Changed in software-center (Ubuntu):
importance: Undecided → Medium
milestone: none → precise-updates
tags: added: ca-escalated
Minye Hla (minyehla-ysm) wrote :

i don't know

Michael Vogt (mvo) on 2012-06-05
Changed in software-center (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Michael Vogt (mvo)
Changed in software-center (Ubuntu Precise):
status: New → In Progress
importance: Undecided → Medium
description: updated
Changed in software-center (Ubuntu Precise):
status: In Progress → Fix Committed
Changed in software-center (Ubuntu):
status: In Progress → Fix Committed
tags: removed: ca-escalated
Changed in software-center (Ubuntu Precise):
milestone: none → precise-updates
Changed in software-center (Ubuntu):
milestone: precise-updates → none

Hello melchiaros, or anyone else affected,

Accepted software-center into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/software-center/5.2.4 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed
description: updated
Sasa Paporovic (melchiaros) wrote :

Have done five times with software center 5.2.4.

No crash.

I set it to verification-done.

tags: added: verification-done
removed: verification-needed
Gary Lasker (gary-lasker) wrote :

I have verified that software-center version 5.2.4 in precise-proposed fixes this bug per the test case given in the description.

Thanks!

Changed in software-center (Ubuntu):
status: Fix Committed → Fix Released
Gary Lasker (gary-lasker) wrote :

Thanks for your verification, melchiaros!!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 5.2.4

---------------
software-center (5.2.4) precise-proposed; urgency=low

  [ Michael Vogt ]
  * lp:~mvo/software-center/lp970627:
    - fix intermittent crash when expunging the cache (LP: #970627)
  * lp:~mvo/software-center/lp971776:
    - fix crash when a downloaded image is invalid for whatever
      reason (network issues, proxy issues, pay-wall in between)
      (LP: #971776)
  * lp:~mvo/software-center/lp967036-2:
    - fix unicode error crash for people running with the
      LANGUAGE=zh_CN.UTF-8 or zh_TW.UTF-8 (LP: #967036)
  * lp:~mvo/software-center/cookie-jar:
    - fix paypal support in the purchases window (LP: #1018347)

  [ Gary Lasker ]
  * debian/control:
    - update vcs link to point to the 5.2 branch
  * lp:~gary-lasker/software-center/previous-purchase-sorting-lp873104:
    - return correct results when sorting the list of previous
      purchases (LP: #873104)
  * lp:~gary-lasker/software-center/recommendations-string-change-lp986437-for-5.2:
    - switch to the updated recommendations opt-in string now that the
      corresponding language pack updates are released and available
      (LP: #986437)
  * lp:~gary-lasker/software-center/fix-lp920741:
    - fix UnicodeDecodeError when a commercial app's title contains
      a unicode character (LP: #920741)

  [ Natalia Bidart ]
  * lp:~nataliabidart/software-center/cant-stop-the-music:
    - Stop the video if user navigates away from an app details page
      (LP: #1003954).
 -- Michael Vogt <email address hidden> Thu, 28 Jun 2012 10:35:55 +0200

Changed in software-center (Ubuntu Precise):
status: Fix Committed → Fix Released
affects: software-center (Ubuntu) → lubuntu-software-center (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers