The lubuntu software centre is not showing any other software execpt the ones already installed on my computer.

Bug #1078820 reported by Ibrahim Musa on 2012-11-14
48
This bug affects 9 people
Affects Status Importance Assigned to Milestone
Lubuntu Software Center
Undecided
Unassigned
lubuntu-software-center (Ubuntu)
Undecided
Unassigned

Bug Description

The lubuntu software centre is not showing softwares except the ones already installed. I have updated the repositories and synaptic package manager is showing them. But lubuntu software centre not.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: lubuntu-software-center 0.0.5~bzr135-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-23.36-generic 3.2.14
Uname: Linux 3.2.0-23-generic i686
ApportVersion: 2.0.1-0ubuntu5
Architecture: i386
Date: Wed Nov 14 22:59:05 2012
EcryptfsInUse: Yes
InstallationMedia: Lubuntu 12.04 "Precise Pangolin" - Release i386 (20120423.1)
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=en_IN:en
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_IN
 SHELL=/bin/bash
SourcePackage: lubuntu-software-center
UpgradeStatus: No upgrade log present (probably fresh install)

Ibrahim Musa (astazidt) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in lubuntu-software-center (Ubuntu):
status: New → Confirmed
Phill Whiteside (phillw) wrote :

Also affects 12.10 Amd64 release.

Julien Lavergne (gilir) wrote :

It's because the apt cache is not up-to-date. if you run "sudo apt-get update", close and re-open LSC, it should show all the applications.
Still, LSC should detects this and update the cache itself

Phill Whiteside (phillw) wrote :

I have run "sudo apt-get update", which I believe had already been tried. LSC cannot find applications that have been installed via synaptics... E.g. on my installing bluefish editor, Lubuntu Menu correctly added a new menu entry called "Programming". LSC cannot see this group, nor can it see the fact I have firefox installed when I check out the list of installed applications under 'Internet'.
I have installed lubuntu-12.04-alternate-amd64.iso via KVM and it shows the same problem upon installation. I will ask 12.04 to fully update and report back the result.

Phill Whiteside (phillw) wrote :

The same behavior is seen in my updated 12.04 (64Bit) Installation on KVM.

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1078820

tags: added: iso-testing
David Conner (dlbike76) wrote :

I think I am hitting this bug in the current (20121215) daily lubuntu-desktop image. I tried updating the cache as suggested, but that did not seem to resolve the problem.

I'm unable to see even currently installed software under LSC.

I added a tag for raring

Thanks,

David

tags: added: raring
warren (wkclemmons) wrote :

Lubuntu 13.04 LSC
Did apt-get update still no packages are displayed after clicking the package category. After clicking the installed software no packages are displayed.

warren (wkclemmons) wrote :

Also affecting me on Lubuntu Raring beta. Was working in 12.10.

Jaimy de Bree (jdbxyz) wrote :

I can also confirm this bug of LSC not showing any software in Raring beta 3.
I get the following error trying to reinstall LSC:

Traceback (most recent call last):
  File "/usr/sbin/lubuntu-software-center-build-db", line 103, in <module>
    single_pkg = DE.DesktopEntry(base_folder+item)
  File "/usr/lib/python2.7/dist-packages/xdg/DesktopEntry.py", line 33, in __init__
    self.parse(filename)
  File "/usr/lib/python2.7/dist-packages/xdg/DesktopEntry.py", line 42, in parse
    IniFile.parse(self, file, ["Desktop Entry", "KDE Desktop Entry"])
  File "/usr/lib/python2.7/dist-packages/xdg/IniFile.py", line 81, in parse
    raise ParsingError("Invalid line: " + line, filename)
xdg.Exceptions.ParsingError

The problem is the /var/cache/lsc_packages.db stays empty after install.
It does work in 12.10, hope this gets fixed before the release.

Phill Whiteside (phillw) wrote :

My hunt for a reasonably competent python programmer to maintain LSC have been in vain. Until someone succeeds LSC is not getting updates / bug fixes. Sorry about this, I do keep trying!

Jaimy de Bree (jdbxyz) wrote :

Downgrading python-xdg to Quantal fixes the database building.
Then I had problems with LSC itself; only showing installed packages, so also downgraded that to Quantal.
Now it works fine.

Phill Whiteside (phillw) wrote :

Replace /usr/share/pyshared/LSC/threadingops.py with the attached file. When LSC is started it will ask for the admin password and then build the database to include all the installed applications.

The attachment "threadingops.py" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lubuntu-software-center - 0.0.5~bzr161-0ubuntu1

---------------
lubuntu-software-center (0.0.5~bzr161-0ubuntu1) saucy; urgency=low

  * New upstream snapshot.
   - Rebuild database when LSC start if there is no database (LP: #1078820).
 -- Julien Lavergne <email address hidden> Sun, 30 Jun 2013 23:25:50 +0200

Changed in lubuntu-software-center (Ubuntu):
status: Confirmed → Fix Released
Jackson Doak (noskcaj) on 2013-10-06
Changed in lubuntu-software-center:
status: New → Fix Committed
Jackson Doak (noskcaj) on 2015-02-24
Changed in lubuntu-software-center:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers