[12.04] gnome-session is trying to install unity on lubuntu

Bug #903895 reported by Michael Basse on 2011-12-13
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
lubuntu-meta (Ubuntu)
Undecided
Julien Lavergne

Bug Description

dist-upgrade on 12.04 (lubuntu) is trying to install unity but ubuntu-desktop is not installed. So this is a clean lubuntu-system

The following NEW packages will be installed:
  apg appmenu-gtk appmenu-gtk3 appmenu-qt bamfdaemon compiz compiz-core compiz-gnome
  compiz-plugins-default compiz-plugins-main-default compizconfig-backend-gconf geoclue
  geoclue-ubuntu-geoip gnome-control-center gnome-control-center-data gnome-desktop-data
  gnome-icon-theme-symbolic gnome-menus gnome-online-accounts gnome-session gnome-session-bin
  gnome-session-common gnome-settings-daemon indicator-appmenu indicator-datetime indicator-messages
  indicator-power indicator-session indicator-sound indicator-status-provider-mc5 libbamf3-0
  libboost-serialization1.46.1 libcompizconfig0 libdbusmenu-qt2 libdecoration0 libglew1.5
  libglewmx1.5 libglib2.0-bin libgnome-menu-3-0 libgnome-menu2 libido3-0.1-0
  libindicator-messages-status-provider1 libmetacity-private0 libnux-1.0-0 libnux-1.0-common
  libtelepathy-glib0 libunity-core-4.0-4 libunity-misc4 libwnck-3-0 libwnck-3-common libwnck-common
  libwnck22 libxres1 libzeitgeist-1.0-1 metacity-common mousetweaks nux-tools ubuntu-docs
  ubuntu-system-service unity unity-asset-pool unity-common unity-lens-applications unity-lens-files
  unity-lens-music unity-scope-musicstores unity-services
The following packages will be upgraded:
  gir1.2-gnomebluetooth-1.0 gir1.2-gtk-3.0 gnome-bluetooth libgail-3-0 libgnome-bluetooth8
  libgtk-3-0 libgtk-3-bin libgtk-3-common libxerces2-java pppconfig python3.2 python3.2-minimal
12 upgraded, 67 newly installed, 0 to remove and 0 not upgraded.
Need to get 22.2 MB of archives.
After this operation, 55.2 MB of additional disk space will be used.

if i get this output correctly, xinit is causing this

michael@eeebuntu:~$ sudo aptitude why unity
i xinit Recommends xterm | x-session-manager | x-window-manager | x-terminal-emulator
p gnome-session Provides x-session-manager
p gnome-session Recommends unity | unity-2d | gnome-shell (>= 3.0)

the dependencies should be fixed, because on a lubuntu-system you dont want unity or other stuff which does not belong to lxde

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: xinit 1.3.1-1
ProcVersionSignature: Ubuntu 3.2.0-4.10-generic 3.2.0-rc5
Uname: Linux 3.2.0-4-generic i686
ApportVersion: 1.90-0ubuntu1
Architecture: i386
Date: Tue Dec 13 20:42:10 2011
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release i386 (20110426)
ProcEnviron:
 PATH=(custom, no user)
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
SourcePackage: xinit
UpgradeStatus: Upgraded to precise on 2011-12-04 (9 days ago)

sudo apt-get install xinit is not installing unity, so i dont know which package is trying to install unity.

maybe you have some apt/aptitude/dpkg-foo for me to provide better informations.

summary: - [12.04] xinit is trying to install unity on lubuntu
+ [12.04] dist-upgrade is trying to install unity on lubuntu

gnome-bluetooth is the reason. gnome-bluetooth is installed on my lubuntu and the newest version will pull some stuff

michael@eeebuntu:~$ sudo apt-get install gnome-bluetooth
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
  apg appmenu-gtk appmenu-gtk3 appmenu-qt bamfdaemon compiz compiz-core compiz-gnome compiz-plugins-default compiz-plugins-main-default
  compizconfig-backend-gconf geoclue geoclue-ubuntu-geoip gir1.2-gnomebluetooth-1.0 gnome-control-center gnome-control-center-data
  gnome-desktop-data gnome-icon-theme-symbolic gnome-menus gnome-online-accounts gnome-session gnome-session-bin gnome-session-common
  gnome-settings-daemon indicator-appmenu indicator-datetime indicator-messages indicator-power indicator-session indicator-sound
  indicator-status-provider-mc5 libbamf3-0 libboost-serialization1.46.1 libcompizconfig0 libdbusmenu-qt2 libdecoration0 libglew1.5
  libglewmx1.5 libglib2.0-bin libgnome-menu-3-0 libgnome-menu2 libido3-0.1-0 libindicator-messages-status-provider1 libmetacity-private0
  libnux-1.0-0 libnux-1.0-common libtelepathy-glib0 libunity-core-4.0-4 libunity-misc4 libwnck-3-0 libwnck-3-common libwnck-common libwnck22
  libxres1 libzeitgeist-1.0-1 metacity-common mousetweaks nux-tools ubuntu-docs ubuntu-system-service unity unity-asset-pool unity-common
  unity-lens-applications unity-lens-files unity-lens-music unity-scope-musicstores unity-services
Suggested packages:
  compizconfig-settings-manager gnome-themes nautilus-sendto desktop-base gnome-session-fallback glew-utils1.5
The following NEW packages will be installed:
  apg appmenu-gtk appmenu-gtk3 appmenu-qt bamfdaemon compiz compiz-core compiz-gnome compiz-plugins-default compiz-plugins-main-default
  compizconfig-backend-gconf geoclue geoclue-ubuntu-geoip gnome-control-center gnome-control-center-data gnome-desktop-data
  gnome-icon-theme-symbolic gnome-menus gnome-online-accounts gnome-session gnome-session-bin gnome-session-common gnome-settings-daemon
  indicator-appmenu indicator-datetime indicator-messages indicator-power indicator-session indicator-sound indicator-status-provider-mc5
  libbamf3-0 libboost-serialization1.46.1 libcompizconfig0 libdbusmenu-qt2 libdecoration0 libglew1.5 libglewmx1.5 libglib2.0-bin
  libgnome-menu-3-0 libgnome-menu2 libido3-0.1-0 libindicator-messages-status-provider1 libmetacity-private0 libnux-1.0-0 libnux-1.0-common
  libtelepathy-glib0 libunity-core-4.0-4 libunity-misc4 libwnck-3-0 libwnck-3-common libwnck-common libwnck22 libxres1 libzeitgeist-1.0-1
  metacity-common mousetweaks nux-tools ubuntu-docs ubuntu-system-service unity unity-asset-pool unity-common unity-lens-applications
  unity-lens-files unity-lens-music unity-scope-musicstores unity-services
The following packages will be upgraded:
  gir1.2-gnomebluetooth-1.0 gnome-bluetooth
2 upgraded, 67 newly installed, 0 to remove and 10 not upgraded.
Need to get 12.2 MB of archives.
After this operation, 54.9 MB of additional disk space will be used.
Do you want to continue [Y/n]?

sudo apt-get install gnome-session is doing the same but it will not upgraded from dist-upgrade.

both are providing x-session-manager

affects: xinit (Ubuntu) → gnome-session (Ubuntu)
summary: - [12.04] dist-upgrade is trying to install unity on lubuntu
+ [12.04] gnome-session is trying to install unity on lubuntu
Sebastien Bacher (seb128) wrote :

the issue is a lubuntu one, gnome-bluetooth does need gnome-control-center since the preferences dialog is a .so for gnome-control-center, the ui can't be displayed without it

Sebastien Bacher (seb128) wrote :

see bug #831488 for a similar issue on xubuntu

Julien Lavergne (gilir) wrote :

Since gnome-bluetooth is useless in Lubuntu, we need to remove it from the seed and find a replacement.

affects: gnome-session (Ubuntu) → lubuntu-meta (Ubuntu)
Changed in lubuntu-meta (Ubuntu):
assignee: nobody → Julien Lavergne (gilir)
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lubuntu-meta - 0.31

---------------
lubuntu-meta (0.31) precise; urgency=low

  * Refreshed dependencies
  * Added ibus to desktop-recommends (LP: #889384)
  * Removed gnome-bluetooth from desktop-recommends (LP: #903895)
 -- Julien Lavergne <email address hidden> Thu, 15 Dec 2011 00:09:27 +0100

Changed in lubuntu-meta (Ubuntu):
status: In Progress → Fix Released

Julien, i can confirm that this fixed the issue. Thank you

ditto tho the "ubuntu 11.10" on the lightdm screen sure freaked me out
for a second. ;)

On 12/14/2011 10:23 PM, Michael Basse wrote:
> Julien, i can confirm that this fixed the issue. Thank you
>

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers