Unable to install on PowerPC

Bug #718087 reported by Carl on 2011-02-13
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
lubuntu-meta (Ubuntu)
High
Julien Lavergne

Bug Description

The lubuntu-desktop meta-package is unable to install on PowerPC machines.

This problem is introduced in v0.18 which is current on maverick and is still present on v0.20 which is current on natty.

The PowerPC arch build of those to versions are trying to install chromium-browser-l10n. This package is available on PowerPC but will not install without chromium-browser. Chromium-browser does not have a PPC build and most likely never will. So untill chromium-browser-l10n is removed from desktop-powerpc, powerpc users will not be able to install the lubuntu-desktop package.

Sorry this is my first bug report hopefully enough information was given.

1) The release of Ubuntu you are using, via 'lsb_release -rd' or System -> About Ubuntu
Ubuntu 11.04 natty pre-release

2) The version of the package you are using, via 'apt-cache policy pkgname' or by checking in Software Center
0.20 lubuntu-desktop

3) What you expected to happen
install packages listed to install

4) What happened instead
says can't install because dependices issues with chromium-browser-l10n

tags: added: lubuntu
Jonathan Marsden (jmarsden) wrote :

I do not think PowerPC is a currently supported CPU architecture for Lubuntu 11.04, the only ISOs produced for Lubuntu 11.04 Alpha testing so far have been i386 ISOs.

Regarding those wishing to install the lubuntu-desktop package after the fact on PPC machines, surely those folks (probably people familiar with PPC and using older versions of Linux) are generally competent enough with the relevant tools to examine the Depends: list of the package specifies, and install all of them except chromium-browser , if they so choose. lubuntu-desktop is simply a meta-package, so there is no loss of code or functionality in doing this. The Lubuntu team has made a deliberate decision that its default browser is now chromium-browser, so if that package is not and will not be available for older PPC machines, that is unfortunate, but not (as I see it) something to be overly concerned by.

If Lubuntu ever does create PPC ISOs it will need to do something different, but I suspect there are more pressing work items for the team at the moment :)

Suggested workaround:

  sudo apt-get install abiword, ace-of-penguins, alsa-base, alsa-utils, anacron, apport-gtk, audacious, audacious-plugins, cron, cups-driver-gutenprint, desktop-file-utils, evince, file-roller, galculator, gdebi, gecko-mediaplayer, gksu, gnome-bluetooth, gnome-disk-utility, gnome-keyring, gnome-mplayer, gnome-power-manager, gnome-system-tools, gnumeric, gnumeric-doc, gpicview, gucharmap, gvfs-backends, gvfs-fuse, hardinfo, icedtea-plugin, jockey-gtk, language-selector-gnome, leafpad, logrotate, lubuntu-core, lxappearance, lxappearance-obconf, lxdm, lxinput, lxkeymap, lxlauncher, lxpanel-indicator-applet-plugin, lxrandr, lxsession-edit, lxshortcut, lxtask, lxterminal, lzma, modemmanager, mtpaint, network-manager-gnome, ntp, nvidia-common, obconf, osmo, pcmciautils, pidgin, pidgin-libnotify, pm-utils, policykit-desktop-privileges, ppp, scrot, simple-scan, software-properties-gtk, sylpheed, sylpheed-doc, sylpheed-i18n, sylpheed-plugins, synaptic, system-config-printer-gnome, transmission, ttf-indic-fonts-core, ttf-kacst-one, ttf-khmeros-core, ttf-lao, ttf-liberation, ttf-punjabi-fonts, ttf-takao-pgothic, ttf-thai-tlwg, ttf-ubuntu-font-family, ttf-unfonts-core, ttf-wqy-microhei, ubuntu-extras-keyring, unzip, update-notifier, usb-modeswitch, wireless-tools, wpasupplicant, wvdial, x11-utils, xchat, xdg-user-dirs, xfburn, xpad, xscreensaver, zip

Then add another browser of your choice, that is packaged for PPC.

Tm_T (Jussi Kekkonen) (tmt) wrote :

Just to make the obvious thing clear and avoid any misinterpration: in text "so if that package is not and will not be available for older PPC machines" the "older" should be omitted, no any PPC is supported in this case.

Julien Lavergne (gilir) on 2011-07-08
Changed in lubuntu-meta (Ubuntu):
status: New → In Progress
importance: Undecided → High
assignee: nobody → Julien Lavergne (gilir)
Launchpad Janitor (janitor) wrote :
Download full text (3.3 KiB)

This bug was fixed in the package lubuntu-meta - 0.25

---------------
lubuntu-meta (0.25) oneiric; urgency=low

  * Update to oneiric
  * Update branch location for the Lubuntu seed.
  * Remove multiverse support, not needed
  * Refreshed dependencies
  * Added lightdm to desktop
  * Added lightdm-greeter-example-gtk to desktop
  * Removed anacron from desktop
  * Removed chromium-browser-l10n from desktop (LP: #718087)
  * Removed cron from desktop
  * Removed gecko-mediaplayer from desktop
  * Removed gksu from desktop
  * Removed gnumeric-doc from desktop
  * Removed logrotate from desktop
  * Removed lxdm from desktop
  * Removed mobile-broadband-provider-info from desktop
  * Removed modemmanager from desktop
  * Removed pidgin-libnotify from desktop
  * Removed ppp from desktop
  * Removed software-properties-gtk from desktop
  * Removed usb-modeswitch from desktop
  * Removed xchat from desktop
  * Moved abiword to desktop-recommends
  * Moved ace-of-penguins to desktop-recommends
  * Moved apport-gtk to desktop-recommends
  * Moved audacious to desktop-recommends
  * Moved audacious-plugins to desktop-recommends
  * Moved chromium-browser to desktop-recommends [amd64 armel i386]
  * Moved galculator to desktop-recommends
  * Moved gnome-disk-utility to desktop-recommends
  * Moved gnome-mplayer to desktop-recommends
  * Moved gnome-time-admin to desktop-recommends
  * Moved gnumeric to desktop-recommends
  * Moved gucharmap to desktop-recommends
  * Moved guvcview to desktop-recommends
  * Moved hardinfo to desktop-recommends
  * Moved jockey-gtk to desktop-recommends
  * Moved lxappearance to desktop-recommends
  * Moved lxappearance-obconf to desktop-recommends
  * Moved lxinput to desktop-recommends
  * Moved lxpanel-indicator-applet-plugin to desktop-recommends
  * Moved lxrandr to desktop-recommends
  * Moved lxsession-edit to desktop-recommends
  * Moved lxshortcut to desktop-recommends
  * Moved lxtask to desktop-recommends
  * Moved lzma to desktop-recommends
  * Moved mtpaint to desktop-recommends
  * Moved ntp to desktop-recommends
  * Moved nvidia-common to desktop-recommends [amd64 i386]
  * Moved obconf to desktop-recommends
  * Moved osmo to desktop-recommends
  * Moved pidgin to desktop-recommends
  * Moved simple-scan to desktop-recommends
  * Moved sylpheed to desktop-recommends
  * Moved sylpheed-doc to desktop-recommends
  * Moved sylpheed-i18n to desktop-recommends
  * Moved sylpheed-plugins to desktop-recommends
  * Moved transmission to desktop-recommends
  * Moved ttf-indic-fonts-core to desktop-recommends
  * Moved ttf-kacst-one to desktop-recommends
  * Moved ttf-khmeros-core to desktop-recommends
  * Moved ttf-lao to desktop-recommends
  * Moved ttf-liberation to desktop-recommends
  * Moved ttf-punjabi-fonts to desktop-recommends
  * Moved ttf-takao-pgothic to desktop-recommends
  * Moved ttf-thai-tlwg to desktop-recommends
  * Moved ttf-ubuntu-font-family to desktop-recommends
  * Moved ttf-unfonts-core to desktop-recommends
  * Moved ttf-wqy-microhei to desktop-recommends
  * Moved unzip to desktop-recommends
  * Moved xfburn to desktop-recommends
  * Moved xpad to desktop-recommends
  * Moved xscreensave...

Read more...

Changed in lubuntu-meta (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers