Add gvfs-backends to lubuntu-desktop

Bug #675212 reported by Julien Lavergne on 2010-11-14
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
lubuntu-meta (Ubuntu)
Medium
Julien Lavergne
Maverick
Undecided
Unassigned

Bug Description

Add gvfs-backends to lubuntu-desktop to add support for SMB, gphoto etc ... in pcmanfm using gvfs.

SRU explanation:
1. Without gvfs-backend, pcmanfm lacks support for network browing by default, which is one of the most bug report on Lubuntu.
2. The bugs was fixed on Natty by adding gvfs-backends to the seed
3. You can find the diff on http://bazaar.launchpad.net/~lubuntu-desktop/+junk/lubuntu-meta-maverick/revision/53
4. To verify, install Lubuntu and try to navigate in network shares with pcmanfm (which should not work). Installing gvfs-backends should fix the problem.
5. I can't see any regression.

Phill Whiteside (phillw) wrote :

It's causing support calls, so if can be added along with the os-prober fix it will make life a little more peaceful :)

Thanks,

Phill.
P.S. There you go, just to prove I DO read the bug reports.

Changed in lubuntu-meta (Ubuntu Maverick):
status: New → Confirmed
Julien Lavergne (gilir) on 2010-12-02
Changed in lubuntu-meta (Ubuntu):
assignee: nobody → Julien Lavergne (gilir)
importance: Undecided → Medium
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lubuntu-meta - 0.19

---------------
lubuntu-meta (0.19) natty; urgency=low

  * Switch to natty.
  * Refreshed dependencies
  * Added gecko-mediaplayer to desktop
  * Added icedtea-plugin to desktop [amd64 i386 powerpc]
  * Removed powernowd from desktop-recommends
  * Added gvfs-backends to desktop (LP: #675212)
  * Added audacious to desktop
  * Added audacious-plugins to desktop
  * Added file-roller to desktop
  * Added lzma to desktop
  * Removed aqualung from desktop
  * Removed cheese from desktop
  * Removed xarchiver from desktop
  * Removed xdg-utils from desktop
 -- Julien Lavergne <email address hidden> Thu, 02 Dec 2010 23:43:18 +0100

Changed in lubuntu-meta (Ubuntu):
status: In Progress → Fix Released
Julien Lavergne (gilir) wrote :

Package uploaded to maverick-proposed.

description: updated

Accepted lubuntu-meta into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in lubuntu-meta (Ubuntu Maverick):
status: Confirmed → Fix Committed
tags: added: verification-needed
Jonathan Marsden (jmarsden) wrote :

SRU explanation 4. in the Description of this bug says "To verify, install Lubuntu and...".

Does this mean that to verify this proposed change, the tester has to create an ISO including the -proposed lubuntu-desktop and then install from that? Seems mildly annoying -- is there a more efficient way to test than that? (I might be up for doing it, but I was hoping it would be less work!). At the other end of the effort scale, do daily test images including -proposed get automatically created and made available online somewhere, for example?

Julien Lavergne (gilir) wrote :

To be perfect, the tester should start on a fresh install of Lubuntu (not the iso directly), because the bug is relative to the meta-package lubuntu-desktop, and I'm sure it will be reproductible on this configuration. However, if you can reproduce the bug on an already Lubuntu system (not fresh install), you should also be able to test the fix.

Jonathan Marsden (jmarsden) wrote :

OK, thanks. I think that will install some packages (aqualung, cheese, xarchiver, xdg-utils) which will not be uninstalled by adding he lubuntu-desktop from -proposed. So at that level, the test is not going to be the same as what will happen when the new lubuntu-desktop is on the install CD.

If that's OK, then I'll try a test that way this evening. Sounds like I'm being overly cautious here :)

A fresh Lubuntu 10.10 install is easy and quick (from ISO to a virtual machine). A fresh build of a special ISO containing the -proposed packages, and then installing from that, is... more work!

Adolfo Jayme (fitojb) on 2014-02-28
Changed in lubuntu-meta (Ubuntu Maverick):
status: Fix Committed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers