Display corrupted in virtualbox

Bug #1766859 reported by Hans P Möller on 2018-04-25
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
lubuntu-meta (Ubuntu)
Undecided
Unassigned

Bug Description

In Virtual Box testing Bionic Beaver 18.04 version from 24 april, during live session or installation, display is corrupted.
Virtualbox configuration is:
Runtime attributes
Screen Resolution
800x600x32 @0,0
VM Uptime
0d 00:06:10
Clipboard Mode
Disabled
Drag and Drop Mode
Disabled
VT-x/AMD-V
Active
Nested Paging
Active
Unrestricted Execution
Active
Paravirtualization Interface
KVM
Guest Additions
5.2.8_KernelUbuntu r120774
Guest OS Type
Linux 2.6 / 3.x / 4.x (64-bit)
Remote Desktop Server Port
Not Available

General
Name
testBionic24
OS Type
Ubuntu (64-bit)

System
Base Memory
1024
Processor(s)
1
Execution Cap
100
Boot Order
Floppy, Optical, Hard Disk
VT-x/AMD-V
Enabled
Nested Paging
Enabled
Paravirtualization Interface
Default

Display
Video Memory
64
3D Acceleration
Enabled
2D Video Acceleration
Disabled
Remote Desktop Server
Disabled

Storage
Controller: IDE
IDE Secondary Master (Optical Drive)
bionic-desktop-amd64.iso (1,00 GB)
Controller: SATA
SATA Port 0
testBionic24.vdi (Normal, 10,00 GB)

Audio
Host Driver
Windows DirectSound
Controller
ICH AC97

Network
Adapter 1
Intel PRO/1000 MT Desktop (NAT)

Serial ports

USB

Shared folders

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1766859

tags: added: iso-testing
Hans P Möller (hmollercl) wrote :

In 25 april version, changing to tty and back (Ctrl+Alt F1 and the back with Ctr+Alt F7) display correctly.

Jb (jebsolutions) wrote :

I installed Lubuntu Bionic Desktop 20180425 under VirtualBox on a Windows 10 host. I tried both with and without 3D acceleration enabled. For me, I didn't get any screen corruption.

However...In the past (over a year ago?) I had exactly the same screen corruption you described.

There has been recent issues with 3D acceleration in VirtualBox. To the point where I turn it off on most of my VMs. Try turning it off to see if that fixes it.

Hans P Möller (hmollercl) wrote :

I had that same problem in the past and that solved it, and now 3d acceleration was disabled.
However, when te system is installed the problem doesn't occour (after installing Bionic and I'm using daily a 17.10).
It also doesn't happen when I use an already existed VM, and boot from it . But with a knew one it happens, ita happened with Bionica Daily 25.1 too.

The workaround of switching to tty and then back to x still works.

Jb (jebsolutions) wrote :

My main Windows 10 computer on VirtualBox 5.1.34 works fine.

I tried on my laptop:
host OS = Windows 10 Pro
VirtualBox: 5.2.8

Works fine with and without 3D acceleration. Full screen window, and small window.

I tried on another desktop:
host OS = Lubuntu 18.04 daily
Computer = Intel Celeron N3450, 4 gig ram
VirtualBox : 5.2.10 from the VirtualBox web site (not the one from the Ubuntu repo).

I got the screen corruption.

But...if I maximize (hit the "+" in the top right of the vm window) and reset the vm to reboot it will sometimes work on the next try. Vice versa, hitting the "+" sign to put it back to windowed mode and resetting also sometimes fixes it on the next try. Changing the size may do nothing, it may just may be random after a reboot.

It's failing inconsistently. It can definitely fail with 3D acceleration both enabled and disabled under an Ubuntu Host. But I couldn't duplicate the problem with a Windows 10 host.

Jb (jebsolutions) wrote :

It's weird. I can no longer duplicate the screen corruption on my Lubuntu 18.04 system now. No matter what settings I use, it always works fine.

riverfr0zen (riverfr0zen) wrote :

mberna's solution here is what worked for me on an Ubuntu 18.04 host with whatever is the current Lubuntu 18.04 desktop amd64 ISO:
https://superuser.com/questions/1295202/garbled-display-when-running-lubuntu-17-10-as-guest-os

1. disabling nested paging (system → acceleration → enable nested paging checkbox)
2. increasing the video memory to 128 mb (display → video memory slider)

After installation you can re-enable nested paging.

LYF (lyf2) wrote :

Press Esc in the language selection menu and select nomodeset in the "Other Options" menu. This somehow works for me.

LYF (lyf2) wrote :

And yes, just like what Jb said, sometimes it just works without any issue. The issue is very hard to reproduce once you solved it, no matter what settings you use. Now the ISO boots fine with 64 MB of video memory, nested paging simulation and 3D acceleration.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in lubuntu-meta (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers