running apport in terminal doesn't work, as python3-launchpadlib is not installed by default in Lubuntu Bionic

Bug #1764399 reported by Ken T on 2018-04-16
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
lubuntu-meta (Ubuntu)
Status tracked in Cosmic
Bionic
Critical
Walter Lapchynski
Cosmic
Critical
Walter Lapchynski

Bug Description

[Impact]

People can't use Apport without this. This is a very big issue for Lubuntu users, because we need crash reports.

[Test Case]

Run `apport-collect <BUG #>` in a terminal.

It should succeed, but instead, it asks for a python3-launchpadlib dependency.

[Regression Potential]

Very unlikely, unless apport or python3-launchpadlib breaks (which is not a problem of ours anyway).

[Original Bug Description]

Tried to append some data to another launchpad bug report by running "apport-collect <Bug number>" in terminal.

Got the following error message:
"(apport-gtk:17860): dbind-WARNING **: 22:15:17.563: Error retrieving accessibility bus address: org.freedesktop.DBus.Error.ServiceUnknown: The name org.a11y.Bus was not provided by any .service files
ERROR: The python3-launchpadlib package is not installed. This functionality is not available.
"

I'd suggest that this package should be installed by default.

Thanks,
Ken.
***

Walter Lapchynski (wxl) on 2018-05-16
affects: lubuntu-next → lubuntu-meta (Ubuntu)
Changed in lubuntu-meta (Ubuntu):
importance: Undecided → Critical
status: New → Triaged
summary: - Lubuntu 18.04 32bit beta2 - running apport in terminal doesn't work, as
- python3-launchpadlib is not installed by default
+ running apport in terminal doesn't work, as python3-launchpadlib is not
+ installed by default in Lubuntu Bionic
Walter Lapchynski (wxl) wrote :
Changed in lubuntu-meta (Ubuntu):
status: Triaged → Fix Committed
Simon Quigley (tsimonq2) on 2018-05-16
Changed in lubuntu-meta (Ubuntu):
assignee: nobody → Walter Lapchynski (wxl)
Simon Quigley (tsimonq2) on 2018-05-16
description: updated
Changed in lubuntu-meta (Ubuntu Bionic):
assignee: nobody → Walter Lapchynski (wxl)
importance: Undecided → Critical
status: New → Fix Committed

Hello Ken, or anyone else affected,

Accepted lubuntu-meta into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/lubuntu-meta/0.94.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed verification-needed-bionic
Walter Lapchynski (wxl) wrote :

With a fresh Bionic VM, I enabled proposed, updated, upgraded to 0.94.1 of lubuntu-desktop, lubuntu-gtk-core and lubuntu-gtk-desktop and everything worked fine.

tags: added: verification-done-bionic
removed: verification-needed-bionic
Łukasz Zemczak (sil2100) wrote :

Not having crash reports is rather critical indeed. Since this is only a dependency change of a package that should have been a dependency, I approve of an early release of this package to bionic-updates.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lubuntu-meta - 0.94.1

---------------
lubuntu-meta (0.94.1) bionic; urgency=high

  * Refreshed dependencies
  * Added python3-launchpadlib to core, core-gtk, core-qt (LP: #1764399)

 -- Walter Lapchynski <email address hidden> Tue, 15 May 2018 18:33:54 -0700

Changed in lubuntu-meta (Ubuntu Bionic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for lubuntu-meta has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Simon Quigley (tsimonq2) on 2018-05-17
Changed in lubuntu-meta (Ubuntu Cosmic):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers