xiterm+thai is installed and set to x-terminal-emulator

Bug #1752733 reported by Leonardo Müller on 2018-03-01
22
This bug affects 2 people
Affects Status Importance Assigned to Milestone
lubuntu-meta (Ubuntu)
Undecided
Unassigned
lxterminal (Ubuntu)
High
Simon Quigley

Bug Description

STEPS TO REPRODUCE
==================
 1. Install a daily version of Lubuntu Desktop Bionic or boot to the live system
 2. Check for where /etc/alternatives/x-terminal-emulator is symlinked

EXPECTED RESULTS
================
/usr/bin/lxterminal

ACTUAL RESULTS
==============
/usr/bin/txiterm

AFFECTED VERSIONS
=================
 * Desktop only; not Alternate
 * Bionic only; Artful is not affected
 * both amd64 and i386

NOTES
=====
 * lxterminal and xiterm+thai are both installed
 * postinst scripts on both packages set the update-alternatives priority to 20 (this cycle lxterminal was lowered to this value)
 * lxterminal is installed after xiterm+thai and thus does not become the new x-terminal-emulator because of the priority being no greater
 * xiterm+thai is not explicitly required by our seeds
 * there is no package that xiterm+thai depends on (apt-rdepends -r), so there should be no indirect depend on it
 * germinate-output, cd-build-logs don't show xiterm+thai being installed
 * cd-build-image logs do show xiterm+thai being installed as a depend of apport-gtk
 * apport-gtk requires x-terminal-emulator, not a specific one
 * if a package satisfying a virtual package is not already installed, the selection is essentially random

POSSIBLE SOLUTIONS
==================
 * explicity unseed xiterm+thai, which I think is more of a band-aid
 * ensure that lxterminal is installed before apport-gtk, which will ideally require running germinate locally

Walter Lapchynski (wxl) on 2018-03-01
Changed in lubuntu-meta (Ubuntu):
status: New → Triaged
summary: - Default terminal emulator is set to txiterm, which causes problems with
- certain characters
+ xiterm+thai is installed and set to x-terminal-emulator
Walter Lapchynski (wxl) on 2018-03-01
description: updated
Simon Quigley (tsimonq2) on 2018-03-03
Changed in lubuntu-meta (Ubuntu):
assignee: nobody → Simon Quigley (tsimonq2)
importance: Undecided → High
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1752733

tags: added: iso-testing
Simon Quigley (tsimonq2) on 2018-03-19
Changed in lxterminal (Ubuntu):
status: New → Triaged
importance: Undecided → High
assignee: nobody → Simon Quigley (tsimonq2)
Changed in lubuntu-meta (Ubuntu):
status: Triaged → Invalid
assignee: Simon Quigley (tsimonq2) → nobody
importance: High → Undecided
Simon Quigley (tsimonq2) wrote :

So the reason this was pulled in is because the Debian maintainer adjusted the update-alternatives priority from 40 to 20 for the change to 11.8.3, which now states "They should also register themselves as an alternative for /usr/bin/x-terminal-emulator, with a priority of 20." The Debian Policy manual defines the usage of "should" as the following: "Non-conformance with guidelines denoted by should (or recommended) will generally be considered a bug, but will not necessarily render a package unsuitable for distribution."

Other options can be explored, but the best option at this time in my opinion is to go against the recommended value and revert back to 40. This will make lxterminal the default again.

As to why xiterm+thai is installed is irrelevant. I have no clue. ¯\_(ツ)_/¯

Jeremy Bicha (jbicha) on 2018-03-19
Changed in lubuntu-meta (Ubuntu):
status: Invalid → Triaged
importance: Undecided → High
Changed in lxterminal (Ubuntu):
status: Triaged → Invalid
status: Invalid → Triaged
Changed in lubuntu-meta (Ubuntu):
status: Triaged → Invalid
Simon Quigley (tsimonq2) on 2018-03-19
Changed in lubuntu-meta (Ubuntu):
importance: High → Undecided
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lxterminal - 0.3.1-2ubuntu1

---------------
lxterminal (0.3.1-2ubuntu1) bionic; urgency=medium

  * Once again bump the update-alternatives priority from 20 to 40
    (LP: #1752733).

 -- Simon Quigley <email address hidden> Mon, 19 Mar 2018 00:43:21 -0500

Changed in lxterminal (Ubuntu):
status: Triaged → Fix Released
rsr (rsr666) wrote :

Newly added inline comment in postinst script is causing an error.

Walter Lapchynski (wxl) wrote :

What error? If this is not the same problem as the bug description, file a new bug.

Simon Quigley (tsimonq2) wrote :

That's my fault. I uploaded a fix that should land soon if it hasn't already.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers