Clicking 'Sound Settings' in Lubuntu is a no-op

Bug #1685598 reported by Juerg Haefliger on 2017-04-23
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
lubuntu-meta (Ubuntu)
Undecided
Unassigned
Xenial
Critical
Simon Quigley

Bug Description

Nothing happens when clicking 'Sound Settings...' in the indicator applet on a fresh install of Lubuntu 17.04.

This is probably because of the following code in src/sound-service-dbus.c:

static void
show_sound_settings_dialog (DbusmenuMenuitem *mi,
                            gpointer user_data)
{
  GError * error = NULL;
  if (!g_spawn_command_line_async("gnome-volume-control --page=applications", &error) &&
      !g_spawn_command_line_async("gnome-control-center sound", &error) &&
      !g_spawn_command_line_async("xfce4-mixer", &error))
  {
    g_warning("Unable to show dialog: %s", error->message);
    g_error_free(error);
  }
}

and the fact that none of the above is installed (or available) by default.

I 'fixed' the issue by creating a symbolic link xfce4-mixer -> pavucontrol. Maybe pavucontrol should be tried in the above code as well since that seems to be the default in Lubuntu?

ProblemType: Bug
DistroRelease: Ubuntu 17.04
Package: indicator-sound-gtk2 12.10.0.1-0ubuntu5
ProcVersionSignature: Ubuntu 4.10.0-19.21-generic 4.10.8
Uname: Linux 4.10.0-19-generic x86_64
ApportVersion: 2.20.4-0ubuntu4
Architecture: amd64
CurrentDesktop: LXDE
Date: Sun Apr 23 11:20:46 2017
InstallationDate: Installed on 2017-04-14 (9 days ago)
InstallationMedia: Lubuntu 17.04 "Zesty Zapus" - Release amd64 (20170412)
SourcePackage: indicator-sound-gtk2
UpgradeStatus: No upgrade log present (probably fresh install)

Juerg Haefliger (juergh) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in indicator-sound-gtk2 (Ubuntu):
status: New → Confirmed
Tiago Pimenta (tiagoapimenta) wrote :

I stated this issue before the release, and Simon promised to fix it as you can see here:

https://bugs.launchpad.net/ubuntu/+source/lubuntu-meta/+bug/1710993/comments/31

Let us hope it get fixed soon

Simon Quigley (tsimonq2) wrote :

You're right.

Changed in indicator-sound-gtk2 (Ubuntu Xenial):
status: New → In Progress
importance: Undecided → Critical
assignee: nobody → Simon Quigley (tsimonq2)
tags: added: regression-update
tags: added: xenial
removed: zesty
Simon Quigley (tsimonq2) on 2017-11-22
Changed in indicator-sound-gtk2 (Ubuntu Xenial):
status: In Progress → Invalid
importance: Critical → Undecided
assignee: Simon Quigley (tsimonq2) → nobody
no longer affects: indicator-sound-gtk2 (Ubuntu Xenial)
no longer affects: indicator-sound-gtk2 (Ubuntu)
Changed in lubuntu-meta (Ubuntu):
status: New → Triaged
Changed in lubuntu-meta (Ubuntu Xenial):
status: New → In Progress
importance: Undecided → Critical
assignee: nobody → Simon Quigley (tsimonq2)
milestone: none → xenial-updates
Chris Halse Rogers (raof) wrote :

Released as per the other bug.

Changed in lubuntu-meta (Ubuntu Xenial):
status: In Progress → Fix Released
Tiago Pimenta (tiagoapimenta) wrote :

Accepted

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers