grub2 missing from manifest on 17.04 so fails to boot

Bug #1649462 reported by Lyn Perrine on 2016-12-13
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
lubuntu-meta (Ubuntu)
Critical
Julien Lavergne

Bug Description

To reproduce Downlaod the latest version of lubuntu daily for 17.04 64 bit and it then tries to install grub but does not have the package installed. I was offline at the time but a bootloader is mandatory for almost all users. I was installing on an xfs / filesystem but doubt that matters and chose something else to get this option with manual partitioning.

Description: Ubuntu Zesty Zapus (development branch)
Release: 17.04

I expected the installer to isntall grub instead I may have to manually install grub .

ProblemType: Bug
DistroRelease: Ubuntu 17.04
Package: lubuntu-desktop 0.73
ProcVersionSignature: Ubuntu 4.8.0-30.32-generic 4.8.6
Uname: Linux 4.8.0-30-generic x86_64
ApportVersion: 2.20.3-0ubuntu8
Architecture: amd64
CasperVersion: 1.379
CurrentDesktop: LXDE
Date: Mon Dec 12 20:25:05 2016
LiveMediaBuild: Lubuntu 17.04 "Zesty Zapus" - Alpha amd64 (20161212)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: lubuntu-meta
UpgradeStatus: No upgrade log present (probably fresh install)

Lyn Perrine (walterorlin) wrote :
Jeremy Bicha (jbicha) on 2016-12-14
Changed in lubuntu-meta (Ubuntu):
importance: Undecided → Critical
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in lubuntu-meta (Ubuntu):
status: New → Confirmed
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1649462

tags: added: iso-testing
Julien Lavergne (gilir) wrote :

I think the removal of the grub binary messed up the seeds. I replaced it with grub2 to see if it's better, but I'm not sure it will be enough.

Julien Lavergne (gilir) wrote :

I pushed a potential fix to the seed. I hope it will be enough.

Apparently, grub is put on flavors ISO just by the recommend of Ubiquity.
See : http://people.canonical.com/~ubuntu-archive/germinate-output/xubuntu.zesty/live
And : http://people.canonical.com/~ubuntu-archive/germinate-output/ubuntu.zesty/live

Since lubuntu uses no-follow-recommends, we miss this one, so I put it explicitly on the seed.

Changed in lubuntu-meta (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Julien Lavergne (gilir)
Lyn Perrine (walterorlin) wrote :

Yes I have sucessfully used the iso to install a vm so think this may be fixed.

Jeremy Bicha (jbicha) wrote :

Brendan, thanks for verifying the fix!

I did see that grub2-common is now in the manifest again:
http://cdimage.ubuntu.com/lubuntu/daily-live/current/zesty-desktop-amd64.manifest

Changed in lubuntu-meta (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers