Intel video driver not installed by default on Lubuntu 16.04 fresh install

Bug #1575460 reported by Camilo Gonzalez on 2016-04-27
82
This bug affects 18 people
Affects Status Importance Assigned to Milestone
lubuntu-meta (Ubuntu)
Critical
Julien Lavergne
Xenial
Undecided
Unassigned

Bug Description

[Impact]

 * xserver-xorg-video-intel is not included in Lubuntu ISO because it switched to recommends on the common seeds. Since Lubuntu ISO doesn't include recommends, so xserver-xorg-video-intel is missing (but included on other flavors).

 * xserver-xorg-video-intel is not mandatory for Intel users, but it needs a recent hardware to work correctly. According to the packages description :

"The use of this driver is discouraged if your hw is new enough (ca. 2007
and newer). You can try uninstalling this driver and let the server use
it's builtin modesetting driver instead."

 * However, Lubuntu targets old hardwares, and there are a lot of reports from Intel users that, without this drivers, X doesn't load.

[Test Case]

 * Install Lubuntu 16.04 with an official 16.04 ISO, on a system with an Intel graphic device.
 * Boot on the installed system, and the boot process should stop before X is loading.
 * To confirm the fix, install manually xserver-xorg-video-intel and boot again.

[Regression Potential]

 * Stick with the old driver may have an impact on the performances of the driver (the new one should be better for 3D and others graphic stuff).

 * However, others flavors kept this driver on the ISO, and according to the reports, it's probably safe to keep this driver for now.

[Original report]

I did a new installation of Lubuntu 16.04 LTS on a intel atom netbook
installation completes with any problem.

On booting the installed system i only got a black screen with the message: "/dev/sda1: clean, 121563/920272 files"
I've changed to a terminal (CTRL+ALT+F1), and reading logs i've
 found xserver-xorg-video-intel package is NOT INSTALLED

installed the xserver-xorg-video-intel package, and everything works ok now.

Tried again with other computers (intel gpu all) and i've downloaded the iso again and still happens

can confirm this happen to at least other two people on ubuntu forums:

http://ubuntuforums.org/showthread.php?t=2322111
http://ubuntuforums.org/showthread.php?t=2321916

description: updated
Timo Aaltonen (tjaalton) wrote :

xserver-xorg-video-all Recommends x-x-v-intel, so if lubuntu doesn't install those then that's too bad, but not a driver issue

Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Invalid
Camilo Gonzalez (yhwh-aggro) wrote :

Yeah not a driver issue sorry for that.

I tried the installation on other two computers with intel video cards and got the same result.

no longer affects: xserver-xorg-video-intel (Ubuntu)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in lubuntu-meta (Ubuntu):
status: New → Confirmed
description: updated
description: updated
Tos (soto-patrick) wrote :

Just for information, I confirm the lack of this driver in Lubuntu 16.04.
See http://ubuntuforums.org/showthread.php?t=2321317&page=2&p=13478810#post13478810

Camilo Gonzalez (yhwh-aggro) wrote :

more info: in one of my computers when i press CTRL+ALT+F1
the system automatically returns to the default tty (the one with the /dev/sda1 clean message...) after a few seconds
and it's very difficult to log in and do the apt-get install and network configuration etc...

if this happen to anyone do this:

try to login.. you will have to press CTRL+ALT+F1 multiple times because the system will return you to the default tty
next use this command "sudo service lightdm stop" , to stop lightdm
(lightdm is crashed because of no suitable video driver, triying to run again, crashing again...
   because of this the tty changes automatically)
then the system will stop you from automatically switch to the default tty

Drimux (drimux) wrote :

Same problem here (and same problem to change tty... but it's not always, sometimes I can change tty if I remove 'quiet' parameter of grub). I tried to install Lubuntu on old computers (with no GPU nvidia): especially Aspire One Happy and Samsung NC10. Always stuck on "/dev/sda1: clean, xxx/xxx files xxx/xxx blocks". Although Lubuntu 15.10 or Ubuntu Mate working.

With 'nomodeset' parameter, Lubuntu boots, but of course it's bad resolution (800x600).

Andres (andresespinoza100) wrote :

same problem here, after installing with no problems, then re start the laptop and get stucked in "/dev/sda6: clean, xxxxx/xxxxx files", try to login in tty but it returns constantly to black screen. After running in circles I try to install elementary OS with no troubles at all and running fine

My laptop is an old hp500, celeron M, 2 GB RAM

Raphael (raphaelciribelly) wrote :

same problem here! :(

Glauber Marinho (sr-marinho) wrote :

Same problem here also!

/dev/sda1: clean, 191427/3129344 files, 1313527/12499712 blocks

that's what appears when rebooting and when I get to the login screen it's simply hibernate, only gets back when I press the power button...

My notebook is a intel core i5-2410M 2.3GHz, 6GB RAM, Intel®HD Graphics 3000

Lucas Stegel (lucas-stegel) wrote :

Guys, try this. Worked for me.

Hold down shift while booting to access boot options menu
Select recovery console
Enable networking
Select Administrator Root terminal

# sudo apt-get update
# sudo apt-get install xserver-xorg-video-intel

Select Continue Normal boot.

Benny (benny-malengier) wrote :

For Compaq Mini, you should press ESC key to access boot options instead of shift.
Then this PC has the broadcom wireless driver, so you must have done install with ethernet cable attached or you have no network to update and install the missing driver...
otherwise the fix via recovery and install of intel drivers works

Albert (heisenberg-hnch3) wrote :

Thanks Lucas Stegel that solution works for me to =D

ajgreeny (ajg-charlbury) wrote :

I had the same problem as Camilo Gonzalez in post #5, on a netbook with Atom 270 cpu and Intel 954M graphics.
Solved by booting with nomodesdet option from the grub menu to get a low resolution GUI and then installing the xserver-xorg-video-intel package.
All works very well now.

Julien Lavergne (gilir) on 2016-06-22
Changed in lubuntu-meta (Ubuntu):
importance: Undecided → Critical
status: Confirmed → In Progress
assignee: nobody → Julien Lavergne (gilir)
victorel (vparasch) wrote :

Same problem after fresh install Lubuntu on Dell inspiron 1011
At startup, stuck at:
/dev/sda5: clean, xxx/xxx files, xxx/xxx blocks

What I did, force shut down, then start and choose Advanced Options for Ubuntu, then ubuntu recovery console. From there, I just chose to continue normal boot, and it showed me the login screen and logged me in: but with low resolution screen.
Then I connected the LAN internet cable (not to encounter wifi issues), and I opened a terminal and
# sudo apt-get update
# sudo apt-get install xserver-xorg-video-intel

Then shut down, and started back: problem disappeared.

Thanks for the people who wrote the solutions above, and hope it will be fixed in the future.

Julien Lavergne (gilir) on 2016-06-26
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in lubuntu-meta (Ubuntu Xenial):
status: New → Confirmed
sudodus (nio-wiklund) wrote :

Please fix this bug in Xenial preparing for the first point release, 16.04.1 LTS.

I checked the current daily iso file,

-rw------- 856M 2016-06-30 16:42 "xenial-desktop-i386.iso"

$ md5sum xenial-desktop-i386.iso
43249c865a5e5fb9441e835b76234a0b xenial-desktop-i386.iso

and 'xserver-xorg-video-intel' is still missing.

Julien Lavergne (gilir) wrote :

It should be fixed in 16.10 with lubuntu-core 0.67. The SRU for 16.04 will follow.

Changed in lubuntu-meta (Ubuntu):
status: In Progress → Fix Released
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1575460

tags: added: iso-testing
LinuxFreak (bwvienna) wrote :

The Lubuntu iso lubuntu-16.04-desktop-i386.iso from the 24.06.2016 did contain the bug, on a Acer Aspire 3610 laptop with an INTEL Mobile 915GM/GMS/910GML Express Graphics Controller.

CTRL + ALT + F1 did only last for one second an a tty1-console. Than it was switching back to the message: /dev/sda1: clean, xxx/xxx files, xxx/xxx blocks

After a sudo apt-get update and sudo apt-get upgrade, the tty1 console was not switching back any more. So i could install the mentoined: sudo apt-get install xserver-xorg-video-intel
After a rebbot Lubunte could start into the LXDE Login screen (-:

regards AP

Hello Camilo, or anyone else affected,

Accepted lubuntu-meta into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/lubuntu-meta/0.65.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in lubuntu-meta (Ubuntu Xenial):
status: Confirmed → Fix Committed
tags: added: verification-needed
sudodus (nio-wiklund) wrote :

The program package xserver-xorg-video-intel was installed, when I updated and dist-upgraded a test installation created by the Lubuntu daily iso file (i386), which has the proposed repository active.

I confirm that this bug is solved for me, but I will not edit any tag. I leave that to people who are more involved in Launchpad, and know what is needed for a full verification.

---

tester@tester-SATELLITE-PRO-C850-19W:~$ apt-cache policy xserver-xorg-video-intel
xserver-xorg-video-intel:
  Installerad: 2:2.99.917+git20160325-1ubuntu1
  Kandidat: 2:2.99.917+git20160325-1ubuntu1
  Versionstabell:
 *** 2:2.99.917+git20160325-1ubuntu1 500
        500 http://se.archive.ubuntu.com/ubuntu xenial/main i386 Packages
        100 /var/lib/dpkg/status
tester@tester-SATELLITE-PRO-C850-19W:~$ apt-cache policy lubuntu-meta
N: Kunde inte hitta paketet lubuntu-meta
tester@tester-SATELLITE-PRO-C850-19W:~$ apt-cache policy lubuntu-core
lubuntu-core:
  Installerad: 0.65.1
  Kandidat: 0.65.1
  Versionstabell:
 *** 0.65.1 500
        500 http://archive.ubuntu.com/ubuntu xenial-proposed/universe i386 Packages
        100 /var/lib/dpkg/status
     0.65 500
        500 http://se.archive.ubuntu.com/ubuntu xenial/universe i386 Packages
tester@tester-SATELLITE-PRO-C850-19W:~$ apt-cache policy lubuntu-desktop
lubuntu-desktop:
  Installerad: 0.65.1
  Kandidat: 0.65.1
  Versionstabell:
 *** 0.65.1 500
        500 http://archive.ubuntu.com/ubuntu xenial-proposed/universe i386 Packages
        100 /var/lib/dpkg/status
     0.65 500
        500 http://se.archive.ubuntu.com/ubuntu xenial/universe i386 Packages
tester@tester-SATELLITE-PRO-C850-19W:~$

Simon Quigley (tsimonq2) wrote :

There you are, Nio. :)

tags: added: verification-done
removed: verification-needed
sudodus (nio-wiklund) wrote :

I can confirm that 'xserver-xorg-video-intel' is part of the current daily iso file

xenial-desktop-i386.iso

:-)

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lubuntu-meta - 0.65.1

---------------
lubuntu-meta (0.65.1) xenial-proposed; urgency=medium

  * Refreshed dependencies
  * Added xserver-xorg-video-intel to core [amd64 i386] (LP: #1575460)

 -- Julien Lavergne <email address hidden> Mon, 04 Jul 2016 22:52:54 +0200

Changed in lubuntu-meta (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for lubuntu-meta has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers