'amixer' can mute the speaker but it cannot unmute it.

Bug #1468914 reported by bzb001 on 2015-06-25
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
lubuntu-meta (Ubuntu)
Undecided
Unassigned

Bug Description

My system:
Lubuntu 15.04 64bit.
Currently using hp laptop model# 15-r174ca.

'amixer' can mute the speaker but it cannot unmute it.

I used the following command to toggle mute/unmute the speaker. The console output status indicated that the command completed successfully. The problem is that the speaker once muted, cannot be unmuted using the following commands. I had to manually click on the volume applet on the desktop in order to unmute it.

$ amixer -c 1 sset Master toggle
Simple mixer control 'Master',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined
  Playback channels: Mono
  Limits: Playback 0 - 87
  Mono: Playback 18 [21%] [-51.75dB] [off]
17:14:41:(3),jobs=0,cmd#=2,hist#=77

$ amixer -c 1 sset Master toggle
Simple mixer control 'Master',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined
  Playback channels: Mono
  Limits: Playback 0 - 87
  Mono: Playback 18 [21%] [-51.75dB] [on]

I also tried using the following. It still does not work. ie. I cannot unmute the speaker using the command. Console message seems ok but the speaker does not turn back on.

$ amixer -c 1 sset Master mute
Simple mixer control 'Master',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined
  Playback channels: Mono
  Limits: Playback 0 - 87
  Mono: Playback 18 [21%] [-51.75dB] [off]
17:17:39:(3),jobs=0,cmd#=4,hist#=78

$ amixer -c 1 sset Master unmute
Simple mixer control 'Master',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined
  Playback channels: Mono
  Limits: Playback 0 - 87
  Mono: Playback 18 [21%] [-51.75dB] [on]

bzb001 (bzb-dev001) on 2015-06-25
description: updated
Chris Guiver (guiverc) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. We are sorry that we do not always have the capacity to look at all reported bugs in a timely manner. There have been many changes in Ubuntu since that time you reported the bug and your problem may have been fixed with some of the updates. It would help us a lot if you could test it on a currently supported Ubuntu version. When you test it and it is still an issue, kindly upload the updated logs by running only once:
apport-collect <bug #>

and any other logs that are relevant for this particular issue.

Changed in lubuntu-meta (Ubuntu):
status: New → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for lubuntu-meta (Ubuntu) because there has been no activity for 60 days.]

Changed in lubuntu-meta (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers