several packages missing or added in Lubuntu 14.04.2 manifests

Bug #1417784 reported by Lyn Perrine on 2015-02-03
26
This bug affects 4 people
Affects Status Importance Assigned to Milestone
lubuntu-meta (Ubuntu)
Critical
Adam Conrad

Bug Description

EXPECTED RESULTS:
 * Manifest should include standard packages.

ACTUAL RESULTS:
 * Manifest is missing packages and has some added packages.
 * The diff of `dpkg -l | awk -F" " '{print $2}'` in the live environment of both 14.04.1 and 14.04.2 is compared here:
   * i386: https://www.diffchecker.com/3gdr5roj
   * amd64: https://www.diffchecker.com/9rl29l79
 * The diff of mounting the alternate image and then doing `ls -R | grep "\.deb" | awk -F"_[0-9]" '{print $1}'` within the mounted directory of both 14.04.1 and 14.04.2 is compared here:
   * i386: https://www.diffchecker.com/6fgc92wl
   * amd64: https://www.diffchecker.com/2ixnc9ye

Lyn Perrine (walterorlin) wrote :

installing xserver-xorg-input-synaptics-lts-utopic: seems to make my scrollwheel function so it seems to work now but I don't know why it is not in the manifest.

It should be noted that it's not missing in the Ubuntu manifest, so this is a problem only affecting Lubuntu, apparently:
http://cdimage.ubuntu.com/lubuntu/trusty/daily-live/20150203/trusty-desktop-i386.manifest
http://cdimage.ubuntu.com/trusty/daily-live/20150203.2/trusty-desktop-i386.manifest

summary: - no synclinet or driver for touchpad installedin 14.04.2 daily
+ xserver-xorg-input-synaptics missing from Lubuntu 14.04.2 manifest
Changed in lubuntu-meta (Ubuntu):
status: New → Triaged
importance: Undecided → High
assignee: nobody → Julien Lavergne (gilir)
milestone: none → ubuntu-14.04.2
Walter Lapchynski (wxl) wrote :

It should also be noted that several other xserver-xorg-input packages are missing:
xserver-xorg-input-all-lts-utopic 1:7.7+7ubuntu2~trusty1
xserver-xorg-input-mouse-lts-utopic 1:1.9.0-1build2~trusty1
xserver-xorg-input-synaptics-lts-utopic 1.8.1-1ubuntu1~trusty1
xserver-xorg-input-vmmouse-lts-utopic 1:13.0.0-1build2~trusty1
xserver-xorg-input-wacom-lts-utopic 1:0.25.0-0ubuntu1~trusty1

All of the above are present in Lubuntu 14.04.1:
http://cdimage.ubuntu.com/lubuntu/releases/14.04.1/release/lubuntu-14.04.1-desktop-i386.manifest

Lyn Perrine (walterorlin) wrote :

find of the iso image for alti386.

Walter Lapchynski (wxl) wrote :

yep they're all there. one can assume that this is ONLY an issue with i386 Desktop.

summary: - xserver-xorg-input-synaptics missing from Lubuntu 14.04.2 manifest
+ xserver-xorg-input-synaptics missing from Lubuntu 14.04.2 Desktop i386
+ manifest
tags: added: lubuntu
summary: - xserver-xorg-input-synaptics missing from Lubuntu 14.04.2 Desktop i386
+ xserver-xorg-input drivers missing from Lubuntu 14.04.2 Desktop i386
manifest

Apparently not all there as they are missing the *-utopic ones as for the lts there are the xorg-input and xorg-input-utopic packages.

Lyn Perrine (walterorlin) wrote :

status from failed alternate installer.

Lyn Perrine (walterorlin) wrote :

hardware summary.

Lyn Perrine (walterorlin) wrote :
Walter Lapchynski (wxl) on 2015-02-04
summary: - xserver-xorg-input drivers missing from Lubuntu 14.04.2 Desktop i386
- manifest
+ xserver-xorg-input drivers missing from Lubuntu 14.04.2 i386 manifest1
summary: - xserver-xorg-input drivers missing from Lubuntu 14.04.2 i386 manifest1
+ xserver-xorg-input drivers missing from Lubuntu 14.04.2 i386 manifest
summary: - xserver-xorg-input drivers missing from Lubuntu 14.04.2 i386 manifest
+ xserver-xorg-input drivers incomplete from Lubuntu 14.04.2 i386 manifest
Walter Lapchynski (wxl) on 2015-02-04
description: updated
description: updated
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1417784

tags: added: iso-testing
Walter Lapchynski (wxl) on 2015-02-04
summary: - xserver-xorg-input drivers incomplete from Lubuntu 14.04.2 i386 manifest
+ xserver-xorg-input drivers incomplete from some Lubuntu 14.04.2
+ manifests
tags: added: amd64
description: updated
Timo Aaltonen (tjaalton) wrote :

the lts-utopic stack is still in trusty-proposed

http://people.canonical.com/~ubuntu-archive/pending-sru.html

then why does this only affect certain images? other images seem to
have the stack.

On Wed, Feb 4, 2015 at 12:58 PM, Timo Aaltonen <email address hidden> wrote:
> the lts-utopic stack is still in trusty-proposed
>
> http://people.canonical.com/~ubuntu-archive/pending-sru.html
>
> --
> You received this bug notification because you are a member of Lubuntu
> Packages Team, which is subscribed to lubuntu-meta in Ubuntu.
> https://bugs.launchpad.net/bugs/1417784
>
> Title:
> xserver-xorg-input drivers incomplete from some Lubuntu 14.04.2
> manifests
>
> Status in lubuntu-meta package in Ubuntu:
> Triaged
>
> Bug description:
> EXPECTED RESULTS:
> * Manifest should include the following:
> xserver-xorg-input-all-lts-utopic 1:7.7+7ubuntu2~trusty1
> xserver-xorg-input-evdev-lts-utopic 1:2.9.0-1ubuntu2~trusty1
> xserver-xorg-input-mouse-lts-utopic 1:1.9.0-1build2~trusty1
> xserver-xorg-input-synaptics-lts-utopic 1.8.1-1ubuntu1~trusty1
> xserver-xorg-input-vmmouse-lts-utopic 1:13.0.0-1build2~trusty1
> xserver-xorg-input-wacom-lts-utopic 1:0.25.0-0ubuntu1~trusty1
>
> ACTUAL RESULTS:
> * Desktop i386 image only has evdev.
> * Alternate i386 image has all of them, but not all of the -utopic versions:
> /media/brenda/Lubuntu 14.04.2 LTS i386/pool/main/x/xserver-xorg-input-evdev/xserver-xorg-input-evdev_2.8.2-1ubuntu2_i386.deb
> /media/brenda/Lubuntu 14.04.2 LTS i386/pool/main/x/xserver-xorg-input-evdev/xserver-xorg-input-evdev-udeb_2.8.2-1ubuntu2_i386.udeb
> /media/brenda/Lubuntu 14.04.2 LTS i386/pool/main/x/xserver-xorg-input-evdev-lts-utopic/xserver-xorg-input-evdev-lts-utopic_2.9.0-1ubuntu2~trusty1_i386.deb
> /media/brenda/Lubuntu 14.04.2 LTS i386/pool/main/x/xserver-xorg-input-mouse/xserver-xorg-input-mouse_1.9.0-1build1_i386.deb
> /media/brenda/Lubuntu 14.04.2 LTS i386/pool/main/x/xserver-xorg-input-synaptics/xserver-xorg-input-synaptics_1.7.4-0ubuntu1_i386.deb
> /media/brenda/Lubuntu 14.04.2 LTS i386/pool/main/x/xserver-xorg-input-vmmouse
> /media/brenda/Lubuntu 14.04.2 LTS i386/pool/main/x/xserver-xorg-input-vmmouse/xserver-xorg-input-vmmouse_13.0.0-1build1_i386.deb
> * Alternate amd64 image seems to have the same problem as Alternate i386:
> ./pool/main/x/xserver-xorg-input-evdev/xserver-xorg-input-evdev_2.8.2-1ubuntu2_amd64.deb
> ./pool/main/x/xserver-xorg-input-evdev-lts-utopic/xserver-xorg-input-evdev-lts-utopic_2.9.0-1ubuntu2~trusty1_amd64.deb
> ./pool/main/x/xserver-xorg-input-mouse/xserver-xorg-input-mouse_1.9.0-1build1_amd64.deb
> ./pool/main/x/xserver-xorg-input-synaptics/xserver-xorg-input-synaptics_1.7.4-0ubuntu1_amd64.deb
> ./pool/main/x/xserver-xorg-input-vmmouse/xserver-xorg-input-vmmouse_13.0.0-1build1_amd64.deb
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/lubuntu-meta/+bug/1417784/+subscriptions

--
@wxl
Lubuntu Release Manager, Head of QA
Ubuntu PPC Point of Contact
Ubuntu Oregon LoCo Team Leader

also evdev is a related branch, and yet it's appearing. don't think that's our problem.

Walter Lapchynski (wxl) wrote :

i suspect this problem is related to Xubuntu's problem with extra packages:
https://bugs.launchpad.net/ubuntu/+source/xubuntu-default-settings/+bug/1418377

Walter Lapchynski (wxl) wrote :
tags: added: regression-proposed
removed: regression-release
Walter Lapchynski (wxl) on 2015-02-06
Changed in lubuntu-meta (Ubuntu):
importance: High → Critical
Walter Lapchynski (wxl) on 2015-02-06
summary: - xserver-xorg-input drivers incomplete from some Lubuntu 14.04.2
- manifests
+ several packages missing or added in Lubuntu 14.04.2 manifests
Walter Lapchynski (wxl) on 2015-02-06
description: updated
Walter Lapchynski (wxl) on 2015-02-06
description: updated
Walter Lapchynski (wxl) on 2015-02-06
description: updated
Mélodie (meets) wrote :

Brendan Perrine's syslog contains interesting clues.

https://bugs.launchpad.net/ubuntu/+source/lubuntu-meta/+bug/1417784/comments/13

“Feb 4 01:22:26 debconf-copydb: Cannot open file /target/var/cache/debconf/config.dat-new: No such file or directory
Feb 4 01:22:26 debconf-copydb: Cannot open file /target/var/cache/debconf/templates.dat-new: No such file or directory
Feb 4 01:22:26 base-installer: chroot: can't execute 'debconf-set-selections': No such file or directory
Feb 4 01:22:26 base-installer: warning: /usr/lib/base-installer.d/20console-setup returned error code 127”

“Feb 4 01:23:04 debootstrap: Preparing to unpack .../login_1%3a4.1.5.1-1ubuntu9_amd64.deb ...
Feb 4 01:23:04 debootstrap: dpkg: error: --compare-versions takes three arguments: <version> <relation> <version>”

and this one I have seen in my remixes, it should be possible to fix:
“Feb 4 01:25:48 in-target: W: GPG error: http://extras.ubuntu.com trusty Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 16126D3A3E5C1192”

That's for a search on the chain "error". When it comes to "warning" there are a bunch. The very first one looks related to the hardware only though:

“Feb 4 01:19:01 kernel: [ 0.000000] WARNING: CPU: 0 PID: 0 at /build/buildd/linux-lts-utopic-3.16.0/drivers/iommu/dmar.c:760 warn_invalid_dmar+0x81/0x93()
Feb 4 01:19:01 kernel: [ 0.000000] Your BIOS is broken; DMAR reported at address 0!
Feb 4 01:19:01 kernel: [ 0.000000] BIOS vendor: Hewlett-Packard; Ver: F.33; Product Version: Rev 1”

Then, the warnings are about files missing:

“Feb 4 01:19:14 cdrom-retriever: warning: File /cdrom/dists/trusty/main/debian-installer/binary-amd64/Packages does not exist.
Feb 4 01:19:14 cdrom-retriever: warning: File /cdrom/dists/trusty/restricted/debian-installer/binary-amd64/Packages does not exist.
Feb 4 01:19:14 cdrom-retriever: warning: File /cdrom/dists/trusty/universe/debian-installer/binary-amd64/Packages does not exist.
Feb 4 01:19:14 cdrom-retriever: warning: Unable to find multiverse/debian-installer/binary-amd64/Packages in /cdrom/dists/trusty/Release.
Feb 4 01:19:14 cdrom-retriever: warning: Unable to find multiverse/debian-installer/binary-amd64/Packages.gz in /cdrom/dists/trusty/Release.

later, about nefcfg looking for a wpa-supplicant pid file:
“Feb 4 01:19:44 netcfg[14971]: INFO: Starting netcfg v.1.116ubuntu2 (built 20140923-2000)
Feb 4 01:19:44 netcfg[14971]: WARNING **: Couldn't read Wpasupplicant pid file, not trying to kill.”

and some more warnings to be examined. Once these errors and warnings will have been reduced to their very minimum and hopefully harmless warnings, we will be very near to the release.

I have an idea about just a few specific packages which are missing and could help improve the general behavior. I'll try tomorrow and report back if I see a difference.

Lars Noodén (larsnooden) wrote :
Lars Noodén (larsnooden) wrote :

Sorry. here is the corrected AMD64 diff without the version numbers

https://www.diffchecker.com/9rl29l79

Dave Kokandy (drkokandy) wrote :

Lars, is that amd64 diff for the live environment or the manifest of the alternate installer?

Lars Noodén (larsnooden) wrote :

That would be for the Live DVDs

Please make sure to do the same for alternate.

@wxl
Lubuntu Release Manager, Head of QA
Ubuntu PPC Point of Contact
Ubuntu Oregon Team Leader

Dave Kokandy (drkokandy) wrote :

Working on it

Lars Noodén (larsnooden) wrote :

PPC manifest difference between .1 and .2
https://www.diffchecker.com/qp9xyh7b

Dave Kokandy (drkokandy) wrote :

Here is the difference between packages in the alternate install ISOs, amd-64, with Lubuntu 14.04.1 on the left and 14.04.2 on the right: https://www.diffchecker.com/2ixnc9ye

Found by mounting the alternate image and then doing `ls -R | grep "\.deb" | awk -F"_[0-9]" '{print $1}'` within the mounted directories.

description: updated
Walter Lapchynski (wxl) wrote :

Word is the problems we and other flavors have been having is related to
switching from tasks (not packages) to metapackages. Adam Conrad (infinity)
is on it.

@wxl
Lubuntu Release Manager, Head of QA
Ubuntu PPC Point of Contact
Ubuntu Oregon Team Leader

Walter Lapchynski (wxl) wrote :

Adam worked his magic. :)

Changed in lubuntu-meta (Ubuntu):
status: Triaged → Fix Released
Adam Conrad (adconrad) on 2015-02-25
Changed in lubuntu-meta (Ubuntu):
assignee: Julien Lavergne (gilir) → Adam Conrad (adconrad)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers