Lubuntu: banshee, rhythmbox, etc cannot play audio without pulseaudio or gstreamer1.0-alsa

Bug #1178272 reported by Rüdiger Kupper on 2013-05-09
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
banshee (Ubuntu)
Undecided
Unassigned
gstreamer0.10 (Ubuntu)
Undecided
Unassigned
gstreamer1.0 (Ubuntu)
Undecided
Unassigned
lubuntu-meta (Ubuntu)
Undecided
Unassigned
rhythmbox (Ubuntu)
Undecided
Unassigned

Bug Description

Lubuntu Raring (13.04).
The Lubuntu standard installation comes without jack, and without pulse, just plain alsa. Gstreamer applications (rhythmbox, banshee) used to work fine after installing "ubuntu-restricted-extras", which pulls in the usual gstreamer plugins.
On my system, gstreamer applications stopped working. They report:
> Cannot connect to server socket err = No such file or directory
> Cannot connect to server request channel
> jack server is not running or cannot be started
Since there is no jack on this system, never was, and is not intended to be there, I cannot understand this message. The applications do not produce sound.

This looks like gstreamer tries to start up jackd, regardless whether it is installed or not.

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: libgstreamer0.10-0 0.10.36-1ubuntu2
ProcVersionSignature: Ubuntu 3.8.0-19.30-generic 3.8.8
Uname: Linux 3.8.0-19-generic i686
ApportVersion: 2.9.2-0ubuntu8
Architecture: i386
Date: Thu May 9 15:38:20 2013
InstallationDate: Installed on 2013-02-12 (85 days ago)
InstallationMedia: Lubuntu 12.10 "Quantal Quetzal" - Release i386 (20121017.1)
MarkForUpload: True
SourcePackage: gstreamer0.10
UpgradeStatus: Upgraded to raring on 2013-04-25 (13 days ago)

description: updated

Update: Installing pulseaudio fixes the problem.
However, pulseaudio is not part of the standard Lubuntu installation, and I expect there is a reason for this. (Lubuntu is intended to be very lightweight, alsa should be enough for simple sound output.)

gstreamer0.10-alsa is installed, I take it this should enable gstreamer output with alsa. However, this does not seem to work any longer.

summary: - Gstreamer applications report "jack server is not running or cannot be
- started" and do not play
+ Without pulseaudio, gstreamer applications report "jack server is not
+ running or cannot be started" and do not play

I confirm that this problem exists on another Lubuntu install, too.

Changed in gstreamer0.10 (Ubuntu):
status: New → Confirmed

Correction: The problem appears with Banshee and Rhythmbox, but it does not appear with Quod Libet, which also uses GStreamer.
This may mean it's not a GStreamer problem at all, but more a problem of correctly using GStreamer.

summary: - Without pulseaudio, gstreamer applications report "jack server is not
+ Without pulseaudio, banshee and rhythmbox report "jack server is not
running or cannot be started" and do not play

In addition to the following message to stdout:
> Cannot connect to server socket err = No such file or directory
> Cannot connect to server request channel
> jack server is not running or cannot be started
rhythmbox displays a message box reading
> Couldn't start playback
> Failed to create autoaudiosink element; check your GStreamer installation

On Tue, Aug 06, 2013 at 10:18:53PM -0000, Rüdiger Kupper wrote:
> Correction: The problem appears with Banshee and Rhythmbox, but it does not appear with Quod Libet, which also uses GStreamer.
> This may mean it's not a GStreamer problem at all, but more a problem of correctly using GStreamer.

Nope, this is neither a Banshee nor Rhythmbox problem. Both Banshee and
Rhythmbox now use gstreamer1.0, while quodlibet is still using gstreamer0.10,
which is why you see the difference here.

Gstreamer-using applications require an audio "sink" to output sound. By
default, Ubuntu uses pulseaudio for sound output by default, which is provided
by gstreamer1.0-pulseaudio or gstreamer0.10-pulseaudio depending on the
gstreamer version you're using. If you remove pulseaudio, that sink fails, and
it attempts to fall back onto another sink, which in this case is jack (which
also doesn't work because you don't have jackd running).

The correct sink to use if you've disabled pulseaudio is probably alsa, which is
provided by the gstreamer1.0-alsa package. Please make sure you have that
installed.

  affects ubuntu/banshee
  status invalid

  affects ubuntu/rhythmbox
  status invalid

--
Kind regards,
Loong Jin

Changed in banshee (Ubuntu):
status: New → Invalid
Changed in rhythmbox (Ubuntu):
status: New → Invalid

Thanks, this was of course the solution. I'd suggest that gstreamer1.0-alsa was a dependency of ubuntu-restricted-extras. Assuming that pulseaudio is installed is all right for the standard Ubuntu installation, but not, for example, for Lubuntu. I'd expect that other Lubuntu users run into the same problem.

On Tue, Sep 03, 2013 at 10:13:35AM -0000, Rüdiger Kupper wrote:
> Thanks, this was of course the solution. I'd suggest that
> gstreamer1.0-alsa was a dependency of ubuntu-restricted-extras. Assuming
> that pulseaudio is installed is all right for the standard Ubuntu
> installation, but not, for example, for Lubuntu. I'd expect that other
> Lubuntu users run into the same problem.

No, probably not. I just tried installing lubuntu-desktop on a bare raring
chroot, and pulseaudio came with it. And pulseaudio doesn't belong in
ubuntu-restricted-extras -- what part of pulseaudio sounds restricted to you?

--
Kind regards,
Loong Jin

Hm, to my knowledge Lubuntu does not come with pulseaudio nor gstreamer. The standard install relies on audio applications that use plain ALSA. Try installing from a Lubuntu live CD.
It's certainly hard to choose which (meta-)package should pull in gstreamer1.0-alsa. But some package should include it, otherwise Lubuntu users will end up without it and have the problems described above. It's the link between ALSA and gstreamer, so it could come with one of the packages that deliver ALSA or gstreamer. There's probably no perfect answer here. It could just be included in the standard Lubuntu install, but the Lubuntu people opt for simplicity and use direct ALSA.

However, a typical scenario is as follows:
You install Lubuntu from a Live CD. You find a selection of slim audio software like audacious. However, you miss your rhythmbox/banshee/whatever. You install rhythmbox/banshee/whatever. It does not work, because there is no gstreamer. You google a bit and learn that the gstreamer plugins come with ubuntu-restricted-extras. You install it, but your rhythmbox/banshee/whatever still does not work, because there is no ALSA sink. You google a bit more but find no answer. You end up writing a bug report on launchpad ;-).

Anyway, it might even have helped if gstreamer printed a proper error message (like "no sink found") instead of trying to use the jack sink, which is probably the least likely to exist. I don't know where's the best place of doing it, but somehow it should be guaranteed that there is at least one sink present when gstreamer is installed.

On Tue, Sep 03, 2013 at 10:37:23PM -0000, Rüdiger Kupper wrote:
> Hm, to my knowledge Lubuntu does not come with pulseaudio nor gstreamer. The standard install relies on audio applications that use plain ALSA. Try installing from a Lubuntu live CD.
> It's certainly hard to choose which (meta-)package should pull in gstreamer1.0-alsa. But some package should include it, otherwise Lubuntu users will end up without it and have the problems described above. It's the link between ALSA and gstreamer, so it could come with one of the packages that deliver ALSA or gstreamer. There's probably no perfect answer here. It could just be included in the standard Lubuntu install, but the Lubuntu people opt for simplicity and use direct ALSA.
>
> However, a typical scenario is as follows:
> You install Lubuntu from a Live CD. You find a selection of slim audio software like audacious. However, you miss your rhythmbox/banshee/whatever. You install rhythmbox/banshee/whatever. It does not work, because there is no gstreamer. You google a bit and learn that the gstreamer plugins come with ubuntu-restricted-extras. You install it, but your rhythmbox/banshee/whatever still does not work, because there is no ALSA sink. You google a bit more but find no answer. You end up writing a bug report on launchpad ;-).
>
> Anyway, it might even have helped if gstreamer printed a proper error
> message (like "no sink found") instead of trying to use the jack sink,
> which is probably the least likely to exist. I don't know where's the
> best place of doing it, but somehow it should be guaranteed that there
> is at least one sink present when gstreamer is installed.

There is at least one sink present (the jack one). Banshee depends on
gstreamer1.0-pulseaudio | gstreamer1.0-audiosink, and the latter package is a
virtual package that can be satisfied by any audio sink. In addition, it
recommends gstreamer1.0-pulseaudio, so it should be installed by default (but
will work even if you tell apt not to install gstreamer1.0-pulseaudio, but in
that case you're responsible for choosing another audiosink).

The issue here is that gstreamer1.0-pulseaudio is also useless because you don't
use pulseaudio.

Since this issue is more specific to Lubuntu installations, I'd be tempted to
slap gstreamer1.0-alsa onto lubuntu-desktop, but it looks like none of the
default media players even use gstreamer. I'll stick lubuntu-meta onto this bug
anyway, hopefully someone more acquianted with lubuntu would be able to come up
with a better solution.

  affects ubuntu/lubuntu-meta

--
Kind regards,
Loong Jin

nope. still getting this. with a bunch of apps. try a new .asoundrc first. then theres a setting but I forget the file that asks which sink to use. default is pulse before anything else. change it.

try this.

The attachment "alsa config w software pre-amp tweak" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in lubuntu-meta (Ubuntu):
status: New → Confirmed
gordon-z (gordon-z) wrote :

This is still a problem in Lubuntu 16.04. gstreamer1.0-pulseaudio is installed by default (presumably following Ubuntu), gstreamer1.0-alsa is not.

'sudo apt install gstreamer1.0-alsa' fixes the problem. Gstreamer apps such as banshee now output audio instead of silence.

I will file a bug against lubuntu-desktop and reference this bug.

summary: - Without pulseaudio, banshee and rhythmbox report "jack server is not
- running or cannot be started" and do not play
+ Lubuntu: banshee, rhythmbox, etc cannot play audio without pulseaudio or
+ gstreamer1.0-alsa
gordon-z (gordon-z) wrote :

Never mind, the bug is referenced in lubuntu-meta, I will try to get some attention on it via forums, etc. This is pretty nasty for anyone who wants to use GStreamer apps in Lubuntu.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers