Application Launch Bar in lxpanel refers to wrong browser in PPC

Bug #938470 reported by Walter Lapchynski
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
lubuntu-default-settings (Ubuntu)
Fix Released
Undecided
Julien Lavergne

Bug Description

fresh install of Lubuntu Precise daily-live 20120221
12" 1.5GHz PowerBook G4 PPC
lxpanel 0.5.8+git20120212-0ubuntu1
lubuntu-default-settings 0.24

in Application Launch Bar where there should be an icon for pcmanfm and chromium there is only a "missing location" icon for the latter. clicking on it doesn't result on a browser being loaded so the problem is not the icon itself.

i see 3 potential panel profiles in /usr/share/lxpanel/profile and they all reference different browsers:

1. default
uses lxde-x-www-browser.desktop which doesn't exist

2. Lubuntu
uses chromium-browser.desktop which doesn't exist because there is no PPC version

3. two_panel
which is obviously not the default but uses the CORRECT firefox.desktop

the middle one seems to be the one in use in the default location of ~/.config/lxpanel/Lubuntu/panels/panel
indeed if chromium-browser.desktop is replaced here with firefox.desktop and lxpanelctl restart is performed, we have a functional firefox browser icon again.

as this is ppc specific, the installer should check the arch and change the value appropriately.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: lubuntu-default-settings 0.24
ProcVersionSignature: Ubuntu 3.2.0-17.26-powerpc 3.2.6
Uname: Linux 3.2.0-17-powerpc ppc
ApportVersion: 1.92-0ubuntu1
Architecture: powerpc
Date: Tue Feb 21 23:30:39 2012
InstallationMedia: Lubuntu 12.04 "Precise Pangolin" - Alpha powerpc (20120221)
PackageArchitecture: all
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: lubuntu-default-settings
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
Walter Lapchynski (wxl) wrote :
Revision history for this message
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/938470

tags: added: iso-testing
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in lubuntu-default-settings (Ubuntu):
status: New → Confirmed
Julien Lavergne (gilir)
Changed in lubuntu-default-settings (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Julien Lavergne (gilir)
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lubuntu-default-settings - 0.30

---------------
lubuntu-default-settings (0.30) raring; urgency=low

  * etc/xdg/lubuntu/lxterminal
   - Add a custom configuration file for lxterminal.
   - Use Ubuntu font in lxterminal.
  * usr/bin/startlubuntu*
   - Install the lxterminal configuration file.
   - Workaround ssh agent not autostarted properly.
  * usr/share/lubuntu/openbox/rc.xml
   - Add shortcuts for windows tiling (SuperKey + the direction).
   - Set drawContents to "no" on resize, to reduce the use of resize.
  * usr/share/lubuntu/openbox/menu.xml
   - Use gnome-disks for Disk utility item.
   - Remove osmo from the menu, since it's not in the default installation.
     Thanks karl anliot for the notice. (LP: #1035780)
  * etc/xdg/lubuntu/menus/lxgames-applications.menu :
   - Add a specific menu structure for a games session.
  * usr/bin/startlubuntu-lxgames :
   - Add a new script to start a games session, with a specific menu structure.
  * usr/share/xsessions/lxgames.desktop :
   - Add a new session to start a games session.
  * debian/control:
   - Add new binaries, to configure default session on lightdm.
   - Update VCS fields.
  * Reorganize script in debian/ to handle the creation of the new
    default-session binaries.
  * debian/lubuntu-default-settings.install:
   - Keep all files in lubuntu-default-settings.
  * usr/share/applications/lubuntu-browser.desktop:
   - Add a .dektop file to be placed on the panel to replace chromium icon.
  * usr/share/lxpanel/profile/Lubuntu/panels/panel:
   - Use generic .desktop file to display an icon if another browser than
     chromium is available (LP: #938470)
 -- Julien Lavergne <email address hidden> Fri, 23 Nov 2012 23:42:34 +0100

Changed in lubuntu-default-settings (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers