There is NO Clipboard Manager in Lubuntu - a basic feature yet very important

Bug #926893 reported by amjjawad  on 2012-02-04
28
This bug affects 6 people
Affects Status Importance Assigned to Milestone
lubuntu-default-settings (Ubuntu)
Undecided
Unassigned
lxsession (Ubuntu)
Undecided
Julien Lavergne

Bug Description

Parcellite or any other Clipboard manager must be added to Lubuntu IMHO. This is a very basic feature, yet very important. Whenever I copy a text and try to paste it, I can't do that if the source file/text is gone. Say I want to copy a line from one file to another and I closed the first file so I can't paste unless I re-open the first file and keep it opened in order to finish the copy-paste task.
Please consider to add this on Lubuntu 12.04.

Thanks!

Related branches

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in lubuntu-default-settings (Ubuntu):
status: New → Confirmed
dajare (dajare) wrote :

This regularly drives me nuts, and I had been meaning to ask about it in the maling list or forum. Thanks for the "bug report".

This is an opinion and not a bug, status thefore changed.

Changed in lubuntu-default-settings (Ubuntu):
status: Confirmed → Opinion
amjjawad  (amjjawad) wrote :

Opinion, Bug, Wishlist ... it does not matter what you call it, what does really matter is someone has to highlight this issue :)

Same as LockScreen, such basic features will NEVER affect the performance IMHO. Lubuntu Performance, for me, comes first and I'd vote against ANYTHING that may affect that like making it slow, etc but such feature will NOT affect the overall performance but will make some users happy when they do a very simple task on their daily usage that is "Paste".

Thanks :)

Jared Norris (jarednorris) wrote :

Has anyone done any performance analysis of this in the past? If not can someone suggest what sort of test would be definitive to see if it does impact the performance of the system?

While I don't see this as an essential requirement it would be a "possibly nice to have". Until the facts are laid out there's no point contemplating it until proven it's suitable for inclusion in Lubuntu.

dajare (dajare) wrote :

Useful reference if this starts to develop into a "native" Lx-app. "C(lx)ipper", anyone? ;)

http://www.freedesktop.org/wiki/ClipboardManager

As mentioned on the mailing list, my own sense is that a system-wide clipboard (as opposed one with scope at app level) is sufficiently basic (e.g. ALL users of Macs and Windows have this) that it sneaks into the "essential" category for me. Your new Lubuntu user otherwise thinks their system is broken when "paste" does nothing, although they *know* they "copied" something.

Phill Whiteside (phillw) wrote :

As there is a thread on the Mailing List on this subject, why is there also a bug report? Not everyone gets bug reports automatically, everyone on the ML gets email.

Regards,

Phill.

amjjawad  (amjjawad) wrote :

Phill, I reported this simply because that is what Julien said once. Without this, the developers will not pay much attention and may forget. I still do have an email where Julien made it EXTRA CLEAR that this is the RIGHT thing to do. Now, you made me SO confused!

Thanks!

sjjh (simon-harhues) wrote :

I have to agree with dajare, a system wide clipboard manager is really a missing feature. I often get confused why I can't paste something I copied, forgetting that I closed the source. In my point of view installing one by default is a must have and not a nice to have.

Phill Whiteside (phillw) wrote :

We know things to do it. We dropped it because we did not use it. It seems it is wanted for new comers.

Regards,

Phill,

Julien Lavergne (gilir) on 2012-02-13
Changed in lubuntu-default-settings (Ubuntu):
status: Opinion → Won't Fix
Changed in lxsession (Ubuntu):
status: New → In Progress
assignee: nobody → Julien Lavergne (gilir)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lxsession - 0.4.6.1+git20120214-0ubuntu1

---------------
lxsession (0.4.6.1+git20120214-0ubuntu1) precise; urgency=low

  * New upstream snapshot :
   - Fix double launch at startup (LP: #873756)
   - Add a clipboard manager (LP: #926893)
  * debian/patches:
   - 02_gdm3.patch : Remove, merged upstream.
   - 04_fix-ltsp-shutdown-reboot.patch: Remove, merged upstream.
   - 06_lX11_liking.patch: Remove, merged upstream.
 -- Julien Lavergne <email address hidden> Tue, 14 Feb 2012 00:49:18 +0100

Changed in lxsession (Ubuntu):
status: In Progress → Fix Released
amjjawad  (amjjawad) wrote :

Thank you so much, Julien :D

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers