lxmenu is run everytime you use shortcut using super -key

Bug #890394 reported by Benny Hult
40
This bug affects 7 people
Affects Status Importance Assigned to Milestone
lubuntu-default-settings (Ubuntu)
Fix Released
Undecided
Alexander Andjelkovic

Bug Description

When you press Windows + E for example, it will popup lxmenu and then maybe pcmanfm.

Work-a-round for this problem:
from /usr/share/lubuntu/openbox/rc.xml (becouse it copies it to ~/.config/Openbox/lubuntu-rc.xml ) needs to be removed following lines to disable this behaviour.

    <keybind key="Super_L">
      <action name="Execute">
        <command>lxpanelctl menu</command>
      </action>
    </keybind>
    <keybind key="Super_R">
      <action name="Execute">
        <command>lxpanelctl menu</command>
      </action>
    </keybind>

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: lubuntu-desktop 0.28
ProcVersionSignature: Ubuntu 3.0.0-12.20-generic 3.0.4
Uname: Linux 3.0.0-12-generic i686
ApportVersion: 1.23-0ubuntu4
Architecture: i386
Date: Mon Nov 14 21:51:09 2011
InstallationMedia: Lubuntu 11.10 "Oneiric Ocelot" - Release i386 (20111012)
ProcEnviron:
 LC_TIME=en_US.UTF-8
 LC_CTYPE=fi_FI.UTF-8
 LANG=en_US.UTF-8
 SHELL=/bin/zsh
 LC_NUMERIC=fi_FI.UTF-8
SourcePackage: lubuntu-meta
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
Benny Hult (bioterror) wrote :
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in lubuntu-meta (Ubuntu):
status: New → Confirmed
Julien Lavergne (gilir)
affects: lubuntu-meta (Ubuntu) → lubuntu-default-settings (Ubuntu)
Revision history for this message
amjjawad  (amjjawad) wrote :

Same here!

Changed in lubuntu-default-settings (Ubuntu):
assignee: nobody → Alexander Andjelkovic (frankbooth)
status: Confirmed → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lubuntu-default-settings - 0.24

---------------
lubuntu-default-settings (0.24) precise; urgency=low

  [ Julien Lavergne ]
  * usr/share/lubuntu/openbox/rc.xml
   - Remove workaround for lxpanel run dialog, now it's fixed in lxpanel.
   - Revert maximised windows by default, need more integration (LP: #926788)
  * debian/control:
   - Add a recommend for xscreensaver, for the locking shortcut (LP: #923001)
  * usr/share/lxpanel/profile/Lubuntu/panels/panel:
   - Set the color font of the panel to white to match the new theme.

  [ Colin Watson ]
  * Use maintscript support in dh_installdeb rather than writing out
    dpkg-maintscript-helper commands by hand. We now simply Pre-Depend on a
    new enough version of dpkg rather than using 'dpkg-maintscript-helper
    supports' guards, leading to more predictable behaviour on upgrades.
    (LP: #932209)

  [ Alexander Andjelkovic ]
  * Fixed super-keys were conflicting with other keybinds making them useless.
    (LP: #890394)
 -- Julien Lavergne <email address hidden> Sun, 19 Feb 2012 14:49:00 +0100

Changed in lubuntu-default-settings (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers