Lubuntu 18.04 mistakenly sets the default lock problem to lxlock instead of light-locker

Bug #1812594 reported by Chris Rainey on 2019-01-20
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
lubuntu-default-settings (Ubuntu)
Medium
Unassigned
Bionic
Medium
apt-ghetto

Bug Description

[Summary]

Instead to light-locker-command, the keyboard shortcut to lock the screen is bound to lxlock. The problem is, that lxlock is not included in the iso of the first two point releases (18.04 and 18.04.1) and therefore, the shortcut does not work.
The ability to lock the screen is a basic security feature and should work as expected, even with the provided shortcut.

[Test Case]

Steps to reproduce
------------------

1. Boot Lubuntu 18.04 (installed from an older iso, not 18.04.2)
2. Login
3. Delete ~/.config/lxsession/Lubuntu/desktop.conf
4. Logout
5. Login
6. Press CTRL-ALT-L

Expected behaviour
------------------

The desktop session is locked and requires the password to unlock.

Current behaviour
-----------------

Nothing happens.

[Regression Potential]

If the command in the Exec line does not exist, nothing is executed, so the behaviour does not change. Users with lxlock installed, won't notice any change in the behaviour.
lxlock is a shell script, which calls light-locker-command (see: https://github.com/lxde/lxsession/blob/master/lxlock/lxlock#L27), so the regression potential is very, very small.

[Other Info]

Lubuntu uses another desktop environment from version 18.10 onwards. The only version, which contains the patched file is 18.04. The Lubuntu Team does not support Xenial anymore (16.04 has reached its end of life after 3 years of community support).

-------------------------------------------------------------------------

[Previous Description]

Lubuntu 18.04 lxsession defines `lxlock` as the default for "lock_manager/command" which lxhotkey calls via `lxsession-default lock` when Ctrl-Alt-L is pressed. This should be changed in /etc/xdg/lxsession/Lubuntu/desktop.conf to `light-locker`.

Chris Rainey (ckrzen) wrote :
Walter Lapchynski (wxl) on 2019-07-14
summary: - lubuntu-desktop needs to depend on lxlock
+ Lubuntu 18.04 mistakenly sets the default lock problem to lxlock instead
+ of light-locker
affects: lubuntu-meta (Ubuntu) → lubuntu-default-settings (Ubuntu)
Changed in lubuntu-default-settings (Ubuntu):
importance: Undecided → Low
status: New → Triaged
Walter Lapchynski (wxl) on 2019-07-14
description: updated
apt-ghetto (apt-ghetto) on 2019-07-16
Changed in lubuntu-default-settings (Ubuntu):
assignee: nobody → apt-ghetto (apt-ghetto)
status: Triaged → In Progress
apt-ghetto (apt-ghetto) on 2019-07-28
description: updated
Simon Quigley (tsimonq2) wrote :

Uploaded to the queue.

Changed in lubuntu-default-settings (Ubuntu):
status: In Progress → Fix Committed
importance: Low → Medium
status: Fix Committed → Invalid
assignee: apt-ghetto (apt-ghetto) → nobody
Changed in lubuntu-default-settings (Ubuntu Bionic):
assignee: nobody → apt-ghetto (apt-ghetto)
importance: Undecided → Medium
status: New → In Progress
apt-ghetto (apt-ghetto) wrote :

Hello Chris, or anyone else affected,

Accepted lubuntu-default-settings into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/lubuntu-default-settings/0.54.3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in lubuntu-default-settings (Ubuntu Bionic):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-bionic
Walter Lapchynski (wxl) wrote :

I have tested 0.54.3 on a fully updated Bionic system and following the testcase, I was able to lock the screen successfully with CTRL-ALT-L. This was equivalent to running `light-locker-command -l`.

tags: added: verification-done-bionic
removed: verification-needed-bionic
Chris Guiver (guiverc) wrote :

Virtual box VM created on 19.10 host (sony vaiocrap)

Lubuntu 18.04.1 (amd64) installed [on VM], reboot.
Login
`rm ~/.config/lxsession/Lubuntu/desktop.conf`
`file ~/.config/lxsession/Lubuntu/desktop.conf` - reports "No such file or directory)
Logout
Login
`file ~/.config/lxsession/Lubuntu/desktop.conf` - reports ASCII text

CTRL+ALT+L does NOT WORK

The above has been tried many times. From my reading of testing steps I could use 18.04.1 ISO, since I already had it I used that.

Walter Lapchynski (wxl) wrote :

Chris, is that a fully updated Bionic?

Chris Guiver (guiverc) wrote :

Sorry I hadn't noticed your comment here Walter.
No, I was afraid it'd cause the reason the 18.04.2 couldn't be used be void, and as updating wasn't specifically mentioned I didn't fully update! (yeah I know this mentally created confusion as to how this test was supposed to prove anything without updates, but I let that slide...).
Updating now as stated in irc.

Chris Guiver (guiverc) wrote :

full upgraded 18.04.1 installed VM on sonycrap, rebooted & logged in

neofetch now reports system as 18.04.2

`file ~/.config/lxsession/Lubuntu/desktop.conf` reports ASCII text
`rm ~/.config/lxsession/Lubuntu/desktop.conf`
`file ~/.config/lxsession/Lubuntu/desktop.conf` reports no such file ..
logout

login
`file ~/.config/lxsession/Lubuntu/desktop.conf` reports ASCII text again
ctrl+alt+L DOES NOTHING
`rm ~/.config/lxsession/Lubuntu/desktop.conf`
`file ~/.config/lxsession/Lubuntu/desktop.conf` reports no such file ..
logout

`file ~~/.config/lxsession/Lubuntu/desktop.conf` reports ASCII text :(
CTRL + ALT + L DOES NOTHING

NOTE:

`apt-cache policy lxlock` reports (typed in)
Installed: (none)
Candidate: 0.5.3-2ubuntu1

If I was supposed to install it, I didn't note it in instructions sorry.

Chris Guiver (guiverc) wrote :

`whereis lxlock` produces no results (ie. "lxlock: \n")

apt-ghetto (apt-ghetto) wrote :

Hi Chris Guiver,

Thank you for testing. I think, you are getting the results as described in "Current behaviour". And yes, you should not install "lxlock".

Please check the installed version of "lubuntu-default-settings" with `apt policy lubuntu-default-settings`.
If you have version 0.54.2, then enable the "-proposed" sources, and `sudo apt install lubuntu-default-settings`.
This should install version 0.54.3, with the fix.
Then you can execute the test case and should have the same result as in "Expected behaviour".

You can check also (different results for 0.54.2 and 0.54.3):
`grep lock /etc/xdg/lxsession/Lubuntu/desktop.conf`
`grep lock ~/.config/lxsession/Luubntu/desktop.conf`

Chris Guiver (guiverc) wrote :

You were spot on apt-ghetto.

`apt-cache policy` read 0.54.2 & no I didn't have -proposed enabled
I copied the two desktop.conf you mentioned so will look at that later..
I've added -proposed; `apt update; apt full-upgrade`
logout, login.
// GRRR (i logged out & logged in on real machine, not VM)
// clean up the mess i made...
apt-cache policy now reads 0.54.3; but i'll reboot VM before I continue

apt-cache policy reads 0.54.3 (bionic-proposed/universe) installed
0.54.2 (bionic/universe)

(no diff between desktop.conf's found in $HOME/.config/lxsession/Lubuntu/)
grep of $HOME version results in "lock manager/command=lxlock"
// please note I'm typing, and not copy/pasting..
diff of /etc/..desktop.conf shows diffference!
$diff desktop.conf-normal_etc_xdg_lxsession /etc/xdg/lxsession/Lubuntu/desktop.conf
> lock_manager/command=light-locker-command -l
>
$ grep lock /etc/xdg/lxsession/Lubuntu/desktop.conf
lock_manager/command=light-locker-command -l
logged out; logged back in..

rm ~/.config/lxsession/Lubuntu/desktop.conf
logout
login
file ~/.config/lxsession/Lubuntu/desktop.conf (ASCII text)

CTRL+ALT+L & screen is black....

move mouse & I'm at login/greeter
my usual password & i'm back at terminal

Results @wxl no doubt got... (finally)

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lubuntu-default-settings - 0.54.3

---------------
lubuntu-default-settings (0.54.3) bionic; urgency=medium

  * Set the default lock to light-locker-command instead of lxlock
    (LP: #1812594)

 -- apt-ghetto <email address hidden> Thu, 25 Jul 2019 10:21:00 +0200

Changed in lubuntu-default-settings (Ubuntu Bionic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for lubuntu-default-settings has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers