ubuntu-bug fails trying to open qupzilla browser

Bug #1786986 reported by Walter Lapchynski on 2018-08-14
20
This bug affects 2 people
Affects Status Importance Assigned to Milestone
lubuntu-default-settings (Ubuntu)
Medium
Simon Quigley

Bug Description

To replicate:

 1. Open a terminal
 2. Run `ubuntu-bug some-program`
 3. Hit S to send
 4. Hit 1 to open a browser

Expected response: open the browser (Falkon) to finish filing the report.

Actual response (example):
/usr/bin/xdg-open: 870: /usr/bin/xdg-open: qupzilla: not found
/usr/bin/xdg-open: 870: /usr/bin/xdg-open: qupzilla: not found
xdg-open: no method available for opening 'https://bugs.launchpad.net/ubuntu/+source/nm-tray/+filebug/c1a9fed0-9fe0-11e8-a586-0025b3df357a?'

Things to note:
 * Similar bug reported: 1769780
 * update-alternatives is correctly set to open falkon
 * LXQt session default apps is correctly set to open falkon
 * `xdg-query default {text/html,x-scheme-handler/http,x-scheme-handler/https}` all return firefox.desktop
 * changing the XDG Mime database to refer to /usr/share/applications/org.kde.falkon.desktop has no effect on xdg-open
 * running xdg-open on an html file complains about sensible-browser not finding qupzilla though it does ultimately work:
   /usr/bin/sensible-browser: 8: /usr/bin/sensible-browser: qupzilla: not found
 * running xdg-open on an http(s) URI complains about not finding qupzilla and ultimately fails:
   /usr/bin/xdg-open: 870: /usr/bin/xdg-open: qupzilla: not found
   /usr/bin/xdg-open: 870: /usr/bin/xdg-open: qupzilla: not found
   xdg-open: no method available for opening 'http://http.rip'

Workarounds:
 1. after step 3 above, hit C to cancel and instead click on the link
 2. replace firefox with org.kde.falkon in /etc/gnome/defaults.list but this does not fix the behavior of xdg-open

This was on 20180813 of the 18.10 Lubuntu daily, btw.

ProblemType: Bug
DistroRelease: Ubuntu 18.10
Package: lubuntu-default-settings 1.8
ProcVersionSignature: Ubuntu 4.17.0-6.7-generic 4.17.9
Uname: Linux 4.17.0-6-generic x86_64
ApportVersion: 2.20.10-0ubuntu7
Architecture: amd64
CurrentDesktop: LXQt
Date: Tue Aug 14 09:28:27 2018
InstallationDate: Installed on 2018-08-14 (0 days ago)
InstallationMedia: Lubuntu 18.10 "Cosmic Cuttlefish" - Alpha amd64 (20180813)
PackageArchitecture: all
SourcePackage: lubuntu-default-settings
UpgradeStatus: No upgrade log present (probably fresh install)

Walter Lapchynski (wxl) wrote :
Alf Gaida (agaida) wrote :

should be filed against xdg-open

Alf Gaida (agaida) wrote :

xdg-open:

    # if BROWSER variable is not set, check some well known browsers instead
    if [ x"$BROWSER" = x"" ]; then
        BROWSER=www-browser:links2:elinks:links:lynx:w3m
        if has_display; then
            BROWSER=x-www-browser:firefox:iceweasel:seamonkey:mozilla:epiphany:konqueror:chromium:chromium-browser:google-chrome:$BROWSER
        fi
    fi

Changed in lubuntu-default-settings (Ubuntu):
status: New → Confirmed
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1786986

tags: added: iso-testing
Walter Lapchynski (wxl) wrote :

Basically what xdg-open does with $BROWSER is to set it if and only if
it's unset. If it's set, it should be a colon separated list of
possibilities, starting with x-www-browser. Instead, in our case, it's
equal to qupzilla only. That said, something outside of xdg-open is
setting it to qupzilla, so it's not xdg-open.

It's also not falkon. I was thinking maybe there were some remaining
references left in the postinst to qupzilla, but it is not the case. If
BROWSER was unset, it would be set to x-www-browser and the postinst of
falkon does set it as x-www-browser, so we'd be done.

Unfortunately, it's already set. So maybe that's a bug against xdg-open
that it doesn't do anything if it's already set, but I don't think so.

That said, your hint was a good one, as it gets to the heart of the
problem (the value of BROWSER) but the solution is not obvious. We could
add a BROWSER setting to falkon's postinst but that would really be sort
of strange. None of firefox, chromium-browser, konqueror, epiphany or
w3m do this. I think it would be better if we find the cause and remove
it.

Simon Quigley (tsimonq2) on 2018-08-14
Changed in lubuntu-default-settings (Ubuntu):
assignee: nobody → Simon Quigley (tsimonq2)
importance: Undecided → Medium
Lugito (lugito) wrote :

This bug has been marked as fixed in the Git repository: https://phab.lubuntu.me/rDEFAULTSETTINGSdc68d9f740e6
The commit message is the following: We use Falkon now, not Qupzilla (LP: #1786986).

(Note: I am only a bot. If this message was received in error, please contact my owners on the Lubuntu Team.)

Changed in lubuntu-default-settings (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lubuntu-default-settings - 1.9

---------------
lubuntu-default-settings (1.9) cosmic; urgency=medium

  [ Simon Quigley ]
  * We use Falkon now, not Qupzilla (LP: #1786986).

  [ Walter Lapchynski ]
  * Set qterminal window size to upstream default. (LP: #1786978)

 -- Simon Quigley <email address hidden> Thu, 16 Aug 2018 13:20:33 -0500

Changed in lubuntu-default-settings (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers